Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

sparky update problem - The repository is no longer signed. Failed to fetch.

Started by jamoz, December 10, 2021, 09:35:07 AM

Previous topic - Next topic

jamoz

os version: 6.1
kernal: 5.10.0-9-amd64

from in the terminal i run:
sudo apt-get update
and i get this:


Hit:1 http://security.debian.org/debian-security bullseye-security/updates InRelease
Hit:2 http://deb.debian.org/debian bullseye InRelease                                                   
Hit:3 https://deb.opera.com/opera-stable stable InRelease                                               
Err:4 https://repo.sparkylinux.org unstable InRelease                                                       
  403  Forbidden [IP: 193.107.89.176 443]
Err:5 https://repo.sparkylinux.org core InRelease                           
  403  Forbidden [IP: 193.107.89.176 443]
Err:6 https://repo.sparkylinux.org potolo InRelease
  403  Forbidden [IP: 193.107.89.176 443]
Hit:7 http://deb-multimedia.org bullseye InRelease
Reading package lists... Done
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
E: The repository 'https://repo.sparkylinux.org unstable InRelease' is no longer signed.
E: Failed to fetch https://repo.sparkylinux.org/dists/unstable/InRelease  403  Forbidden [IP: 193.107.89.176 443]
E: Failed to fetch https://repo.sparkylinux.org/dists/core/InRelease  403  Forbidden [IP: 193.107.89.176 443]
E: The repository 'https://repo.sparkylinux.org core InRelease' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://repo.sparkylinux.org/dists/potolo/InRelease  403  Forbidden [IP: 193.107.89.176 443]
E: The repository 'https://repo.sparkylinux.org potolo InRelease' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.





pavroo

Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

AxL

Quote from: pavroo on December 10, 2021, 09:33:54 PM
[...] it was a temporary problem.

Why is access to the repository, through any browser prohibited ... ??   ???


A '403 Forbidden' warning appears as you can see in the image below:











Cheers!!   :)

pavroo

Due to serious problems on our server, some settings have been changed and security hardened.
You can still browse debs manually via a web browser on one of our mirrors:
http://us1.repo.sparkylinux.org/pool/main/
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

AxL

Quote from: pavroo on December 11, 2021, 02:28:00 PM
Due to serious problems on our server, some settings have been changed and security hardened.

You can still browse debs manually via a web browser on one of our mirrors:
http://us1.repo.sparkylinux.org/pool/main/

Ah, okay ;)

Thank you very much, for your quick response, and for the alternative solution.







Cheers!!!  :)

rakemup

I run Sparky Linux 6.2 on my desktop and Sparky 7 on my laptop.  Aptus stopped working on both.
  Any suggestions?
Thanks!

pavroo

Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

rakemup

What I did ---and the results ........

sparky-upgrade
[sudo] password for tac:
Debian server is on, proceed...
Sparky server is on, proceed...
Hit:1 http://dl.google.com/linux/earth/deb stable InRelease
Hit:2 http://deb.debian.org/debian bullseye InRelease                         
Hit:4 http://repository.spotify.com stable InRelease                         
Get:5 http://deb.debian.org/debian-security bullseye-security/updates InRelease [44.1 kB]
Get:6 http://deb.debian.org/debian-security bullseye-security/updates/main Sources [110 kB]
Get:7 http://deb.debian.org/debian-security bullseye-security/updates/main amd64 Packages [124 kB]
Get:8 http://deb.debian.org/debian-security bullseye-security/updates/main i386 Packages [124 kB]
Get:9 http://deb.debian.org/debian-security bullseye-security/updates/main Translation-en [79.1 kB]
Err:3 https://dl.bintray.com/etcher/debian stable InRelease                   
  502  Bad Gateway [IP: 35.161.19.108 443]
Hit:10 http://deb-multimedia.org bullseye InRelease                           
Hit:11 https://repo.sparkylinux.org unstable InRelease
Hit:12 https://repo.sparkylinux.org core InRelease
Get:13 https://repo.sparkylinux.org potolo InRelease [4,316 B]
Get:14 https://repo.sparkylinux.org potolo/main amd64 Packages [80.2 kB]
Fetched 565 kB in 3s (193 kB/s)   
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Failed to fetch https://deb.etcher.io/dists/stable/InRelease  502  Bad Gateway [IP: 35.161.19.108 443]
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  zlib1g zlib1g-dev
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 283 kB of archives.
After this operation, 3,072 B of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://deb.debian.org/debian-security bullseye-security/updates/main amd64 zlib1g-dev amd64 1:1.2.11.dfsg-2+deb11u1 [191 kB]
Get:2 http://deb.debian.org/debian-security bullseye-security/updates/main amd64 zlib1g amd64 1:1.2.11.dfsg-2+deb11u1 [91.4 kB]
Fetched 283 kB in 0s (604 kB/s) 
Reading changelogs... Done
(Reading database ... 202698 files and directories currently installed.)
Preparing to unpack .../zlib1g-dev_1%3a1.2.11.dfsg-2+deb11u1_amd64.deb ...
Unpacking zlib1g-dev:amd64 (1:1.2.11.dfsg-2+deb11u1) over (1:1.2.11.dfsg-2) ...
Preparing to unpack .../zlib1g_1%3a1.2.11.dfsg-2+deb11u1_amd64.deb ...
Unpacking zlib1g:amd64 (1:1.2.11.dfsg-2+deb11u1) over (1:1.2.11.dfsg-2) ...
Setting up zlib1g:amd64 (1:1.2.11.dfsg-2+deb11u1) ...
Setting up zlib1g-dev:amd64 (1:1.2.11.dfsg-2+deb11u1) ...
Processing triggers for man-db (2.9.4-2) ...
Processing triggers for libc-bin (2.31-13+deb11u3) ...
tac@terry-hpdesktop460p2xx:~$ sudo apt update
Hit:1 http://dl.google.com/linux/earth/deb stable InRelease
Hit:2 http://deb.debian.org/debian bullseye InRelease                         
Hit:4 http://deb.debian.org/debian-security bullseye-security/updates InRelease
Hit:5 http://repository.spotify.com stable InRelease
Err:3 https://dl.bintray.com/etcher/debian stable InRelease                   
  502  Bad Gateway [IP: 35.83.99.37 443]
Hit:6 http://deb-multimedia.org bullseye InRelease                           
Hit:7 https://repo.sparkylinux.org unstable InRelease
Hit:8 https://repo.sparkylinux.org core InRelease
Hit:9 https://repo.sparkylinux.org potolo InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
All packages are up to date.
W: Failed to fetch https://deb.etcher.io/dists/stable/InRelease  502  Bad Gateway [IP: 35.83.99.37 443]
W: Some index files failed to download. They have been ignored, or old ones used instead.
tac@terry-hpdesktop460p2xx:~$ sudo apt-key del C40956B8
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
OK
tac@terry-hpdesktop460p2xx:~$ sudo apt-key del D117204E
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
OK
tac@terry-hpdesktop460p2xx:~$ sudo apt update
Hit:1 http://deb.debian.org/debian bullseye InRelease
Hit:2 http://dl.google.com/linux/earth/deb stable InRelease                   
Hit:4 http://deb.debian.org/debian-security bullseye-security/updates InRelease
Hit:5 http://deb-multimedia.org bullseye InRelease                           
Hit:6 http://repository.spotify.com stable InRelease                         
Hit:7 https://repo.sparkylinux.org unstable InRelease                         
Err:3 https://dl.bintray.com/etcher/debian stable InRelease       
  502  Bad Gateway [IP: 35.83.99.37 443]
Hit:8 https://repo.sparkylinux.org core InRelease
Hit:9 https://repo.sparkylinux.org potolo InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
All packages are up to date.
W: Failed to fetch https://deb.etcher.io/dists/stable/InRelease  502  Bad Gateway [IP: 35.83.99.37 443]
W: Some index files failed to download. They have been ignored, or old ones used instead.

and
### sparky core repository is used by all sparky editions
deb [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ core main
deb-src [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ core main

### sparky potolo repository
deb [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ potolo main
deb-src [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ potolo main





pavroo

All your repos, excluding etcher are fine.
The etcher repo fails so temporary disable it waiting for fixing.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

rakemup

What if I comment-out (balena-etcher.list) in my /etc/apt/sources.list.d/?  Will that harm my Sparky?

That's the only place I see a reference to etcher


pavroo

No, it will not.
What you need is Debian and Sparky repos.
Rest of them is your choice.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

rakemup

Thanks for the assist!

My repos look good now and I found and purged a program named "balena-etcher-electron". I've re-installed aptus, but still can't get it to work.

Thanks again for your suggestions!

 


rakemup

aptus will not run from the menu or the command line.
Sparky 6.2

any thoughts?

pavroo

Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

rakemup

this is the reply,,,,

Overriding existing handler for signal 10. Set JSC_SIGNAL_FOR_GC if you want WebKit to use a different signal

View the most recent posts on the forum