Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Recent Posts

Pages: [1] 2 3 ... 10
Moved it to Sparky repos, simply install it via apt or synaptic.
Barry Block's Hiero PPA is for Ubuntu and not for Debian. Adding it to Debian based distro is not recommended and not supported. I'm locking  this thread now.
Hello guys, I'm trying to install Barry Block's Hiero outliner. This is available from a PPA.

When I ran sudo add-apt-repository, I got:

sudo add-apt-repository ppa:bwb-s/hiero
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 95, in <module>
    sp = SoftwareProperties(options=options)
  File "/usr/lib/python3/dist-packages/softwareproperties/", line 109, in __init__
  File "/usr/lib/python3/dist-packages/softwareproperties/", line 599, in reload_sourceslist
  File "/usr/lib/python3/dist-packages/aptsources/", line 93, in get_sources
    (, self.codename))
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Sparky/sid

I assume this means: we can't identify what sort of setup you'd need for that distro. Is there a workaround? Hiero is a pretty simple piece of software and I assume that its requirements are pretty standard.

Best, NP
Sparky applications / Re: <SOLVED>Problem when install desktop via APTus
« Last post by xingjiapeng on October 29, 2020, 02:15:39 pm »
solved, just go to settings -> appearance and choose Sparky theme, the theme will not automatic switch if I change it before and reinstall mate desktop.
(But the Sparky6 window manager theme is still disable...)
Hardware / Re: Cannot install RTL8188FU Wifi Driver
« Last post by bin on October 28, 2020, 07:09:22 am »
As it says "command failed your kernel headers for kernel 4.19.0-9-amd64 cannot be found " it looks like you needed to install the relevant linux headers package.

Code: [Select]
sudo apt install linux-headers-4.19.0-9-amd64
If it comes back with other errors look for the packages it says are missing - possibly cmake.

Looking at the ppa he has used ndiswrapper which allows linux to make use of windows drivers.

Alternatively you could hurl the Realtek dongle out of the window and fit a PCI wifi card???
Hardware / Cannot install RTL8188FU Wifi Driver
« Last post by wantit on October 28, 2020, 05:06:25 am »
I have installed SparkyLinux (sparkylinux-5.12-x86_64-xfce) on a Lenovo M55 PC. For Wifi I am using a USB dongle that uses the Realtek rtl8188fu driver. However the OS does not recognize this device. It does not have a Wifi driver for it. I tried using the instruction from the following webpage :- . First I tried doing it using the Manual commands but the 'sudo dkms build rtl8188fu/1.0 ' command failed, with :- your kernel headers for kernel 4.19.0-9-amd64 cannot be found at /lib/modules/4.19.0-9-amd64/build or  /lib/modules/4.19.0-9-amd64/source . I then tried to add it from a repository as shown in the webpage. I could not add the ppa:kelebek333/kabosuz repository. However I then install Linux Lite ( linux-lite-5.0-64bit ) and once again the Wifi driver rtl8188fu was missing. I then added the repository as called out in the above webpage and installed the driver without any problems. I am now using Linux Lite, but would like to go back to SparkyLinux if I can install the Realtek rtl8188fu Wifi driver. Dows anybody have any ideas?
System upgrading / Re: nvidia module issues
« Last post by paxmark1 on October 27, 2020, 10:05:11 pm »

NVIDIA sent out an advisory to their customers on Friday that they don't expect to have Linux 5.9 kernel support in their proprietary graphics driver until mid-November, or about one month after the kernel was released as stable.
System upgrading / Re: nvidia module issues
« Last post by 151tom on October 26, 2020, 08:05:11 pm »
I have several desktops with NVIDIA C61 [GeForce 6150SE nForce 430] integrated graphics adapters and very few if any Linux distros work successfully without crashing although the opensource nouveau graphics driver works most of the time.

The NVIDIA proprietary driver that is needed seems to be unavailable these days and when available the NVIDIA proprietary driver seems to have dependencies issues / problems with the newer kernels and just will not work. :(

The only two Linux distros that seem to work successfully is Antix Linux and SparkyLinux LXQT. 8) ; :)

I'm glad that these two Linux distros work because I'm old and poor and can't afford to buy a new high powered super computer however what I have works good enough for what I use my computer for.  8) :)
Suggestions / Re: Not so Common Desktop Environment (NsCDE)
« Last post by dksolarium on October 26, 2020, 07:02:31 pm »
Done, built and uploaded to repos:

thank you Pavroo ^_^
Sparky applications / Re: Problem when install desktop via APTus
« Last post by xingjiapeng on October 25, 2020, 07:33:38 am »
I guess it is a problem about NEWCONFIG in sparky-desktop.
I found the setting files are cpoied, but the mate desktop didn't read them for some reason...
Pages: [1] 2 3 ... 10