Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Virtualbox Installation Issue

Started by pnbalaji1974, December 21, 2020, 06:53:11 PM

Previous topic - Next topic

pnbalaji1974

Hi,

I switched over from Manjaro to Sparky Linux couple of weeks ago and it has been a great experience sine I switched. Everything seems to be working fine.

However, I am trying to install virtualbox now and I am having problems installing it. Can some one help?

I have added the below line in /etc/apt/sources.list


deb http://download.virtualbox.org/virtualbox/debian buster contrib


I ran sudo apt update and sudo apt install virtualbox-6.1 and I get the below errors.


[imac111]:~$ sudo apt install virtualbox-6.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libqt5opengl5 : Depends: qtbase-abi-5-11-3
E: Unable to correct problems, you have held broken packages.



I have tried the command "sudo apt --fix-broken install" and did not do anything.


[imac111]:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.



Below is the output of inxi.


[imac111]:~$ inxi -brmnP
System:    Host: imac111 Kernel: 5.9.0-4-amd64 x86_64 bits: 64 Desktop: MATE 1.24.1 Distro: SparkyLinux 6 (Po-Tolo)
Machine:   Type: Desktop System: Apple product: iMac11,1 v: 1.0 serial: <root required>
           Mobo: Apple model: Mac-F2268DAE serial: <root required> UEFI: Apple v: 63.0.0.0.0 date: 06/14/2019
Memory:    RAM: total: 11.69 GiB used: 1.80 GiB (15.4%)
           RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:       Quad Core: Intel Core i7 860 type: MT MCP speed: 1197 MHz min/max: 1197/2794 MHz
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Madison [Mobility Radeon HD 5730 / 6570M] driver: radeon v: kernel
           Display: x11 server: X.Org 1.20.10 driver: ati,radeon unloaded: fbdev,modesetting,vesa resolution: 2560x1440~60Hz
           OpenGL: renderer: AMD REDWOOD (DRM 2.50.0 / 5.9.0-4-amd64 LLVM 11.0.0) v: 3.3 Mesa 20.2.4
Network:   Device-1: Broadcom and subsidiaries NetXtreme BCM5764M Gigabit Ethernet PCIe driver: tg3
           IF: eth0 state: down mac: 58:b0:35:ee:54:13
           Device-2: Qualcomm Atheros AR928X Wireless Network Adapter driver: ath9k
           IF: wlan0 state: up mac: 7c:6d:62:79:2b:e7
Drives:    Local Storage: total: 2.89 TiB used: 1.70 TiB (58.7%)
Partition: ID-1: / size: 47.04 GiB used: 11.08 GiB (23.5%) fs: ext4 dev: /dev/sdb2
           ID-2: /home size: 104.41 GiB used: 70.76 GiB (67.8%) fs: ext4 dev: /dev/sdb4
           ID-3: swap-1 size: 11.99 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb3
Repos:     Active apt repos in: /etc/apt/sources.list
           1: deb http://ftp.us.debian.org/debian/ stable main contrib
           2: deb http://security.debian.org/ stable/updates main contrib
           3: deb http://download.virtualbox.org/virtualbox/debian buster contrib
           No active apt repos in: /etc/apt/sources.list.d/google.list
           Active apt repos in: /etc/apt/sources.list.d/insync.list
           1: deb http://apt.insync.io/ubuntu/ xenial non-free contrib
           No active apt repos in: /etc/apt/sources.list.d/liquorix.list
           No active apt repos in: /etc/apt/sources.list.d/pipelight.list
           No active apt repos in: /etc/apt/sources.list.d/playonlinux.list
           No active apt repos in: /etc/apt/sources.list.d/sid.list
           Active apt repos in: /etc/apt/sources.list.d/sparky-unstable.list
           1: deb https://repo.sparkylinux.org/ unstable main
           2: deb-src https://repo.sparkylinux.org/ unstable main
           Active apt repos in: /etc/apt/sources.list.d/sparky.list
           1: deb https://repo.sparkylinux.org/ core main
           2: deb-src https://repo.sparkylinux.org/ core main
           3: deb https://repo.sparkylinux.org/ potolo main
           4: deb-src https://repo.sparkylinux.org/ potolo main
           No active apt repos in: /etc/apt/sources.list.d/virtualbox.list
           Active apt repos in: /etc/apt/sources.list.d/vscode.list
           1: deb [arch=amd64] http://packages.microsoft.com/repos/vscode/ stable main
           No active apt repos in: /etc/apt/sources.list.d/wine-staging.list
Info:      Processes: 251 Uptime: 26m Shell: bash inxi: 3.0.32



I did not find any package as qtbase-abi-5-11-3 in the repositories. Can someone help?

Thanks,
Balaji.

pavroo

Hi

As I can see, you are running Sparky 6, so:
1. The deb package from the VirtualBox service is not installable on Debian Bullseye/Sparky 6, so
2. Disable (or remove) VirtualBox repositories, refresh pakage list and install Virtualbox from Sparky repos:
sudo apt update
sudo apt install virtualbox virtualbox-qt
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

paxmark1

#2
What pavroo says.   For the stable installs, I always went with the Ubuntu version (bionic these days)  for years starting in 2016 in Debian testing. 

deb http://download.virtualbox.org/virtualbox/debian bionic contrib        #####    For Stable     -  works for me   

But since you are in Rolling, try it the Sparky way.   Appreciate the usage of inxi. 

edited,  the "deb"   gets seperated from the rest of the line from /etc/apt/sources/ 




Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

pnbalaji1974

Thanks for your response. I have updated the sources.list file and ran a sudo apt update and then tried to install virtualbox. However, I am getting the below error message.


[imac111]:~$ sudo apt install virtualbox virtualbox-qt
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libqt5opengl5 : Depends: qtbase-abi-5-11-3
virtualbox : Depends: libgsoap-2.8.104 but it is not installable
              Depends: liblzf1 (>= 1.5) but it is not installable
E: Unable to correct problems, you have held broken packages.


I tried "sudo apt install -f" and "sudo apt install --fix-broken" and these commands are not fixing the issue. I tried with Synaptic Package Manager also and that too did not work.

Can you please help?

pavroo

The package "qtbase-abi-5-11-3" doesn't exist anyway, so show me output of:
cat /etc/apt/sources.list
all files content located in the directory:
/etc/apt/soureces.list.d/
and:
sudo apt update
and:
sudo apt install -s --no-install-recommends virtualbox virtualbox-qt
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

pnbalaji1974

Below is the output of /etc/apt/sources.list


# Debian packages for stable
deb http://ftp.us.debian.org/debian/ stable main contrib
# Uncomment the deb-src line if you want 'apt-get source'
# to work with most packages.
# deb-src http://ftp.us.debian.org/debian/ stable main contrib

# Security updates for stable
deb http://security.debian.org/ stable/updates main contrib
#deb http://download.virtualbox.org/virtualbox/debian buster contrib


List of files in /etc/apt/sources.list.d


total 52
drwxr-xr-x 2 root      root      4096 Dec 21 14:06 .
drwxr-xr-x 8 root      root      4096 Dec 23 11:10 ..
-rw-r--r-- 1 balashaki autologin  336 Dec 19 10:29 google.list
-rw-r--r-- 1 root      root        59 Dec 19 10:29 insync.list
-rw-r--r-- 1 user1 autologin   57 Dec 19 10:29 liquorix.list
-rw-r--r-- 1 user1 autologin   56 Dec 19 10:29 pipelight.list
-rw-r--r-- 1 root      root        48 Dec 19 10:29 playonlinux.list
-rw-r--r-- 1 root      root       195 Dec 19 10:29 sid.list
-rw-r--r-- 1 root      root       292 Dec 19 10:29 sparky.list
-rw-r--r-- 1 root      root       129 Dec 21 14:06 sparky-unstable.list
-rw-r--r-- 1 root      root        73 Dec 19 10:29 virtualbox.list
-rw-r--r-- 1 root      root       200 Dec 19 10:29 vscode.list
-rw-r--r-- 1 root      root        56 Dec 19 10:29 wine-staging.list


Output of sudo apt update is below.


Hit:1 http://ftp.us.debian.org/debian stable InRelease
Hit:2 http://packages.microsoft.com/repos/vscode stable InRelease                                           
Get:3 http://security.debian.org stable/updates InRelease [65.4 kB]                                         
Hit:4 http://apt.insync.io/ubuntu xenial InRelease                                       
Hit:5 https://repo.sparkylinux.org unstable InRelease       
Hit:6 https://repo.sparkylinux.org core InRelease
Hit:7 https://repo.sparkylinux.org potolo InRelease
Fetched 65.4 kB in 2s (38.2 kB/s)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.


Output of virtualbox install.


Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libqt5opengl5 : Depends: qtbase-abi-5-11-3
virtualbox : Depends: libgsoap-2.8.104 but it is not installable
              Depends: liblzf1 (>= 1.5) but it is not installable
E: Unable to correct problems, you have held broken packages.


Let me know if you need any other information.

pavroo

You have mixed repos, it is bad idea.
I guess you installed Debian stable, then added Sparky testing repos, right?
If so, change Sparky repos from potolo (testing) to nibiru (stable) in the file:
/etc/apt/sources.list.d/sparky.list
https://wiki.sparkylinux.org/doku.php/repository_stable
then refresh package list again and install virtualbox for stable:
sudo apt update
sudo apt install virtualbox-6.1
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

pnbalaji1974

I did all the things you have mentioned. However, I am still having problems with broken packages. Below is the output of virtualbox installation.


balashaki@balaji-imac111:~/Downloads$ sudo apt install virtualbox-6.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libqt5opengl5 : Depends: qtbase-abi-5-11-3
E: Unable to correct problems, you have held broken packages.


Do I have to cleanup any other files under /etc/apt/sources.list.d folder?

pavroo

As I said before, the qtbase-abi-5-11-3 package doesn't exist, it's a virtual package provided by other one.
https://packages.debian.org/en/buster/qtbase-abi-5-11-3
Make sure you have libqt5core5a package installed.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

pnbalaji1974

When I tried to download and install libqt5core5a with dpkg, I am getting the below error message.


[imac111]:~/Downloads$ sudo dpkg -i libqt5core5a_5.11.3+dfsg1-1+deb10u4_amd64.deb
(Reading database ... 277998 files and directories currently installed.)
Preparing to unpack libqt5core5a_5.11.3+dfsg1-1+deb10u4_amd64.deb ...
Unpacking libqt5core5a:amd64 (5.11.3+dfsg1-1+deb10u4) over (5.11.3+dfsg1-1+deb10u4) ...
dpkg: dependency problems prevent configuration of libqt5core5a:amd64:
[glow=red,2,300][b] libqt5core5a:amd64 depends on libdouble-conversion1 (>= 2.0.0); however:
  Package libdouble-conversion1 is not installed.
[/b][/glow]
dpkg: error processing package libqt5core5a:amd64 (--install):
dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.31-5) ...
Errors were encountered while processing:
libqt5core5a:amd64


When I tried to install libdouble-conversion1, I got some error messages and it has recommended me to run "sudo apt --fix-broken install". I ran it and then executed "sudo apt autoremove" and then I was able to install libqt5core5a. After this, I tried to install virtualbox with the command "sudo apt install virtualbox-6.1" and I am getting the below error message.


[imac111]:~/Downloads$ sudo apt install virtualbox-6.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libxkbcommon-x11-0 : Depends: libxkbcommon0 (= 0.8.2-1) but 1.0.3-2 is to be installed
E: Unable to correct problems, you have held broken packages.


If I run the command "sudo apt install libxkbcommon0", I am getting the below message.


[imac111]:~/Downloads$ sudo apt install libxkbcommon0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libxkbcommon0 is already the newest version (1.0.3-2).
0 upgraded, 0 newly installed, 0 to remove and 15 not upgraded.


What could be the issue?

Thanks,
Balaji.

pavroo

Can you explain me what version of Sparky or Debian you have been installed?

Depends: libxkbcommon0 (= 0.8.2-1) but 1.0.3-2 is to be installed
It says that you have Debian Bullseye but you are using Debian stable Buster repos (and Sparky testing repo before).
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

pnbalaji1974

How do I find out what version of sparky linux I have installed? Running "uname -a" shows the below results.


[imac111]:~/Downloads$ uname -a
Linux imac111 5.9.0-4-amd64 #1 SMP Debian 5.9.11-1 (2020-11-27) x86_64 GNU/Linux


Running inxi -brmnP shows the below results for system and repos.


System:    Host: imac111 Kernel: 5.9.0-4-amd64 x86_64 bits: 64 Desktop: MATE 1.24.1 Distro: SparkyLinux 6 (Po-Tolo)

Repos:     Active apt repos in: /etc/apt/sources.list
           1: deb http://ftp.us.debian.org/debian/ stable main contrib
           2: deb http://security.debian.org/ stable/updates main contrib
           No active apt repos in: /etc/apt/sources.list.d/google.list
           Active apt repos in: /etc/apt/sources.list.d/insync.list
           1: deb http://apt.insync.io/ubuntu/ xenial non-free contrib
           No active apt repos in: /etc/apt/sources.list.d/liquorix.list
           No active apt repos in: /etc/apt/sources.list.d/pipelight.list
           No active apt repos in: /etc/apt/sources.list.d/playonlinux.list
           No active apt repos in: /etc/apt/sources.list.d/sid.list
           Active apt repos in: /etc/apt/sources.list.d/sparky-unstable.list
           1: deb https://repo.sparkylinux.org/ unstable main
           2: deb-src https://repo.sparkylinux.org/ unstable main
           Active apt repos in: /etc/apt/sources.list.d/sparky.list
           1: deb https://repo.sparkylinux.org/ nibiru main
           2: deb-src https://repo.sparkylinux.org/ nibiru main
           3: deb https://repo.sparkylinux.org/ core main
           4: deb-src https://repo.sparkylinux.org/ core main
           No active apt repos in: /etc/apt/sources.list.d/virtualbox.list
           Active apt repos in: /etc/apt/sources.list.d/vscode.list
           1: deb [arch=amd64] http://packages.microsoft.com/repos/vscode/ stable main
           No active apt repos in: /etc/apt/sources.list.d/wine-staging.list



How do I cleanup the mixed up repos?

Thanks,
Balaji.

paxmark1

Over in #debian-next in irc they would mention DebFrankenstein and probably advise you to back up all data and re-install.   However this is Sparky.   You should look at your linux skill set.   If you are new or new to Sparky-Debian and apt you might want to go with Stable, Sparky5.   For that I would strongly suggest a full re-install.   Back up, back up , back up. 

If you prefer to  be using the newest programs, etc. you could possibly drop the Debian repos and go with the Niburu repos.    I am going to work.    I would comment out the  unstable Sparky repos, What I post is a fuzzy road map.  Please do not blindly follow my advice.   Others are better at this than me. 

If you ever run straight debian, you will really want to add non-free to main and cotrib.   

I can tell you that Virtualbox 6.1 will work in stable.  My belief is that in the future if I get back to having  time to use Virtual images, that I would go with qemu/kvm as they have matured greatly since 2016.   
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

bin

I also ran into problems with Virtualbox whilst trying out Bullseye. That's why they call it 'testing' I guess  :)

Although Virtualbox has a slightly more user friendly method of working,  qemu-kvm + virt-manager was where I went after reverting to Sparky Stable. It takes a little bit of learning but is worth the effort.

For me the one big plus is the much more reliable interface with USB devices.

pavroo

I guess it is testing line, not stable anyway, so...

1. Revert Debian repos from stable to testing:
sudo mv /etc/apt/sources.list /etc/apt/sources.list.bak
sudo touch /etc/apt/sources.list

and paste into the new source.list file:
deb http://deb.debian.org/debian/ bullseye main contrib non-free
deb-src http://deb.debian.org/debian/ bullseye non-free contrib main
deb http://security.debian.org/debian-security/ bullseye-security/updates non-free contrib main
deb-src http://security.debian.org/debian-security/ bullseye-security/updates non-free contrib main
deb http://deb-multimedia.org/ bullseye main non-free


2. Make sure Sparky repos:
/etc/apt/sources.list.d/sparky.list
points to testing potolo:
### sparky core repository is used by all sparky editions
deb https://repo.sparkylinux.org/ core main
deb-src https://repo.sparkylinux.org/ core main
### sparky potolo (testing) repository
deb https://repo.sparkylinux.org/ potolo main
deb-src https://repo.sparkylinux.org/ potolo main


Then refresh package list and try to install vbox:
sudo apt update
sudo apt install virtualbox virtualbox-qt


If any problem, past FULL output of all the commands you run at the forums.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum