Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: 1 tremendous annoyance... SOLVED  (Read 339 times)

Offline coyotl

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
1 tremendous annoyance... SOLVED
« on: August 10, 2020, 11:13:35 pm »
Gameover Edition/Bullseye.

A simple problem: System Upgrade upgrades the kernel but does not install the header package. With the nvidia driver installed this leads to an unusable desktop at next boot (horrible resolution as the driver is missing). If you are busy it's easy to just click on Update and not check what is installed.
Then you come back, reboot the machine to do something, and are faced with the tedious business of having to install the correct headers, reinstall nvidia-dkms to build the driver and reboot. (plus delete the old kernel and headers)

A Debian Testing issue I guess.
« Last Edit: August 12, 2020, 12:18:19 pm by coyotl »

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 294
  • Karma: +5/-0
    • Sparky Community Repos
Re: 1 tremendous annoyance...
« Reply #1 on: August 11, 2020, 08:49:22 am »
There is linux headers metapackage (linux-headers-amd64 for 64bit system) which sole purpose is to pull newest kernel headers when available. It works with debian kernel (linux-image-amd64). Seperate packages are available for Zen and Sparky kernels.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline coyotl

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: 1 tremendous annoyance... SOLVED
« Reply #2 on: August 12, 2020, 12:20:43 pm »
Thanks - so this will pull the corresponding header package on upgrade? Installing it.

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 294
  • Karma: +5/-0
    • Sparky Community Repos
Re: 1 tremendous annoyance... SOLVED
« Reply #3 on: August 12, 2020, 03:06:34 pm »
Thanks - so this will pull the corresponding header package on upgrade?
Yes. That's correct.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net