Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: Installation error  (Read 175 times)

Offline Bazzer786

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Installation error
« on: July 12, 2020, 06:41:05 pm »
I try to install Sparkylinux 5.1 Gamer edition 64 bit.



I try to install SparkyLinux 5.1 GameOver edition 64 bit. All is fine until the very end when i get this error message:

Installation Failed

Boost.Python error in job "packages"

<class 'subprocess.CalledProcesssError'>
Command 'apt-get update' returned non-zero exit status 100
Traceback:
File "/usr/lib/calamares/modules/packages/main.py", line 419, in run pkgman.update_db()
File "/usr/lib/calamares/modules/packages/main.py", line 230, in update_db check_target_env_call(["apt-get", "update"])
File "<string>", line 2, in <module>

What the hell does this mean?

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2112
  • Karma: +2/-0
    • SparkyLinux
Re: Installation error
« Reply #1 on: July 12, 2020, 06:51:12 pm »
Run the live system again.
Edit the packages config file:
Code: [Select]
sudo nano /usr/share/calamares/modules/packages.confand change:
Code: [Select]
update_db: true
update_system: true
to:
Code: [Select]
update_db: flase
update_system: false
then save the file and run the installer normally.

As an option, you can use the advanced installer instead of the calamares.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline Bazzer786

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Installation error
« Reply #2 on: July 15, 2020, 07:09:57 pm »
How do you edit the packages.config file?

I can't see this from the Live System with the Installation icons.

Please Help!



Offline lami07

  • Global Moderator
  • Full Member
  • *****
  • Posts: 238
  • Karma: +3/-0
    • Sparky Community Repos
Re: Installation error
« Reply #3 on: July 15, 2020, 09:03:42 pm »
Get yourself newer installation medium. Sparky gameover 5.1 is 2 and half year old. Things changed, repository adress changed. Try newer ISO.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net