Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: [Solved] can't upgrade from Buster to Bullseye  (Read 1878 times)

Offline vp_nbi

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
[Solved] can't upgrade from Buster to Bullseye
« on: May 29, 2020, 03:34:08 am »
I followed the online documentation for upgrading, but something in the upgrade process appears to be broken. I double checked the repository information which is correct.
Code: [Select]
apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
This doesn't make sense. Both libc6-dev and libgcc-8-dev are at the Buster level (as is libc6). What is it complaining about? We expect everything to be at the Buster level prior to the upgrade.

UPDATE: Problem solved. I'm not sure how, but I constructed a lengthy apt-get install command with arguments in the form of package/bullseye. I simply kept adding the dependency packages to the command until there were no more unresolved dependencies. Why this didn't happen automatically with apt-get dist-upgrade is a mystery to me, but I seem to have successfully upgraded to Bullseye as Synaptic shows Bullseye versions and there are no broken packages.
 
« Last Edit: May 29, 2020, 06:04:40 pm by lami07 »

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 293
  • Karma: +5/-0
    • Sparky Community Repos
Re: can't upgrade from Buster to Bullseye
« Reply #1 on: May 29, 2020, 05:44:26 pm »
There is currently bug in debian gcc-8, which is already fixed in unstable, and soon should be in testing. For now  issue with
Code: [Select]
The following packages have unmet dependencies:
 libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
can be fixed by manually upgrading gcc-8-base package ( sudo apt install gcc-8-base ) prior to conducting full system upgrade.

« Last Edit: May 29, 2020, 05:57:25 pm by lami07 »
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline Akito

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: [Solved] can't upgrade from Buster to Bullseye
« Reply #2 on: July 14, 2020, 12:15:13 pm »
Thank you very much, lami07. This solution works on my Raspberry Pi running DietPi, based on Raspbian Buster.

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 293
  • Karma: +5/-0
    • Sparky Community Repos
Re: [Solved] can't upgrade from Buster to Bullseye
« Reply #3 on: July 15, 2020, 11:04:37 am »
You are welcome akito.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net