Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: No internet connection after update this morning  (Read 226 times)

Offline Mic_a

  • Newbie
  • *
  • Posts: 10
  • Climate economist
No internet connection after update this morning
« on: February 10, 2020, 12:20:15 pm »
I am running Sparky Testing Minimum GUI on an old acer netbook. Since this update this morning I cannot access to the internet any more. An update is no longer possible - no website - but the connection to the router is available (I can see the icon) - but I cannot open Fritz-Box-menu.

Haven't changed the system - it is running since month unchanged. Don't know what to do  ;/
« Last Edit: February 10, 2020, 12:23:42 pm by Mic_a »

Offline Mic_a

  • Newbie
  • *
  • Posts: 10
  • Climate economist
Re: No internet connection after update this morning
« Reply #1 on: February 10, 2020, 12:23:00 pm »
When I try to reboot - shutdown has problems - takes a long time. 'Running jobs'

While booting I can see 1 problem (but cannot read it) - the rest works fine. Boots, browser starts - but nothing happens.

Offline lami07

  • Global Moderator
  • Full Member
  • *****
  • Posts: 170
    • Sparky Community Repos
Re: No internet connection after update this morning
« Reply #2 on: February 10, 2020, 01:26:04 pm »
Post content of /var/log/dpkg.log and /var/log/apt/history.log . Also run sudo journalctl -b in terminal and share the result.

Do not post the stuff I asked for directly on the forum. Upload it to pastebin.com and share the links.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline Mic_a

  • Newbie
  • *
  • Posts: 10
  • Climate economist
Re: No internet connection after update this morning
« Reply #3 on: February 10, 2020, 03:04:35 pm »
No sorry, I have no internet connection on this netbook anymore. No postings.

journalctl -b: CONFIG: UNKNOWN KEY

« Last Edit: February 10, 2020, 03:08:51 pm by Mic_a »

Offline Mic_a

  • Newbie
  • *
  • Posts: 10
  • Climate economist
Re: No internet connection after update this morning
« Reply #4 on: February 10, 2020, 03:10:55 pm »
At shutdown: stop job running for user manager for UID 1000

several times

this message I have now the first time.
« Last Edit: February 10, 2020, 03:17:18 pm by Mic_a »

Offline Mic_a

  • Newbie
  • *
  • Posts: 10
  • Climate economist
Re: No internet connection after update this morning
« Reply #5 on: February 10, 2020, 03:45:53 pm »
systemctl restart NetworkManager

does not help

Offline lami07

  • Global Moderator
  • Full Member
  • *****
  • Posts: 170
    • Sparky Community Repos
Re: No internet connection after update this morning
« Reply #6 on: February 10, 2020, 06:51:54 pm »
Ok. I've done some debugging.  If you have firewall (aka ufw) active, disable it. Run
Code: [Select]
sudo ufw disable
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2065
    • SparkyLinux
Re: No internet connection after update this morning
« Reply #7 on: February 11, 2020, 12:44:18 am »
Moved older iptables packages to Sparky testing repos so should be fine, until a new version will be available in Debian testing repos.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline lami07

  • Global Moderator
  • Full Member
  • *****
  • Posts: 170
    • Sparky Community Repos
Re: No internet connection after update this morning
« Reply #8 on: February 11, 2020, 11:07:46 am »
@Mic_a your issue ''I cannot access to the internet any more'' seems to be caused by regression in newest iptables release (v 1.8.4). As Pavroo mentioned workaround for this issue has been already applied. What you should do is to disable firewall
Code: [Select]
sudo ufw disableNext you do full system upgrade
Code: [Select]
sudo apt update && sudo apt full-upgrade this will downgrade iptables to last working version [1.8.3]. Now you can enable firewall once more
Code: [Select]
sudo ufw enable
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net