Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: <SOLVED> Caprine  (Read 281 times)

Offline braciszekodd

  • Newbie
  • *
  • Posts: 3
<SOLVED> Caprine
« on: November 16, 2019, 05:27:53 am »
Hi,
Sine I am using messenger a lot, I've installed Caprine via APTus. It doesn't open when i trying to open either via gui or terminal.
In the terminal i am getting message that Sandbox wasn't configured correctly.

Does anyone has similar problem?
« Last Edit: November 17, 2019, 04:44:28 am by braciszekodd »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2051
    • SparkyLinux
Re: Caprine
« Reply #1 on: November 16, 2019, 12:11:26 pm »
Try this:
https://github.com/sindresorhus/caprine/issues/887
« Last Edit: November 16, 2019, 01:57:24 pm by lami07 »
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline lami07

  • Global Moderator
  • Full Member
  • *****
  • Posts: 142
    • Sparky Community Repos
Re: Caprine
« Reply #2 on: November 16, 2019, 01:28:45 pm »
Debian disables unprivileged user namespaces by default, and your "issue" is consequence of this. Basically I see 3 options:
1) You do what error message says and make sure that /opt/Caprine/chrome-sandbox is owned by root and has mode 4755 (installation I made for the sake of tasting  was indeed owned by root, but had got wrong permissions) ;
2) You enables unprivileged user namespaces all together via sysctl kernel.unprivileged_userns_clone=1 ;
3) You run APTus and you install sparky (or liquorix ) kernel .
« Last Edit: November 16, 2019, 01:57:41 pm by lami07 »
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline braciszekodd

  • Newbie
  • *
  • Posts: 3
Re: <SOLVED> Caprine
« Reply #3 on: November 17, 2019, 04:46:38 am »
HI,

didn't know that solution will be so easy. I've just installed sparky kernel via APTus.

Thank you guys for your support! My Caprine is working now:)