SparkyLinux Forums

Software & hardware support => Applications => Topic started by: braciszekodd on November 16, 2019, 05:27:53 am

Title: <SOLVED> Caprine
Post by: braciszekodd on November 16, 2019, 05:27:53 am
Hi,
Sine I am using messenger a lot, I've installed Caprine via APTus. It doesn't open when i trying to open either via gui or terminal.
In the terminal i am getting message that Sandbox wasn't configured correctly.

Does anyone has similar problem?
Title: Re: Caprine
Post by: pavroo on November 16, 2019, 12:11:26 pm
Try this:
https://github.com/sindresorhus/caprine/issues/887
Title: Re: Caprine
Post by: lami07 on November 16, 2019, 01:28:45 pm
Debian disables unprivileged user namespaces by default, and your "issue" is consequence of this. Basically I see 3 options:
1) You do what error message says and make sure that /opt/Caprine/chrome-sandbox is owned by root and has mode 4755 (installation I made for the sake of tasting  was indeed owned by root, but had got wrong permissions) ;
2) You enables unprivileged user namespaces all together via sysctl kernel.unprivileged_userns_clone=1 ;
3) You run APTus and you install sparky (or liquorix ) kernel .
Title: Re: <SOLVED> Caprine
Post by: braciszekodd on November 17, 2019, 04:46:38 am
HI,

didn't know that solution will be so easy. I've just installed sparky kernel via APTus.

Thank you guys for your support! My Caprine is working now:)