Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: Permission denied  (Read 1025 times)

Offline prince

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Permission denied
« on: September 23, 2019, 09:11:16 pm »
Hey all. I've been using Sparky as a fast Windows alternative for some of my older machines, and I'm pretty impressed with the performance so far, aside from some of the weird quirks that pop up using dark themes (but that's a different question). I'm by no means a programmer or computer expert, especially when it comes to Linux, so the solution to this is probably really simple and I'm just a moron. I seem to be having trouble trying to install things from the terminal, it keeps telling me "permission denied". I swear there used to be a little program called APTuS or something that looked like a software repository or something, but I cant seem to find it anymore.

Thanks for your help and patience.

(I'd put the screenshot of the exact problem but I have no idea how. forums are hard)

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 855
  • Karma: 4
  • https://forum.sparkylinux.org/index.php/topic,4614
Re: Permission denied
« Reply #1 on: September 23, 2019, 09:50:26 pm »
You do not say which version of Sparky you are on.  There is #5 - stable and #6 rolling     If you are newer, especially with machines over a year old, #5 is the way to go. 

If you are into linux for the reasonable future, learning how to cut and paste from terminal to message field is helpful.

Quote
How to Cut, Copy, and Paste in the Terminal

In most applications Cut, Copy and Paste are Ctrl + X, Ctrl + C and Ctrl+V respectively.
In the Terminal, Ctrl+C is the cancel command. Use these in the terminal instead:
To cut Ctrl + Shift + X.
To copy Ctrl + Shift + C.
To paste Ctrl + Shift + V.


Mark it up with the code button     #

Note:  I have been working with the mentally challenged almost 30 years after leaving the laboratory, I would be grateful if you did not use the  "moron"  term.  You are de-valueing yourself and others. 

To use sudo for updating and upgrading  "sudo apt update" will update your program base of possible programs.  It will ask you for your password (not the root password) . 
                                                                      "sudo apt upgrade"    (or "sudo apt full-upgrade" in Sparky6) will allow you to upgrade all existing programs. 

Others can discuss the state of aptus. 

posting the output of "inxi -br"  give us some info on your machine and your repostories. 

example  - marked up as code with the # button in Post Reply. 

Code: [Select]
inxi -rb
System:    Host: dbnbuster Kernel: 4.19.0-6-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.14.5
           Distro: Debian GNU/Linux 10 (buster)
Machine:   Type: Desktop System: Gigabyte product: H81M-S2H GSM v: N/A serial: <root required>
           Mobo: Gigabyte model: H81M-S2H GSM v: x.x serial: <root required> BIOS: American Megatrends v: F2 date: 08/11/2015
CPU:       Dual Core: Intel Core i3-4170 type: MT MCP speed: 798 MHz min/max: 800/3700 MHz
Graphics:  Device-1: Intel 4th Generation Core Processor Family Integrated Graphics driver: i915 v: kernel
           Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa DRI Intel Haswell v: 4.5 Mesa 18.3.6
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           Device-2: Realtek RTL8812AU 802.11a/b/g/n/ac 2T2R DB WLAN Adapter type: USB driver: rtl8812au
Drives:    Local Storage: total: 2.27 TiB used: 481.22 GiB (20.7%)
Repos:     Active apt repos in: /etc/apt/sources.list
           1: deb http://debian.mirror.rafal.ca/debian/ buster main non-free contrib
           2: deb-src http://debian.mirror.rafal.ca/debian/ buster main non-free contrib
           3: deb http://security.debian.org/debian-security buster/updates main contrib non-free
           4: deb-src http://security.debian.org/debian-security buster/updates main contrib non-free
           5: deb http://download.virtualbox.org/virtualbox/debian bionic contrib
           Active apt repos in: /etc/apt/sources.list.d/spideroakone.list
           1: deb https://apt.spideroak.com/ubuntu/ release restricted
Info:      Processes: 195 Uptime: 30m Memory: 11.20 GiB used: 1.85 GiB (16.5%) Shell: bash inxi: 3.0.32

Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 307
  • Karma: 6
    • Sparky Community Repos
Re: Permission denied
« Reply #2 on: September 23, 2019, 09:52:35 pm »
 Hey. Have you tried to run install command with sudo ?
Like
Code: [Select]
sudo apt update
sudo apt install name-of-the-app

Run
Code: [Select]
apt policy sparky-aptus
To find out if APTus is installed on you system.
If not than :
Code: [Select]
sudo apt update
sudo apt install sparky-aptus
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net