Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: Installation on Pentium M  (Read 1088 times)

Offline darzu

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Installation on Pentium M
« on: August 23, 2019, 12:23:24 am »
Hello guys,

where can I find a lightweight version for a notebook DELL X300 running on Pentium M and 512MB of ram I tried old stable and still asking for 1GB of RAM. can someone provide me a link or point me how could I download a version what should work just fine for me?

Thanks

darzu

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 855
  • Karma: 4
  • https://forum.sparkylinux.org/index.php/topic,4614
Re: Installation on Pentium M
« Reply #1 on: August 23, 2019, 03:47:03 am »
Is it 32 bit?  If it is 64 bit, see if you can get some cheap memory, see below.  I believe you can run Sparky in 1 gb - to install a recent iso, you need 64 bits. 

https://sparkylinux.org/forum/index.php/topic,5019.0.html

512 mb is getting to be mighty small.  Stores that sell old computers might have some memory that would work for you at a very cheap price.  If you can get if for less than a fair meal out, do it. 

Sparky does not do 32 bit any more.  If you are bound and determined to go with 32 bit I would suggest Debian. 

I have an intel atom with 1 GB running lxqt on an old sparky tracking Debian testing when it is not running Sway wm in debian unstable. 
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 307
  • Karma: 6
    • Sparky Community Repos
Re: Installation on Pentium M
« Reply #2 on: August 23, 2019, 09:32:05 am »
Quote
I tried old stable and still asking for 1GB of RAM
1GB of RAM is requirement of calamares ( graphical installer) not Sparky. You can install sparky on your machine but you have to use advanced installer.
Code: [Select]
https://sparkylinux.org/wiki/doku.php/advanced_installer
Considering information found on the internet your machine doesn't support 64 bit. If that is correct I recommended sparky 5.8 miniGUI 32-bit, which can be found here:
Code: [Select]
https://sparkylinux.org/download/stable/
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline darzu

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Re: Installation on Pentium M
« Reply #3 on: August 24, 2019, 09:07:20 am »
Hello,

yes it is 32-bit only and I only got 512MB RAM it my fathers notebook actually, I used the sparky 5.8 miniGUI 32-bit and was able to install the LXDE desktop but also after install it seems to slow. He was using the notebook with Windows OS (XP Sp1) and it was running fine, but I was thinking to switch on linux because the Windows OS was not supported anymore, any thoughts if I could do anything else? If I go with 4.x version of SparkyLinux it will help?

Thanks

Ervin

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 307
  • Karma: 6
    • Sparky Community Repos
Re: Installation on Pentium M
« Reply #4 on: August 24, 2019, 09:59:30 am »
Quote from: darzu
I was thinking to switch on linux because the Windows OS was not supported anymore, any thoughts if I could do anything else? If I go with 4.x version of SparkyLinux it will help?
You can try 4.11 but I don't think it will do much. Other thing you can try is to yet again install from 5.8 miniGUI 32-bit, but this time pick 'openbox' as desktop of choise. It will provide you with openbox window manager and basic set of tools. This way you will have desktop environment healthy balanced between user friendliness and hunger for resource.
Unfortunately this won't change sad truth, 512 MB of RAM is not enough to have pleasant experience. You system will swap like hell most of the time.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net