Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: qmplay2  (Read 6914 times)

Offline penguin

  • Full Member
  • ***
  • Posts: 129
  • Karma: +0/-0
qmplay2
« on: July 22, 2019, 08:50:47 am »
Hi all.

I upgraded my Sparky 4.10 (XFCE) to Sparky 5.8 (XFCE) weeks ago. I noticed a conflict during upgrading of qmplay2 so I decided to keep (lock version). Today I decide to resolve this problem. So ... upgrading of qmplay2 from version qmplay2_18.12.26~sparky4~1-1_amd64 to qmplay2_18.12.26~sparky5~1-1_amd64.
Still having trouble I decided to uninstall old version and install the new one.

The follow lines comes from my terminal

Quote
sudo apt-get install qmplay2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qmplay2 : Depends: libcdio18 (>= 1:2.0.0) but 2.0.0-2 is to be installed
E: Unable to correct problems, you have held broken packages.

Version of my installed libcdio18 is 2.0.0.2

I used all commands for fixing broken packages but still problem persist.

I cannot remove libcdio18 because removal process want to remove clementine , strawberry and gfs-backends.

Anyone have faced the same problem ?

@pavroo . Please. Can you investigate the above mentioned problem with qmplay2?

Meanwhile I will go back to the previous version .....  but now I am in trouble. I downloaded the previous version of qmplay2 from :

Code: [Select]
https://sparkylinux.org/repo/pool/main/q/qmplay2/
Trying to install qmplay2(manually) version qmplay2_18.12.26~sparky4~1-1_amd6 I get the follow error:

Quote
Error:Dependencey is not satisfiable : libavdevice57 (>=10:3:3.9)


Meanwhile I have resolved problem in this way:

I tried to installing old version by installing manually of missing dependencies ...but this method directed me to install an chain of non satisfied dependencies. So?

I downloaded qmplay2 from the author site
Code: [Select]
https://github.com/zaps166/QMPlay2 and I found that libtag-extras1 needs to be installed. I installed it from Synaptic.

Second step . I tried to install qmplay2-ubuntu-amd64-18.12.26-1.deb  by gdebi also by gdebi-tool , but no success. So, I enter terminal as su - (this is important). Go to your directory where qmplay2-ubuntu-amd64-18.12.26-1.deb is and install it by command
dpkg -i qmplay2-ubuntu-amd64-18.12.26-1.deb .


Done ! Till moment I will find another solution, I locked my qmplay2 from Synaptic, to avoid qmplay2 update.
« Last Edit: July 22, 2019, 09:28:18 am by penguin »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2085
  • Karma: +0/-0
    • SparkyLinux
Re: qmplay2
« Reply #1 on: July 22, 2019, 11:15:13 am »
If you enable Debian multimedia repos, you will get the required dependencies to qmplay2.
« Last Edit: July 22, 2019, 04:28:21 pm by pavroo »
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline penguin

  • Full Member
  • ***
  • Posts: 129
  • Karma: +0/-0
Re: qmplay2
« Reply #2 on: July 22, 2019, 05:09:54 pm »
If you enable Debian multimedia repos, you will get the required dependencies to qmplay2.

Follow are my repos:

Code: [Select]
Active apt repos in: /etc/apt/sources.list
  1: deb http://ftp.debian.org/debian/ buster main contrib non-free
  2: deb-src http://ftp.debian.org/debian/ buster non-free contrib main
  3: deb http://security.debian.org/ buster/updates non-free contrib main
  4: deb-src http://security.debian.org/ buster/updates non-free contrib main
  5: deb http://www.deb-multimedia.org/ buster main non-free
 
  Active apt repos in: /etc/apt/sources.list.d/mono-official-stable.list
  1: deb https://download.mono-project.com/repo/debian/ stable-buster main
 
Active apt repos in: /etc/apt/sources.list.d/opera-stable.list
  1: deb https://deb.opera.com/opera-stable/ stable non-free

  Active apt repos in: /etc/apt/sources.list.d/skype-stable.list
  1: deb [arch=amd64] https://repo.skype.com/deb stable main
 
 Active apt repos in: /etc/apt/sources.list.d/sparky-stable.list
  1: deb https://sparkylinux.org/repo/ core main
  2: deb-src https://sparkylinux.org/repo/ core main
  3: deb https://sparkylinux.org/repo/ stable main
  4: deb-src https://sparkylinux.org/repo/ stable main

seems that media repo are enabled.

Tried as follow:

Uninstalled qmplay2 previosly installed and

sudo apt-get update && sudo apt-get upgrade


Tried to install qmplay2_18.12.26~sparky5~1-1_amd64.deb  from Synaptic.

Quote
Error :

Could not mark all packages for installation or upgrade
The following packages have unresolvable dependencies. Make sure that all required repositories are added and enabled in the preferences.

qmplay2:
  Depends: libcdio18 (>=1:2.0.0) but 2.0.0-2 is to be installed
 
« Last Edit: July 22, 2019, 09:01:51 pm by lami07 »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2085
  • Karma: +0/-0
    • SparkyLinux
Re: qmplay2
« Reply #3 on: July 22, 2019, 05:54:10 pm »
Quote
Depends: libcdio18 (>=1:2.0.0) but 2.0.0-2 is to be installed
It is quite not normal for me, so show me (paste your code into "Insert Code" please):
Code: [Select]
sudo apt update
sudo apt policy libcdio18
and eveyrthing you have at /etc/apt/preferences.d/  dir.
« Last Edit: July 22, 2019, 05:56:03 pm by pavroo »
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline penguin

  • Full Member
  • ***
  • Posts: 129
  • Karma: +0/-0
Re: qmplay2
« Reply #4 on: July 23, 2019, 11:08:00 am »
Quote
Depends: libcdio18 (>=1:2.0.0) but 2.0.0-2 is to be installed
It is quite not normal for me, so show me (paste your code into "Insert Code" please):
Code: [Select]
sudo apt update
sudo apt policy libcdio18
and eveyrthing you have at /etc/apt/preferences.d/  dir.


as required :

Code: [Select]
sudo apt policy libcdio18
libcdio18:
  Installed: 2.0.0-2
  Candidate: 2.0.0-2
  Version table:
 *** 2.0.0-2 500
        500 http://ftp.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status

within /etc/apt/preferences.d/ is a file named sparky (follow is contain of this file)

Code: [Select]
Package: *
Pin: release o=SparkyLinux
Pin-Priority: 1001

Thank you pavroo for your time and support.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2085
  • Karma: +0/-0
    • SparkyLinux
Re: qmplay2
« Reply #5 on: July 23, 2019, 03:12:00 pm »
Ok, found the problem now.
When I build the qmplay2 package, there was libcdio18 available in Debian and Debian Multimedia repos, the 1:2.0.0 was installed from the Multimedia, and my deb needs exactly this version.
But, there is no libcdio18 pack in Multimedia repos any more, was upgraded up to libcdio19 - that's the problem.
A solution - have to rebuild qmplay2 with the new lib.

Edit
Fixed now.
« Last Edit: July 24, 2019, 03:43:52 pm by pavroo »
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net