Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: Upgrading to 5 from 4 Tyche  (Read 2949 times)

Offline otello

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Upgrading to 5 from 4 Tyche
« on: July 14, 2019, 03:32:30 pm »
Hi, while trying to upgrade the sparky5-apt:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 sparky5-apt : Dipende: apt (>= 1.8) ma la versione 1.4.9 sta per essere installata
               Dipende: base-files (>= 10~sparky0)
               Dipende: libc6 (>= 2.28) ma la versione 2.24-11+deb9u4 sta per essere installata

How can I fix?

Thanks in advance

Otello



Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 307
  • Karma: 6
    • Sparky Community Repos
Re: Upgrading to 5 from 4 Tyche
« Reply #1 on: July 14, 2019, 04:33:41 pm »
Have you consulted guide at the link below ?
Code: [Select]
https://sparkylinux.org/sparky-4-transition/
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline penguin

  • Full Member
  • ***
  • Posts: 134
  • Karma: 1
Re: Upgrading to 5 from 4 Tyche
« Reply #2 on: July 15, 2019, 09:08:41 am »
Vedi anche il mio post

Code: [Select]
https://sparkylinux.org/forum/index.php/topic,4966.0.html
fai attenzione con i repos !!!

Offline penguin

  • Full Member
  • ***
  • Posts: 134
  • Karma: 1
Re: Upgrading to 5 from 4 Tyche
« Reply #3 on: September 16, 2019, 07:08:13 am »
Hi, while trying to upgrade the sparky5-apt:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 sparky5-apt : Dipende: apt (>= 1.8) ma la versione 1.4.9 sta per essere installata
               Dipende: base-files (>= 10~sparky0)
               Dipende: libc6 (>= 2.28) ma la versione 2.24-11+deb9u4 sta per essere installata

How can I fix?

Thanks in advance

Otello

Sorry that I gave you a wrong answer before. Sorry. First of all. Make a image of Sparky. If you use Windows ...fire up Windows and using Drive Snapshoot of Sparky partition.



Prima di installare new sparky_apt ad sparky5_apt bisognia cambiare i repos.

i passi seguenti:

sudo apt update
cambia i repos ( stretch > buster ) manualmente in synaptic or

Code: [Select]
Example:
FROM STRECTH:
deb http://httpredir.debian.org/debian stretch main
deb http://httpredir.debian.org/debian stretch-updates main
deb http://security.debian.org stretch/updates main

TO BUSTER:
deb http://httpredir.debian.org/debian buster main
deb http://httpredir.debian.org/debian buster-updates main
deb http://security.debian.org buster/updates main
Alternatively, use a sed command to automate this tedious task:
# sed -i 's/stretch/buster/g' /etc/apt/sources.list
Once the above /etc/apt/sources.list file edit is completed, use apt-get command to update packages index:

code get from https://linuxconfig.org/how-to-upgrade-debian-9-stretch-to-debian-10-buster


sudo apt update

sudo apt install sparky-apt sparky5-apt

sudo apt full-upgrade

fai attenzione durante il upgrade process con i domande. Se nos sei sicuro solo ( N) - keep default.

bisognia installare manualmente sparky_aptus.



 

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2290
  • Karma: 7
    • SparkyLinux
Re: Upgrading to 5 from 4 Tyche
« Reply #4 on: September 16, 2019, 11:14:42 pm »
As lami07 pasted a link to my post about moving Sparky 4 to 5, there is correct way to upgrade it.
Due to a problem with upgrading the system, I upgraded the post after, so...

The trick is to set Debian and Sparky stable repos manually, before trying to install sparky5-apt
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat