Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

APTus cannot install KDE (print-manager package missing!)

Started by nox, July 25, 2018, 12:03:02 AM

Previous topic - Next topic

nox

Hello all!

I'm having some issues with installing KDE through APTus.


  • I get asked if I'd like to install now, I click the install button
  • A terminal window pops up a few times, then it says "Something went wrong!"
There is no terminal output when I start aptus through terminal either, so I'm at a loss here.


EDIT1: I tried to install the meta package sparky-desktop-kde:
sudo apt install sparky-desktop-kde
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
sparky-desktop-kde : Depends: print-manager but it is not installable
E: Unable to correct problems, you have held broken packages.


So, a dependecy, "print-manager", is missing from the repositories.

Any ideas of how to resolve this?

EDIT2: Installed print-manager from unstable, successfully installed kde, but now everything seems halfbroken. Can't even set a custom background picture with KDE :(

paxmark1

https://packages.debian.org/unstable/main/print-manager

See my previous post today.
http://sparkylinux.org/forum/index.php/topic,4501.msg11443.html#new
QuoteIf you are in testing (Sparky5), packages can suddenly disappear. Packages that have not had enough "maintenance" for Debian can be pulled   In this case it appears it has been pulled but reintroduced into Sid, (unstable).  If you really want to get information, lots, about a package go to the Debian package site. In this case 

edit  You can really mess things up by just blindly pulling in things from Sid.  Always investigate first. Also check
https://release.debian.org/transitions/

Also https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=print-manager;dist=unstable
It will not move to Buster - Sparky5 until the critical bug is fixed, and add 5 days for the standard transition to Buster - Testing. 
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

pavroo

Temporary moved print-manager to sparky repos so refresh package list and try again.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum