Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: [SOLVED] Cant Install sparky-aptus  (Read 1762 times)

Offline pkmorrison

  • Newbie
  • *
  • Posts: 5
[SOLVED] Cant Install sparky-aptus
« on: January 26, 2018, 02:51:18 pm »
Some sort of dependancy hell - dont see how to track it down further.

===============================================================================================
root@sparky:~# apt install sparky-aptus
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 sparky-aptus : Depends: zenity
E: Unable to correct problems, you have held broken packages.
root@sparky:~# apt install zenity
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zenity : Depends: libwebkit2gtk-4.0-37 (>= 2.15.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@sparky:~# apt install libwebkit2gtk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libwebkit2gtk
root@sparky:~# apt install libwebkit2gtk-4.0-37
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwebkit2gtk-4.0-37 : Depends: libgstreamer-plugins-bad1.0-0 (< 1.13) but 1:1.12.2-dmo1 is to be installed
E: Unable to correct problems, you have held broken packages.
==============================================================================================
« Last Edit: January 27, 2018, 02:42:13 pm by pkmorrison »

Offline Capitain_Jack

  • Full Member
  • ***
  • Posts: 101
Re: Cant Install sparky-aptus
« Reply #1 on: January 26, 2018, 04:42:11 pm »
Try installing first aptitude, than try again to install sparky-aptus using it (same commands as apt-get), it will offer solutions for the broken/dependence packages.

If you feel you found the solution, please edit the first message title, adding [SOLVED] to the beginning of it, so others can benefit from it. thaks!
"Great spirits have always encountered violent opposition from mediocre minds."
Albert Einstein

Offline pkmorrison

  • Newbie
  • *
  • Posts: 5
Re: [SOLVED] Cant Install sparky-aptus
« Reply #2 on: January 27, 2018, 02:47:04 pm »
I removed  libgstreamer-plugins-bad1.0. It removed a bunch of other stuff.
Installed sparky-aptus and it works fine. This also reinstalled
libgstreamer-plugins-bad1.0 with dmo2 instead of dmo1

Offline Katsyarissha

  • Newbie
  • *
  • Posts: 1
Re: [SOLVED] Cant Install sparky-aptus
« Reply #3 on: October 10, 2019, 02:57:03 am »
i have lost aptus aswell and ive tried everything i can think of to get it back. i even installed a older verson of sparkylinux and it worked but soon as i let the system update its gone again.. idk what to do. this is the only version of linux that runs worth a crap on my old old laptop.. anyone have any other solution?