Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Unable to mount usbstick since upgrade (gvfs?)

Started by red.iceman, November 25, 2016, 08:33:11 AM

Previous topic - Next topic

red.iceman

Hi,

since thursday I cannot mount usbsticks anymore: "not authorized to perform operation"
In happens in all gvfs based filemanagers like nemo, thunar, pcmanfm, nautilus..., while dolphin works fine.

System: Lenovo X240
Desktop: Budgie, XFCE

Any idea?

Jens



pavroo

Make sure you have installed 'policykit-1-gnome' package and 'polkit-gnome-authentication-agent-1' is enabled to start with the system starts.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

red.iceman


# sudo aptitude search policykit-1
i A policykit-1                                                             - Rahmen für die Verwaltung von Privilegien und administrativen Verfahren         
p   policykit-1:i386                                                        - Rahmen für die Verwaltung von Privilegien und administrativen Verfahren         
p   policykit-1-doc                                                         - Dokumentation für PolicyKit-1                                                   
i A policykit-1-gnome                                                       - XFCE and Unity authentication agent for PolicyKit-1                             
p   policykit-1-gnome:i386                                                  - XFCE and Unity authentication agent for PolicyKit-1


Quote from: pavroo on November 25, 2016, 11:22:12 AM
Make sure you have [...] 'polkit-gnome-authentication-agent-1' is enabled to start with the system starts.
How can I verify this?

Jens

Dai_trying

apt-cache policy policykit-1
if you have a line that says Installed <version> then it is installed, if it says Installed: (none) then it is not installed.

red.iceman


# apt-cache policy policykit-1

policykit-1:
  Installiert:           0.112-5.3.1~really-0.105-8
  Installationskandidat: 0.112-5.3.1~really-0.105-8
  Versionstabelle:
*** 0.112-5.3.1~really-0.105-8 100
        100 /var/lib/dpkg/status
     0.105-17 500
        500 http://ftp.debian.org/debian testing/main amd64 Packages


As far as I understand it doesn't mean that 'polkit-gnome-authentication-agent-1' is enabled.

pavroo

Check does it work now:
pidof polkit-gnome-authentication-agent-1
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

red.iceman


# pidof polkit-gnome-authentication-agent-1
#

Okay, it is not running.


# ls /etc/xdg/autostart/polkit*
/etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop /etc/xdg/autostart/polkit-mate-authentication-agent-1.desktop
/etc/xdg/autostart/polkit-kde-authentication-agent-1.desktop


So it should be started, shouldn't it?

pavroo

#7
Copy polkit-gnome-authentication-agent-1.desktop to home dir:
~HOME/.config/autostart/polkit-gnome-authentication-agent-1.desktop
Then reboot.

And make sure the exec line is:
Exec=/usr/lib/polkit-gnome-authentication-agent-1
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

red.iceman

Sorry, still the same error.


# pidof polkit-gnome-authentication-agent-1
# ps ax | grep polkit
  930 ?        Ssl    0:00 /usr/lib/policykit-1/polkitd --no-debug
2145 ?        Sl     0:00 budgie-polkit-dialog
2553 pts/0    S+     0:00 grep polkit

red.iceman

I have tried the following:

create a simple .xinitrc

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
    for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
        [ -x "$f" ] && . "$f"
    done
    unset f
fi

exec budgie-desktop


reboot to init 3.

Now I can mount usb sticks.

So maybe the display manager (lightdm, but I tried slim, too) is the problem.

red.iceman

If I start without X (multiuser.target), I can mount USB sticks.
If I start with X (graphical.target), it does not work.

This is not a solution but a workaround.

Further ideas?

Jens

piker

I upgraded the other day and also have this problem. I cant access anything on a usb flash drive at all. Has anyone got an update on this?

piker

..also just realised that my auto mounts (fstab) disappeared when a usb flash is inserted.


pavroo

Connect the usb drive and show what parted says:
sudo parted -l
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum