Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Problem getting Grub to recognise alternative operating system, SCO Open Server

Started by Roy, June 23, 2015, 04:14:02 PM

Previous topic - Next topic

Roy

Hello all,

The machine is a Pentium ll  333Mhz,  524meg Ram

The primary HD (master) has SCO Open Server 5.04 on it
Sparky is on a second HD as (slave).

The SCO 5.04 has to be set as master otherwise it won't install or boot.
I realise that it dates back to 1997 but it supports some very old software that I need.

After installing Sparky nothing would boot so I ran the live DVD of Sparky and went into "Preferences/Boot Repair" and at the end of the routine as message said to set my bios boot to D.

That worked an I get a grub menu showing an entry to boot Sparky and Memory test options but there is no entry to boot SCO Open Server 5.04 installed on drive C

If I run fdisk -l  both HD's are found
SCO openserver 5.04 is on sdb /dev/sdb4
Sparky is on sdc /dev/sdc1

If I boot with a Parted Majic live CD and use the extra menu options I can boot into /dev/sdb4 (SCO open server 5.04)
I am assuming that the Grub2 probe utility is having a problem recognising the SCO Unix and that I need to make a manual entry in a script in /etc/grub.d but I don't have a clue what to enter.

I would be very grateful for any help offered.

Roy

pavroo

Hi

If !
1. You don't have /dev/sda disk
2. Grub installed by Sparky has been installed in MBR, not the Sparky's root partition
then:

In a case like that, edit the file (as root): /etc/grub.d/40_custom
and add your entry:
menuentry "SCO Open Server" {
set root=(hd1,4)
drivemap -s (hd0) (hd1)
}

Then update grub:
sudo update-grub
It's an old Unix system so the config file can be a little bit different, not sure.
Here is a nice post about Grub too: http://ubuntuforums.org/showthread.php?t=1195275
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Roy

Hi Pavroo,

Thanks for replying.

I did what you said but unfortunately it did not work, the menu option showed but all that happened was that the screen blanked for 1/2 second and returned to the menu options.   I did try changing set root to different obvious variables from (hd1,4) to hd0,4) etc, etc but to no effect. I also tried commenting out the drivemap line but again to no effect.

One clue though.  When I run the GParted live boot disc and took the "Local Boot Routines Menu / [first option]. Local Boot" a message displayed showing -
Bypass the SYSLINUX Loader, and use the Boot Loader on your hard disc.

This worked fine.

Is there some way I can do as the message implied within Grub2.

Many thanks again

Roy

pavroo

You should find out how the SCO Open Server's bootloader boots the system (SCO Open Server docs, faq, wiki - find its bootloader config) and use it to configure the '40_custom' file. It's what I can do now.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum