Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

openbox has no hdmi sound options only spdif something

Started by Lizbeth, April 17, 2015, 10:10:16 AM

Previous topic - Next topic

Lizbeth

consequently, even with my amd drivers installed, i cant get alsamixer to activate my hdmi sound.  the volume icon is worthless.

however, once i install pavucontrol i can then select hdmi output and it works great though the volume icon on the tint2 taskbar is still worthless.

the good news is the videos in the browser run much better with pipelight than with any other system ive run.  ive always loved that about openbox.  everything runs better. Even with hbo now using pipelight and flash i never use more than 9% of my 6 gigs of memory.  I think that's rather amazing.  Also the openbox is the only system i didnt have to use the spoofer to fool hbo now into thinking i was on a windows machine.  No system spoofer installed and it ran so well.  No sound mismatches no studdering.  Just flawless playback in the browser with picture and sound.

I have installed the openbox 4.0 rc3 with the 686 pae kernel running on my a6 laptop with an external monitor since my lcd died and i use it as my desktop.  it come with the apu 6520g 512m videoram on die.

way12go

Success gives birth to success? Failure gives birth to failure? - Sagar Gorijala.

Lizbeth

yes but how do i get my volume icon on the tint2 taskbar to work?

pavroo

I am not sure that the volumeicon will be cooperate with pulseaudio and pavucontrol.
The volumeicon-alsa works with alsa only as the description says:
QuoteThis is a lightweight volume control that sits in your systray. This version is compatible with ALSA.
Some of our members used lxde-panel or xfce4-panel or fbpanel instead of tint2 to launch different volume icon on it for example (and some more functions).
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Lizbeth

ok.  but pulse ausio and alsa were installed by default.  so if i delete pulse then alsa should work?  i just want the minimal install.  tint2 and plank are enough if alsa will work.  it wasn't working at all though after the install.  can you offer some help with that please?

pavroo

As you said before:
Quotei cant get alsamixer to activate my hdmi sound
You have a problem using alsa so I wouldn't remove pulse if it works.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat


Lizbeth

maybe ill have a go at compiz on top of openbox.  ive used compiz to provide services before in mate and deleted the mate panels (back when it was gnome 2 still.


is there a startup editor for openbox's programs that run on startup?

i guess ill look to see where it might be.  probably a file hidden in the home directory somewhere?

pavroo

No editor, only a script file:
~HOME/.config[/openbox/autostart.sh
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat


View the most recent posts on the forum