Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[Solved] Obmenu problems

Started by cynclida, February 17, 2015, 11:05:44 AM

Previous topic - Next topic


Hi, first of all thanks for this nice and well-done linux distro.

Installed base-version with openbox. To configure a customized openbox menu, I installed obmenu. But obmenu works just with root privileges, and -the real problem- it opens the file /root/.config/openbox/menu.xml, no way to open the flie I wanted to edit, which is /home/myuser/.config/menu.xml.

Finally I configured the menu editing menu.xml manually, but it is really strange. On another machine I run Debian testing, and there obmenu runs without root privileges and accesses the correct menu.xml. What is the problem?


Check who is the owner of the menu.xml file:
ls -l /home/you/.confg/openbox/menu.xml
If not you, change it, as root:
chown you:you /home/you/.confg/openbox/menu.xml

Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Thanks for your reply.

Onwer of the /home/petra/.config/openbox/menu.xml file is me:

petra@jft00:~$ ls -l /home/petra/.config/openbox/menu.xml
-rwxr-xr-x 1 petra petra 36788 Feb 15 23:47 /home/petra/.config/openbox/menu.xml

The problem remains unchanged. If it helps, this is the output of the obmenu command (without root privileges):

petra@jft00:~$ obmenu
Traceback (most recent call last):
  File "/usr/bin/obmenu", line 617, in <module>
  File "/usr/bin/obmenu", line 610, in init
    self.createTree(None, None)
  File "/usr/bin/obmenu", line 41, in createTree
    if["id"]) and it["action"] == "":
  File "/usr/lib/pymodules/python2.7/", line 334, in getMenu
    d = self._get_menu_props(i)
  File "/usr/lib/pymodules/python2.7/", line 137, in _get_menu_props
    if mnu: lb = mnu.attributes["label"].nodeValue
  File "/usr/lib/python2.7/xml/dom/", line 522, in __getitem__
    return self._attrs[attname_or_tuple]
KeyError: 'label'

But don't worry, I can edit the  /home/petra/.config/openbox/menu.xml manually, just sometimes it's good to have the gui as well. And I really don't understand why it behaves like that.


I remember now.
I saw the problem time ago and it came from Debian package.
That's why I removed it from Sparky's Openbox iso.
Somebody should reported it to Debian devs already I think.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Ok, and I installed it right from the debian repo.

Thanks for the info. Maybe some upadate will repair it.


Just could solve the problem: replace in ~/.config/openbox/menu.xml the lines

<menu id="/Debian">


<menu id="/Debian" />

Then obmenu works as it should, also for general user.

View the most recent posts on the forum