Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Can't instal sparky dual boot

Started by xydroh, February 05, 2015, 11:55:32 AM

Previous topic - Next topic

xydroh

Hello, when i was trying to install my dual boot windows/sparky I got the message that my EFI partition isn't big enough, it's 100mb but that's probably all that windows 8.1 takes already. I have my windows on my ssd and plan to install sparky on my second harddrive.

Are there people that experienced the same problem or know solutions please contact me, thank you.

pavroo

#1
Windows bootloader shouldn't use all of the 100MB space.
Probably the installer detected that your boot efi partition is for example 99,8MB large so it's not enough (the installer minimum limit is round 100).

What can you do?
1. Run Sparky live iso
2. Update package list:
sudo apt-get update
3. Remove the present version of the installer:
sudo apt-get purge live-installer
4. Install the latest version of the installer (20150204) from sparky repository:
sudo apt-get install live-installer
sudo apt-get install -f

5. Edit the file via a text editor (with sudo), for example:
sudo leafpad /usr/lib/live-installer/frontend/gtk_interface.py
Change 'leafpad' for a text editor you have installed.
Find line 829 and change '100' to '80', save and close the file, than run the Sparky Installer.
6. Let me know does it help.

Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

xydroh

It did in fact give the message that the EFI is not 100MB but this is not correct since it has 100.5 MB space from which I saw on the gparted menu.

pavroo

The installer and Gparted can recognize the partition size in a different way.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum