Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

[SOLVED] Unable to install Parcellite 1.1.9 from source

Started by one23, October 17, 2014, 11:13:30 PM

Previous topic - Next topic

one23

I was wondering why it was impossible to install Parcellite 1.1.9 from source (earlier version suffer from nasty bug which disallows you to clean the history).  After executing

./configure

terminal was spitting out


configure: error: Package requirements (gtk+-2.0 >= 2.10.0) were not met:

No package 'gtk+-2.0' found


I had no problem with using deb package though

pavroo

It should be 'libgtk2.0-dev' package missing.
Get it via Synaptic and try again.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

pavroo

If parcellite 1.1.9 is fixed you can install it from sid repository without compiling from source.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

one23

Installing libgtk2.0-dev did resolve dependency issue and  could compile the program from source.

Just out of curiosity, why deb package was installed without libgtk2.0-dev being installed first? Is it something to do with the way that deb package installer handles package dependencies?

pavroo

It simple - if you'd like to compile something you need 'dev' libs.
If you install 'deb' package you don't need 'dev' just normal libs.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

one23


View the most recent posts on the forum