Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Sparky APTus 2 bytes letter problem

Started by LeGoff55, May 16, 2014, 06:04:36 PM

Previous topic - Next topic

LeGoff55

Hi from Japan!



I like the beginner friendly graphical features of APTus.

However, when I work with it, the terminal window does not display 2 bytes letters (Chinese characters and Japanese letters)

correctly. Instead it shows white squares and I can not read the messages shown in the terminal.

Other applications such as LXTerminal and Iceweasel handle 2 bytes letters correctly, so I assume that my locale setting is

OK.

Is there any solution?










pavroo

#1
Hi from Poland :)

I still have the same problem with Polish letters. I tried to reconfigure console-data, but it did not change anything.

I think, the best way is to change the xterm for something different, such as Lxterminal.

What do you think?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

pavroo

#2
It's done. APTus uses the default terminal emulator now.

Upgrade it up to 0.1.7.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

LeGoff55

#3
HI, pavroo!



WOW WOW, so quick job, I'm impressed.

Now APTus launches LXterminal and it shows 2 bytes letters perfectly.

Thank you !!!!

pavroo

#4
It launches the default terminal emulator depends of a desktop:

LXDE - Lxterminal

Xfce - Xfce4-termianal

MATE - mate-terminal, etc.

I had to add one more option : Update packages.

Xterm supports double commands only for aptus (command1 && command2).

So I separated update && upgrade commands.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum