Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

lxpanelctl shortcuts don't work after upgrade

Started by famewolf, November 14, 2018, 04:22:13 AM

Previous topic - Next topic


I installed a clean copy of "sparkylinux-5.5-i686-lxqt.iso" onto my old acer aspire 3000.  I let it do it's upgrade process and upon reboot I find that the majority of keyboard shortcuts no longer work.  "Failed to execute child process "lxpanelctl" (no such file or directory)".



That was the first thing I tried. It stopped the errors but the shortcuts still didn't work....neither did running "lxpanelctl run" from a shell command line.

Thanks for the reply!


lxpanelctl is is a program that controls lxpanel.
LXQt session does not use lxpanel, but it uses lxqt-panel instead.
So... if you have not lxpanel installed you should remove lxpanelctl shortcuts from LXQt settings.
Check it out via menu LXQt Settings and Openbox config as well.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Thanks.  Suppose I'll wait till the lxqt version is more stable. 


two cents here.  I don't think it is stability,
"apt-cache show lxpanel"     No Qt5 components.

Several year old Debian stable lxqt
aptitude show lxpanel
Package: lxpanel                         
Version: 0.9.3-1
State: not installed

via "apt-cache show lxqt-panel"


It is an absolute rewrite - possibly from a blank terminal of the panel.  I would ask at the lxqt irc for advice on how to import your old settings. 

Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


I didn't have any "old" settings.  I did a clean install of the latest rolling iso...let it update itself and it was broke out of the box.   lxqt shouldn't still be making lxde calls obviously and I'm not going to live without the Alt-F2 shortcut when I want to run a file.  After being unable to get the rtl8812au source to compile after having it work on multiple other distro's I gave up. 



Might be the kernel version.  Old versions of rt... wont compile for newer kernels.
Go with Gordboys, his is the most recent.

I compiled around Apr 29, 2018 with the zebulon git on amd64 in stable and i386 in sparky rolling.  Since then I have been stuck at 4.14 in stable with backports in Debian for awhile. Lazy, I did not want to re-compile, I posted my success in the debian forum, they only want to hear things pure debian, which my one box is. 

But I moved my puter and desk and bought Cat-6 cable and did compile via dkms 2 days ago. Smooth as silk. I am at 4.15 kernel presently.

Alt-F2  my sid with amdC-50 (now dead) tiny box went to lxqt from #!, my desktop got lxqt 9months before stretch went stable and 2 old netbooks all have had lxqt and all worked out of box on Alt-F2. 

I wish you nothing but success if you return to lxde. But if you want another try at lxqt another way you could always try the Debian testing netiso.  Be sure to get the non-free version.  You have to hunt for it. 

peace out.

Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


Thank for the followup.   I reloaded the "rolling iso" and verified the shortcuts are actually broken on the live dvd as well so it's something that got missed.  Would you have a copy of the proper shortcut file for lxqt from one of your other builds that calls the lxqt panel equivalents?  The file is ~/.config/openbox/lxqt-rc.xml   Thanks alot for the info on the 8812au.   I've tried a few other distro's such as raspian etc...part of the problem is I'm testing this all out on an ancient 32 bit laptop with a quirky video chipset.  Some distro's hang on boot.  Some give me no gui display or 640x480 resolution.   I will say this for sparkylinux...both the lxde and the lxqt versions booted right up and displayed correctly.  I wanted to get it running so if I take it out in public and it gets stolen I'm not really out that much. 

Oh the lxqt version is using kernel 4.19.2 I think with earlier installs being 4.18.xx but not anything earlier.

*update*  For others the Alt F2 shortcut specifically can be fixed by replacing "lxpanelctl run" with "lxqt-runner".  There are several others that call lxpanelctl "menu, task" etc that I don't have replacements for.  The other lxqt distro's I looked at don't appear to be using openbox to handle their shortcuts because alt-f2 isn't even found in their copy of lxqt-rc.xml.


Sorry about the delay.  There is the option of xfwm4 or openbox in  Preferences> LXQT settings> Sesion settings.  More work is being done on the using the xfwm4 window manager in lxqt as it is wayland compliant.  (Nice of XFCE to make an WM that can be utilized in other DE's.) It might be that you would have to install xfwm4 to have it available. 

  I was going to point you to /etc/skel/.config where the standard versions of many configs are.
/etc/skel/.config$ tree
├── fontconfig
│   └── fonts.conf
├── gtk-2.0
│   └── settings.ini
├── gtk-3.0
│   └── settings.ini
├── lxqt
│   ├── desktop.conf
│   ├── globalkeyshortcuts.conf
│   ├── lxqt.conf
│   ├── lxqt-powermanagement.conf
│   ├── lxqt-runner.conf
│   ├── notifications.conf
│   ├── panel.conf
│   ├── power.conf
│   ├── session.conf
│   └── windowmanagers.conf
├── openbox
│   ├──
│   ├── lxde-rc.xml
│   ├── menu.xml
│   └── rc.xml
├── pcmanfm-qt
│   └── lxqt
│       ├── settings.conf
│       ├── settings.conf.lock
│       └── settings.conf.XM1230  has info about lxqt-runner

and I was going to see if you had lxqt-global keys which would pull in the runner

I am just a hobbyist.  My parents combined ages is >180 y.o. I got pulled away. 
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


I can "survive" with alt-f2 working..most of the basic shortcuts like f11 for full screen etc still work.

As for the wifi.  I ended up having to use a different source as well as a patch for Kernel v4.9 (found in an open ISSUE submitted by a USER on dev's github) to make it compile.  This of course is in no way sparkylinux's fault but I finally did get the thing working.

The device shows:
Bus 001 Device 002: ID 0bda:a811 Realtek Semiconductor Corp.

After patching the source the following commands worked:

git clone

cd rtl8812AU_8821AU_linux

sudo make -f Makefile.dkms install

sudo dkms status: rtl8812au, 4.3.14, 4.15.0-34-generic, x86_64: installed


Previously I've been able to depmod -a and then plug/unplug the usb module but had to actually reboot this time.

Screenshot showing Arc-Dark theme, conky and tilda along with Sparkylinux: 

View the most recent posts on the forum