Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Switching GPU

Started by NexusPenguin, May 01, 2016, 12:37:25 PM

Previous topic - Next topic



I am currently using Sparky Linux in it's latest version (I think it's 4.3).
So far I am pleased with it as it seems to fullfill my needs :-)

The system runs on the following machine :
- Apple Mac Pro
- dual Xeon Hexa-Core running @2.93Ghz ;
- 40GB of RAM ;
- system installed on mSATA SSD installed on PCI card ;
- Home folder on Intel DC-S3500 600GB SSD ;
- ATI Radeon HD 5870 GPU.

I think that the weak spot in this config is the GPU.
So I would like to replace it.
I already bought a Radeon HD 7970.
I know the card is not fualty.
My system can boot into Linux, Mac or Windows.
In MacOS, the card scores 1550 points in Unigine (OpenGL) and it reaches the 2000 points
In Windows using DirectX.
And each time it is reported as : "AMD Radeon HD 7970 - 3GB RAM".

But when I boot Linux (Linux Mint Debian Edition before, Sparky Linux now), it does not work properly.
It's detected as hardware (gprep says "Tahiti" which is correct), but on the software side, it doesn't seem that it's recognized.
Here are the symptoms :
- fan goes too fast and lound ;
- fan doesn't really go to sleep as it should ;
- benchmark performances are poor (Unigine Valley => 850 points). 
- benchmark tool reports "Unknown GPU - 256MB VRam".

I tried to play with drivers in Linux, but that resulted to be a night mare :
- in some cases, I simply got a black screen. Blinking _ and after several seconds, alert message saying that X Server could not load :-( As I don't know how to get rid of that, that means : new fresh install (yeah, I'm stupid, but don't forget that 1 month ago I only ran MacOs X so Please forgive me !) ;
- drivers messed up but booting machine in the other scenario. I can access the "X-Server" but it seems the drivers are somewhat messed up because the card goes loud again...

I am also offered a really nice card for a really fair price : a NVidia Geforce GTX 690, which is basically 2 GTX 680 on the same card and offering performances that are on par or vastly superior to a NVidia GTX 970.
I haven't bought it, but I had the opportunity to test it. Same "X-server" error message.
I tried to install the NVidia drivers and then to reboot. But it says : "No Nvidia card installed".
Booted with the GTX 690 installed. Could reach the drivers downloaded from NVidia and install them using CLI, but then got to a message that the "nouveau kernel can't be disabled".

Anyone would care to tell me in regular english which steps to take to :
- try to get the HD 7970 to work ;
- to swap the AMD/ATI cards (5870 and 7970) to the GTX 690 in the most gentle way ?

I already read some things and the most useful thread right here, and was the answer to "carlo" given by mradam.

Anyways, I'd love to have specific support for this annoying issue.

Of course, if you say : "The Sapphire HD 7970 is known to be incompatible with Linux" then so be it... But as it's the "Reference design" just from Sapphire... I think it should work.

Thanks in advance for your answers.

View the most recent posts on the forum