Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: exFat hard drive non recognized  (Read 283 times)

Offline dtm2000

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
exFat hard drive non recognized
« on: July 12, 2020, 03:36:48 pm »
Hello, after the last updates my SparkyLinux GameOver edition doesn't recognize my external hard drive formatted as exFat. It always worked fine but now it can't be recognized anymore. What's wrong and how can i solve this problem? Thanks


Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2113
  • Karma: +2/-0
    • SparkyLinux
Re: exFat hard drive non recognized
« Reply #1 on: July 12, 2020, 06:52:44 pm »
Check do you have the "exfat-utils" package installed.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline dtm2000

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: exFat hard drive non recognized
« Reply #2 on: July 13, 2020, 07:49:37 pm »
ex-fat utils are already installed but don't work. I tried to unplug and then plug this hard drive but still Sparky can't recognize ex-fat. I also have another linux distro on another partition and the hard drive works perfectly. I don't know what else to do to let it work on Sparky..

Offline bin

  • Newbie
  • *
  • Posts: 23
  • Karma: +0/-0
Re: exFat hard drive non recognized
« Reply #3 on: July 14, 2020, 06:38:00 am »
What happens if you run

Code: [Select]
sudo mount -t exfat /dev/sdxxx /media/exfat
You need to establish the drive ID as it could be sdb1 sdc1 etc depending on your setup.

I normally use dmesg to show me what the drive is but other methods are available


Offline dtm2000

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: exFat hard drive non recognized
« Reply #4 on: July 14, 2020, 08:41:41 pm »
it says : can't find in /etc/fstab.
What does it mean?

Offline Niggazzz

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: exFat hard drive non recognized
« Reply #5 on: July 15, 2020, 04:20:20 am »
Menu
Preferences
File Manager settings
Advanced> enable volume management

Offline dtm2000

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: exFat hard drive non recognized
« Reply #6 on: July 19, 2020, 01:51:45 am »
ok finally
Menu
Preferences
File Manager settings
Advanced> enable volume management

ok finally it worked. Thank you so much!  :)