Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: My monitor's optimum settings are 1600x900 resolution with 60Hz frequency...  (Read 172 times)

Offline vijay1700

  • Newbie
  • *
  • Posts: 2
My monitor's optimum settings are 1600x900 resolution with 60Hz frequency...This is NOT listed at all. How to permanently add this resolution to the monitor settings and also avoid the OS from NOT loading (by default) ANY OTHER resolution while at log-in screen? The OS actually automatically loads some resolution with 120 Hz frequency every time at the log-in screen!
« Last Edit: October 30, 2019, 06:09:51 am by vijay1700 »

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 656
Your OS is Sparky, basically Debian.

Your DE (desktop environment) might be a big part of the 120 hz error. 

Please post outpur of "inxi -bGS"  ##   Ctl-Shift-C will copy from the terminal  please use the # button to mark up the xml as code.  example follows

Code: [Select]

dbnbuster:~$ inxi -bGS
System:    Host: dbnbuster Kernel: 4.19.0-6-amd64 x86_64 bits: 64 Desktop: LXQt 0.14.1 Distro: Debian GNU/Linux 10 (buster)
Machine:   Type: Desktop System: Gigabyte product: H81M-S2H GSM v: N/A serial: <root required>
           Mobo: Gigabyte model: H81M-S2H GSM v: x.x serial: <root required> BIOS: American Megatrends v: F2 date: 08/11/2015
CPU:       Dual Core: Intel Core i3-4170 type: MT MCP speed: 1215 MHz min/max: 800/3700 MHz
Graphics:  Device-1: Intel 4th Generation Core Processor Family Integrated Graphics driver: i915 v: kernel
           Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa DRI Intel Haswell v: 4.5 Mesa 18.3.6
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           Device-2: Realtek RTL8812AU 802.11a/b/g/n/ac 2T2R DB WLAN Adapter type: USB driver: rtl8812au
Drives:    Local Storage: total: 2.27 TiB used: 496.41 GiB (21.3%)
Info:      Processes: 206 Uptime: 3h 27m Memory: 11.20 GiB used: 2.28 GiB (20.4%) Shell: bash inxi: 3.0.32

Making an .xorg.conf might fix this.  Normally xorg.conf is not generated anymore.  You can search for it with "locate xorg.conf"   Prefix of /usr/share/    for all means you do not have one. 

If others can take the ball and run with the op's replies - much appreciated.   TIA

peace  out.
Don't make a FrankenDebian

Offline vijay1700

  • Newbie
  • *
  • Posts: 2
Thanks for the reply :)

Since I am a novice, I don't know what you meant when you said - "please use the # button to mark up the xml as code" - Sorry!

Here is the output of "inxi -bGS" command

Code: [Select]
shivu@Sparky-Linux-OS:~$ inxi -bGS
System: Host: Sparky-Linux-OS Kernel: 4.19.0-6-amd64 x86_64 bits: 64 Desktop: LXQt 0.14.1
Distro: SparkyLinux 5.9 (Nibiru)
Machine: Type: Desktop Mobo: Intel model: DZ68PL v: AAG42750-301 serial: <root required>
BIOS: Intel v: PLZ6810H.86A.0002.2011.1011.1505 date: 10/11/2011
CPU: Quad Core: Intel Core i5-2400 type: MCP speed: 1596 MHz min/max: 1600/3400 MHz
Graphics: Device-1: NVIDIA G96 [GeForce 9500 GT] driver: nouveau v: kernel
Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa tty: N/A
OpenGL: renderer: NV96 v: 3.3 Mesa 18.3.6
Network: Device-1: Intel 82579V Gigabit Network driver: e1000e
Drives: Local Storage: total: 2.05 TiB used: 37.23 GiB (1.8%)
Info: Processes: 223 Uptime: 1h 14m Memory: 5.80 GiB used: 2.54 GiB (43.8%) Shell: bash inxi: 3.0.32

Here is the output of "locate xorg.conf" command:

Code: [Select]
/usr/share/X11/xorg.conf.d
/usr/share/X11/xorg.conf.d/10-evdev.conf
/usr/share/X11/xorg.conf.d/10-quirks.conf
/usr/share/X11/xorg.conf.d/50-synaptics.conf
/usr/share/X11/xorg.conf.d/50-vmmouse.conf
/usr/share/X11/xorg.conf.d/50-wacom.conf
/usr/share/man/man5/xorg.conf.5.gz
/usr/share/man/man5/xorg.conf.d.5.gz

What I did before posting this thread: I tried these...
Code: [Select]
sudo xrandr
sudo cvt 1600 900
sudo xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
sudo xrandr --addmode VGA-1 "1600x900_60.00"
sudo xrandr --output VGA-1 --mode "1600×900"
sudo xrandr -s 1600x900
sudo xrandr -s 1600x900 -r 50
sudo xrandr --fb 1600x900 --dpi 86 --screen 0 ----- ~/.xinitrc should have execute permission!
gedit ~/.profile

Added these lines to gedit ~/.profile   (gedit was not there by default, so I installed it)
Code: [Select]
xrandr --newmode "1600x900_60.00" 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync
xrandr --addmode VGA-0 "1600x900_60.00"

and/or

Code: [Select]
xrandr --output VGA-0 --mode "1600×900"
xrandr -s 1600x900

System did not save these settings even though I applied and saved the settings, but the saved one automatically turned to 1024x768 resolution even in the saved list! These were for Ubuntu, I do not know for Debian...I will try to find out from my end too...

By that time, if you or anyone could type-in a step-by-step procedure to create 1600x900 60 Hz resolution into the list permanently and also avoid the OS from not loading some other resolution even while logging in at the log-in screen would be of helpful  :)
« Last Edit: November 02, 2019, 09:57:20 am by lami07 »

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 656
Above the blasted emoticons is a field of buttons to format text, sup for superscript,  sub for subscript
Code: [Select]
# for code, etc. etc. 

Since all your xorg.conf are prefixed - preceeded by /usr/share    - that means you do not have an xorg.conf. 

I woke up and am off to work in less than 1 hour. 

Sparky 5.9 LXQT             Nvidia users please respond. 
Bios is 2011   so Nouveau should work.  presumably
I am a hobbyist        Sparky 6.9 is the correct choice for a novice.  Off to work.
« Last Edit: November 02, 2019, 04:04:32 am by paxmark1 »
Don't make a FrankenDebian