Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Installation error : Boost.Python error in job "bootloader"[SOVLED]

Started by 108saimon, December 07, 2018, 07:45:26 AM

Previous topic - Next topic

108saimon

I trying install sparkyLinux 5.5 gameover edition and sparkyLinux 4.9 stable.
Always on ~84% of installation same error :

Boost.Python error in job "bootloader".
Command 'grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Sparky --force' returned non-zero exit status 1.
grub-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn't exist. Please specify --target or --directory.

Traceback:
...on my screenshot : https://prnt.sc/lrtp9c (don't fear russian word on top of error - its translate like "installation failed")

info :
I have this error on my PC and notebook both.
I use iso 5.5 gameover and 4.9 - on both devices same error.
Other distros install correctly - linux mint 19, Q4OS, debian 8, lubuntu and other.
Device i use to intall - usb created with multiBoot - i have many distros on it.
http://liveusb.info/dotclear/ (site with this programm)
But other distros from that usb install correctly.
BIOS have UEFI and legacy accepted option.
But i don't have installed grub now(and i don't know i need install it to install sparky? other distros not needed)

I really want istall it cause many articles describe gameover edition like on of best to linux gaming. I trying now leave windows for good. But i need distro who have very good support steam(but not steam OS casuse i need dev tools and i really hate GNOME 3+ wm)

Please help - what i need do to install sparky?

P.S. sorry for my bad language skill, i from Russia

108saimon

Bump

Common guys.
No one get this error before?

I see people write about same problem on manjaro :
https://forum.manjaro.org/t/installation-failed-error-in-job-bootloader/6046/5

...and chakra :
https://community.chakralinux.org/t/installation-failed-boost-python-error-in-job-bootloader/6312

My en_lang is bad and i don't understand - is solved find, but if i right - its all about UEFI
Maybe this is answer :
https://forum.manjaro.org/t/installation-failed-error-in-job-bootloader/6046/5#post_6

Or this not help?



pavroo

Looks like it could be calamares related issue, did you try to install sparky using Sparky Advanced Installer?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

108saimon

Quote from: pavroo on December 07, 2018, 12:31:41 PM
Looks like it could be calamares related issue, did you try to install sparky using Sparky Advanced Installer?
No im not.
I know about it only now from your message.
Thanks great.

But i'm not really expirienced linux user.(and i not have good en_lang skill)
I dont understand from articles - how i can use it. Following this article : https://sparkylinux.org/wiki/doku.php/advanced_installer i have some question :

1) I just load live usb, gameover edition for example and use console, to use Sparky Advanced Installer(SAI next)?
2) Or i need download and use some special iso(minimal ISO, i right?) where SAI is included, and after then install "sparky-meta-game" on installed edition?
https://sparkylinux.org/wiki/doku.php/minimal
https://sparkylinux.org/wiki/doku.php/sparky_gameover
3) Or i can install SAI on live usb gameover edition from live usb console and then use article instruction?
4) Also, in articles about SAI i see using "sudo", if i run this command in sparky live usb what sudo/root pass i need use?


pavroo

All Sparky iso images have the advanced installer preinstalled as a backup to the default one.
What you have to do is updating it in the live system, so...
Run GameOver live iso, open a terminal emulator and do:
sudo apt update
sudo apt install sparky-backup-core

Then run Advaned Installer from menu.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

108saimon

Quote from: pavroo on December 07, 2018, 03:41:27 PM
All Sparky iso images have the advanced installer preinstalled as a backup to the default one.
What you have to do is updating it in the live system, so...
Run GameOver live iso, open a terminal emulator and do:
sudo apt update
sudo apt install sparky-backup-core

Then run Advaned Installer from menu.
Thanks, great.
I'm trying it home today.
I want know it yesterday. But yesterday from my home PC i always see error "error occured bla-bla bot spam you banned forever" whean i try go to the this forum.
I don't know why i see it from home network.

UPD. its work perfect, thanks again

View the most recent posts on the forum