Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

SOLVED: util-linux deb BTS 905303 linkage with bash-completion

Started by paxmark1, August 03, 2018, 05:14:26 AM

Previous topic - Next topic


apt-list flagged this one for me, I am conservative, I will  apt-hold ultil-linux.   I declined the full-upgrade.  I will check on tomorrow. 

If it is real, I'm impressed that it got past Sid.  Peace out.

EDIT  Getting solved.  Fix is in Sid and it is a bug most would never see. I will be apt full-upgrading soon.  .
   The bugreport itself is an  example of how good  it can get..     

EDIT Fix is in Testing.  Apt list change for "su" needed more explaining for me. 
Quoteutil-linux (2.32-0.4) unstable; urgency=medium

  The util-linux implementation of /bin/su is now used, replacing the
  one previously supplied by src:shadow (shipped in login package), and
  bringing Debian in line with other modern distributions. The two
  implementations are very similar but have some minor differences (and
  there might be more that was not yet noticed ofcourse), e.g.

  - new 'su' (with no args, i.e. when preserving the environment) also
    preserves PATH and IFS, while old su would always reset PATH and IFS
    even in 'preserve environment' mode.
  - su '' (empty user string) used to give root, but now returns an error.
  - previously su only had one pam config, but now 'su -' is configured
    separately in /etc/pam.d/su-l

  The first difference is probably the most user visible one. Doing
  plain 'su' is a really bad idea for many reasons, so using 'su -' is
  strongly recommended to always get a newly set up environment similar
  to a normal login. If you want to restore behaviour more similar to
  the previous one you can add 'ALWAYS_SET_PATH yes' in /etc/login.defs.

However, in a terminal, you still can just type "su" with nothing else and after your root password will get you in. I get no error message.   However - from Siduction forum        ##  towards the end of page 2

Quote"su" without arguments works - but it misses to set the PATHs to
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

View the most recent posts on the forum