Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Can't get out of Openbox [solved]

Started by zeh, April 10, 2017, 05:30:08 PM

Previous topic - Next topic


I'm running a LXQt instalation where I've installed MATE. Having Openbox as choice as well, I've decided to give it a try. Found out that many entries in the OB menu do not work. They return something like «Failed to execute child process "wm-logout" (No such file or directory)» - this is the case for the "exit" entry, but happens similarly with some others.
The entry "restart" simply doesn't do anything. The same happens with some others.
I've tried shutting down the computer in the hope that in the next boot I'd get the initial screen where I can choose the desktop I want to use for the session, but the system memorizes the last session and automatically boots into it.
How can I leave OB and get back to the initial screen? 


If you installed LXQt, you have gotten pure Openbox as defualt.
To get missing apps working, you should install them manually, for example 'wm-logout', etc. or install 'sparky-desktop-openbox' meta pack which provides all required by obmenu tools.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Thank you for the fast reply!
Installed wm-logout and... problem solved.
If you allow me a further word, for a beginner it's a little bit strange to ear that OB comes by default but doesn't have everything ready by default...
Anyway, very pleased with the fast and accurate reply. And with the distro, of course. Thanks again.


I checked the live config of Lxqt edition, and the obmenu config shouldn't be there. Just removed, thank's.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]

View the most recent posts on the forum