Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

i think systemd doesn't behave

Started by carlo, August 17, 2016, 02:22:21 PM

Previous topic - Next topic


hi all
sparky 4.3 works very fine in live, but when i install and boot it, i get that timeout for busy devices, then i'm prompted to insert password or press ctrl-d to go on: if i go on booting it gets stuck, if i insert password i'm given terminal there's little i can do.. even startx seems to not exist
if i install sparky 4.2 and update it, the very same happens
the only way to have a working machine (with xorg and the like) when this happens, seems to start the recovery mode, and then, rather than insert root password, to press ctrl-d in order to boot normally

it seems to me that recovery boot skips some passage or something which scrambles my system
if you want later i can upload the journal of the boot, but if memory assists me there should be systemd related issues


Yes, it happens sometimes.
To handle with that manually, remove 'splash' kernel boot option from the GRUB list.
I've seen the same problem with plymouth on Arch Linux too.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Ay ay captain
I'll try and report tomorrow
Nite nite


Wouldn't  hurt for you to look at output of "sudo journalctl -b -0" to view the systemd logs.  To limit to viewing failing services, type "sudo journalctl -b -0 | grep ailed" 
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


please try to not laugh at this:

i've tried to boot in order to export the journal log
but after i was prompt press ctrl.d or give root password the system wasn't accepting any command: all i could do was turning on and off keyboard leds and press ctrl-f1 f2.. or ctr-alt-del

i've tried to plug the ps2 keyboard
and system prompted again for password, but it went on writing those status lines for the boot, so that again i could only send the reset signal

i have removed quiet splash from the grub lines and it happens the very same


little update:
i've upgraded sparky,
removed splash (together with sparky core and others)
reconfigured grub, removed the quiet splash
it still behaves the same

View the most recent posts on the forum