Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

installation in BIOS mode

Started by pampelmoose, July 05, 2016, 01:18:58 AM

Previous topic - Next topic


I am trying to install SparkyLinux [4.3 x86-64] on a computer which already has other distros (and grub2) installed. Although the motherboard is UEFI-compatible, the existing installations are all non-UEFI .

So is there any way to install SparkyLinux to my hard drive in legacy mode, so that I can multi-boot with the other (non-UEFI) distros already there?



If your machine is set to legacy, and you alredy installed other Linux distros in the legacy mode, you shoudn't have problem to install Sparky in the same mode.

Run Sparky live and than after loading a desktop, check have the efi kernel modules been loaded:
lsmod | grep efi
If the output is empty, it means it does not work in UEFI mode so the installer will install Sparky with grub-pc instead of grub-efi.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Thanks for the tip. The "lsmod | grep efi" command yielded empty output in my existing distributions, but it gave me some output when I ran sparky live. So my motherboard does support efi. But I did not want to use efi.

So the tip did not really work, but I think I have figured out how to install sparky in non-efi mode.

First of all, the motherboard did support efi mode ; the problem was that  my other existing distributions had been installed in legacy mode, so that I needed to install Sparky in legacy mode. Which turns out to be difficult to do.

The "advanced installer" seems not to allow legacy installations. Although the installer says that I can make the choice of efi or non-efi mode for installation, it does not actually give me that choice.

Similarly the regular installation also does not give me the choice.

The only way seems to be to use the regular installer, in "expert" mode. So I mounted the partition to which I wanted to install sparky to "/target", and went through the "expert" installation, which seems to have worked.

View the most recent posts on the forum