Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

No sound after fresh install 64bit

Started by PNWDrew, December 23, 2014, 02:23:10 AM

Previous topic - Next topic


I installed the 64bit version and have odd sound output issues now.
Initially I had no audio at all, neither my USB speakers or monitor speakers worked.  Both sets of speakers worked great in 32bit Sparky just a few hours ago.

After a few searches for solutions I created a conf file to set the USB card as default and am able to get sound out of Iceweasel now, although I've lost control of the volume from the system volume control.  I get no sound out of Chromium or any other program I've tried.

Any ideas?

edit  - I was able to get audio out of Chromium after removing pulseaudio and alsa then reinstalling alsa.  I still don't have control over it through the system volume slider though.  I can get used to this I think.  Would love a system-wide mute however.


Can you open Menu-> Multimedia-> GNOME-AlcaMixer and check isn't something muted? 
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Nothing muted. 

I was able to get some sound output to route to USB speakers.  For now it is passable. I expect that will change when I next reboot, every reboot seems to bring a new issue.  Yesterday's fun was loss of sound, today I noticed that I had lost printer function at some point.  I'll start a new thread for that one, as it is necessary if I expect to use Linux primarily.


Scratch that, no sound again.  I had to shut down to install a case fan.  Every time I start this system I lose something! 
Nothing is muted in Alsa.
I can't get anything through the monitor speakers either.


Make sound test, run it in a text console:
aplay /usr/share/sounds/alsa/*.wav
speaker-test -c 2
Show output of the commands:
aplay -l
lsmod |grep snd
Read also:
It's helpful too:
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Thanks for the response. Sorry about the long delay on my part.

I'm not too concerned at the moment. For the most part I have audio.  Once in a while it disappears for unknown reasons.  I can get it back by running alsamixer and repeatedly selecting USB sound card, as long as I close anything else that may use sound (browsers mainly in my case) it will return after a few minutes.  Not sure what that is about but it hasn't been happening too often.  It's been up for about 48hrs now without an issue.

When it goes down the error I get in Alsamixer and Gnome Alsa Mixer is something like  "This Device has No Controls".  I'll try to screenshot it next time I see it.

All in all I've been happy with Sparky, I've been trying to do what I can with the terminal so I can learn.

View the most recent posts on the forum