SparkyLinux Forums

Installation & Upgrade => System upgrading => Topic started by: blargh on June 27, 2020, 11:09:28 am

Title: The repository 'https://sparkylinux.org/repo testing Release' no longer...
Post by: blargh on June 27, 2020, 11:09:28 am
I have Sparky Linux on an old seldom used box and I am trying to update it this weekend. I get this message when I run apt update. It appears I am on Bullseye. I don't have much experience with upgrading distros but I did mange to correct the Debian testing/updates to testing-security.

Code: [Select]
The repository 'https://sparkylinux.org/repo testing Release' no longer has a Release file.
My Sparky sources show:

Code: [Select]
### sparky unstable repository
deb https://sparkylinux.org/repo/ unstable main
deb-src https://sparkylinux.org/repo/ unstable main

### sparky testing repository
### used as default by all sparky editions
deb https://sparkylinux.org/repo/ testing main
deb-src https://sparkylinux.org/repo/ testing main

How should I proceed?
Title: Re: The repository 'https://sparkylinux.org/repo testing Release' no longer...
Post by: pavroo on June 27, 2020, 12:05:17 pm
Sparky repos changed a few months ago.
Follow Wiki to set the present one:
https://wiki.sparkylinux.org/doku.php/repository
Title: Re: The repository 'https://sparkylinux.org/repo testing Release' no longer...
Post by: blargh on June 28, 2020, 10:39:37 am
Ah yes, I see now that lsb_release -a says (po-tolo) so I can use one of those repos. I got hung up with codename bullseye.
Title: Re: The repository 'https://sparkylinux.org/repo testing Release' no longer...
Post by: blargh on June 28, 2020, 10:52:05 am
That helped somewhat but now I have a version issue.

$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnustep-base-runtime : Depends: gnustep-base-common (= 1.27.0-3) but 1.26.0-6 is to be installed
 libgnustep-base1.27 : Depends: gnustep-base-common (= 1.27.0-3) but 1.26.0-6 is to be installed
E: Broken packages
Title: Re: The repository 'https://sparkylinux.org/repo testing Release' no longer...
Post by: blargh on June 28, 2020, 01:55:17 pm
Right, so I solved it by removing the problematic package, then upgrading everything, and afterwards install gnustep-common (or whatever) again.