SparkyLinux Forums

Installation & Upgrade => System upgrading => Topic started by: thesailor on June 27, 2020, 02:14:52 am

Title: Programs requiring root do not load
Post by: thesailor on June 27, 2020, 02:14:52 am
I think this happened after a simple rolling upgrade. I am running the testing with Xfce. Normally on clicking to run a root application such as Synaptic a box pops up asking for password, but now it does not. I can load the application by using sudo in a terminal, although I get this warning: (synaptic:30117): dbind-WARNING **: 12:12:15.458: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-mnxXy7mUkg: Connection refused
Anyone know what could be causing it?
Title: Re: Programs requiring root do not load
Post by: paxmark1 on June 27, 2020, 05:26:09 am
What is your definition of a "root program".   

To the best of my knowledge gui's are never to be run as root.

Either run synaptic as designed via its defacto use of sudo  or command lines via sudo in a terminal.  If you really know what you are doing you can go su - root and run updates, upgrades as root. 

If you are in testing - rolling I would strongly urge you to only use aptus or use command line programs,  I prefer "apt" to "apt-get".  People with more knowledge than me say that apitude can make poor choices in a testing or unstable install. 

Short answer - synaptic probably fails on purpose when people use it via su - root. enabled terminal. 

Usage of aptus will give you the most support here.
Title: Re: Programs requiring root do not load
Post by: bin on June 27, 2020, 06:46:54 am
The use of sudo  - or gsudo - is a thing of the past.

If you launch synaptic with sudo then that's the error it creates.

synaptic-pkexec (no spaces) is the correct command

You need to take a look at the menu entry itself to see if that has been broken.

Also look in Session and Startup Applications and make sure PoilcyKit Authentication Agent is set to start.
Title: Re: Programs requiring root do not load
Post by: thesailor on June 27, 2020, 07:02:34 am
That's it! Policykit Authentication was not ticked. Don't know what happened there but thanks very much. This thing has been really irritating.

I didn't know sudo was deprecated; I use it all the time for a root file manager and to perform root tasks in a terminal. Is that bad?
Title: Re: Programs requiring root do not load
Post by: paxmark1 on June 28, 2020, 05:01:11 am
To the best of my knowledge sudo is not deprecated. I have not seen it mentioned in PlanetDebian or in apt-list changes.  I may have missed it.       But  to su - root  in a terminal   and then fire up any GUIprogram is a security risk. 

examples below     "user" is the name for the user logged in  - could be tallwaliking  or any phrase you  used to define who lives at  /home/

 sudo GUIprogram  is often a chance of security problems. The gui's that perform actions that need more permissions than "user"  will ask you for the passwork for "user". 

thesailor  - I did ask what your definition of what is a "root program".     

https://wiki.debian.org/sudo


Title: Re: Programs requiring root do not load
Post by: bin on June 28, 2020, 07:10:23 am
What he says. Sudo is obviously not deprecated but should not be used to launch gui apps for the reasons stated.

It was rather early in the morning.......... :)
Title: Re: Programs requiring root do not load
Post by: linuxdawg on August 12, 2020, 11:06:52 pm
sudo synaptic

works fine for me...GUI and all.