Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Recent posts

#1
Newbie questions / Re: Graphic issue with Sparky ...
Last post by TRon - Today at 03:28:28 AM
My HD finally arrived today and I went with installing Linux Mint Mate. No offense to sparky but their community seem a bit larger and I was able to find some related issues in their forums.

The graphical issues are solved after having done some updates but mint mate 21 still has some bugs related to the BIOS of this jasper lake machine (seem to be a common issue for newer machines, some issues were fixed around kernel 5.15 but re-introduced in newer kernels). Unfortunately Sparky (but also other current distro's that I have tried/mentioned) show similar issues.

As soon as Sparky Mate becomes more mature I'll give that a go as I'm very pleased with Sparky on my old machine and would like to repeat that for this newer machine.

Is there a dedicated/known time-line/release schedule for Sparky Mate ?

Sorry for the noise.
#2
Sparky applications / Re: Can't find ZSH package in ...
Last post by pavroo - December 02, 2022, 06:17:43 PM
Sparky uses Debian repos as default, stored in:
/etc/apt/sources.listDo you have it?
Looks like you use Sparky rolling "orion" repos so Debian "bookworm" is required too.
#3
Sparky applications / Re: Can't find ZSH package in ...
Last post by gabvil - December 02, 2022, 03:15:39 PM
Quote from: pavroo on December 01, 2022, 09:43:31 PMHold on, you need 'zsh', the shell, right, not 'zfs'?
apt policy zsh
zsh:
  Zainstalowana: (brak)
  Kandydująca:   5.9-2
  Tabela wersji:
     5.9-2 500
        500 http://deb.debian.org/debian bookworm/main amd64 Packages
If yes, it is in debian main repos anyway.


That's right! It's zsh, do I need to setup those Debian repos?
Since they are not set on my current sources.

Regards.-
#4
Sparky applications / Steam EAC isssue - Fail to loa...
Last post by Stormcorporal - December 02, 2022, 02:02:37 PM
Picture of error:

Steam  Failed Easy Anticheat module detection image

Cause: This is due to DT_HASH being removed and replaced by DT_GNU_HASH in Glibc 2.34 and higher versions.
Though, Most users detected it running Glibc 2.36 versions.

Solution: Gentoo, Arch, and other non Ubuntu/Debian distros have patched their Linux Operating system to include both DT_HASH and DT_GNU_HASH in "--hash-style=both". I am not a programmer and still Learning Linux to know what this means. Just did my research on the issue to help SparkyLinux be the first of Ubuntu/Debian distros to resolve this issue since there isn't any fix for them besides using an older version of Glibc less than 2.34. I hope this can be resolved as stated above or some other way that Sparky devs may know. In case more information is needed, check out the following links:

https://www.phoronix.com/news/Glibc-2.36-EAC-Problems

https://maskray.me/blog/2022-08-21-glibc-and-dt-gnu-hash
#5
Sparky applications / Re: Can't find ZSH package in ...
Last post by pavroo - December 01, 2022, 09:43:31 PM
Hold on, you need 'zsh', the shell, right, not 'zfs'?
apt policy zsh
zsh:
  Zainstalowana: (brak)
  Kandydująca:   5.9-2
  Tabela wersji:
     5.9-2 500
        500 http://deb.debian.org/debian bookworm/main amd64 Packages
If yes, it is in debian main repos anyway.
#6
Sparky applications / Re: Can't find ZSH package in ...
Last post by pavroo - December 01, 2022, 09:40:42 PM
It's impossible.
sudo apt update
sudo apt policy zfsutils-linux

zfsutils-linux:
  Zainstalowana: (brak)
  Kandydująca:   2.1.6-3
  Tabela wersji:
     2.1.6-3 500
        500 http://deb.debian.org/debian bookworm/contrib amd64 Packages

It is in Debian contrib repos, so make sure you have it enabled.
#7
Sparky applications / Re: Can't find ZSH package in ...
Last post by gabvil - December 01, 2022, 08:43:44 PM
Quote from: pavroo on December 01, 2022, 08:18:52 PMTry to install 'zfsutils-linux'

Tried but's not available:

gabriel@virtualbox:~$ sudo -i  
[sudo] contraseña para gabriel:   
root@virtualbox:~# apt install zfsutils-linux  
Leyendo lista de paquetes... Hecho  
Creando árbol de dependencias... Hecho  
Leyendo la información de estado... Hecho  
El paquete zfsutils-linux no está disponible, pero algún otro paquete hace referencia  
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se  
encuentra disponible desde alguna otra fuente  
 
E: El paquete «zfsutils-linux» no tiene un candidato para la instalación  
root@virtualbox:~# apt search zfs  
Ordenando... Hecho  
Buscar en todo el texto... Hecho  
parted/now 3.5-3 amd64 [instalado, local]  
disk partition manipulator  
 
root@virtualbox:~#  

*It's in spanish, but I think you get it, there's no "zfsutils-linux" package.
#8
Sparky applications / Re: Can't find ZSH package in ...
Last post by pavroo - December 01, 2022, 08:18:52 PM
Try to install 'zfsutils-linux'
#9
Sparky applications / Can't find ZSH package in 2022...
Last post by gabvil - December 01, 2022, 07:49:03 PM
Hi all,



Tried to install ZSH in the rolling version, but isn't available in the repos.

root@virtualbox:~# apt search zsh  
Ordenando... Hecho  
Buscar en todo el texto... Hecho  
root@virtualbox:~# 
 
Fresh install, do I've to add any additional repo into Sparky?

 

root@virtualbox:/etc/apt/sources.list.d# cat *.list  
# Liquorix kernel  
deb [arch=amd64 signed-by=/etc/apt/trusted.gpg.d/liquorix-keyring.gpg] http://liquorix.net/debian bookworm main  
deb-src [arch=amd64 signed-by=/etc/apt/trusted.gpg.d/liquorix-keyring.gpg] http://liquorix.net/debian bookworm main  
### sparky core repository is used by all sparky editions  
deb [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ core main  
deb-src [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ core main  
 
### sparky orion repository  
deb [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ orion main  
deb-src [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ orion main  
 
# sparky unstable repository  
deb [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ unstable main  
deb-src [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ unstable main  
root@virtualbox:/etc/apt/sources.list.d#

According to https://sparkylinux.org/sparky-repository/ I've what's needed.

Thanks and regards.
#10
System upgrading / Re: No access to synaptic, Apt...
Last post by Regerwurm63 - November 30, 2022, 10:44:14 PM
Quote from: pavroo on November 30, 2022, 07:40:28 PMHi,
Are you sure your last upgrade went well?
Try:
sudo dpkg --configure -athen:
sudo sparky-upgradeand show me an output if any problem.

classical grup-probelm with spark this came after sudo dpkg --configure -aDer GRUB-Bootloader wurde zuvor auf einem Datenträger,     
 │ der nicht mehr im System vorhanden ist oder dessen         
 │ eindeutige Kennung aus irgendeinem Grund geändert           
 │ wurde, installiert. Es ist wichtig, sicherzustellen,       
 │ dass das installierte GRUB-Core-Image synchron mit den     
 │ GRUB-Modulen und grub.cfg bleibt. Bitte prüfen Sie         
 │ erneut, um sicherzustellen, dass GRUB auf die               
 │ entsprechenden Boot-Geräte geschrieben wird. 
Installed from ad DVD

Second comand 60 processes but the above blocked all after two processes. retried with DVD in computer all the same.

View the most recent posts on the forum