Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Recent Posts

Pages: [1] 2 3 ... 10
1
Newbie questions / Re: How to switch from Xorg to wayland or xwayland?
« Last post by paxmark1 on Today at 06:13:46 am »
I did have fun with wayland and Sway WM (no DE, tiling WM) over a year ago back on Sid, i386 on an old old atom, but it died (the netbook - not sway).  If you are in rolling, you can follow Norbert Preining"s posts on Planet Debian.org about the newest things in KDE.  Note, I don't use KDE, but have nothing bad to say about it. 

https://www.preining.info/blog/2021/04/debian-kde-plasma-and-digikam-status-2021-04-07/
2
Newbie questions / Re: How to switch from Xorg to wayland or xwayland?
« Last post by MoroS on Today at 12:23:33 am »
You might want to install the plasma-workspace-wayland package as described here:
https://wiki.debian.org/Wayland#KDE

To run Wayland, you need a compositor. GNOME has one out of the box, so the experience is quite seamless. As for KDE, you'll probably need to install the package above to replace KWin "the Xorg window manager" with KWin "the Wayland compositor" (basically also a window manager, but integrated on a much lower level and much more powerful).

Also note, that this works nicely on Intel and AMD GPUs. NVIDIA with nouveau is probably OK too, but with proprietary drivers additional steps are required - you need to ensure that the driver is running in modesetting mode as described here:
https://community.kde.org/Plasma/Wayland/Nvidia
3
Newbie questions / How to switch from Xorg to wayland or xwayland?
« Last post by Gordaun on May 15, 2021, 08:07:45 pm »
So,my desktop environment is Kde,it already has the necessities installed by default it seems (thank you sparky team) but i can't see how to log into the wayland or xwayland version on the lightdm,and terminal switching to wayland only seens to work on gnome.

So,any hints of what to do?I am doing because i want to experiment and read that althought wayland has less compatibility,it's faster.
4
Sparky Linux kernel / Re: <Solved>Download older kernel
« Last post by pavroo on May 14, 2021, 05:01:16 pm »
I have launched build of kernel 5.11.21, so should be in repos in 2 hours about.
You will not get it as a regular update, have to refresh package list and install it manually.
5
Sparky Linux kernel / Re: <Solved>Download older kernel
« Last post by rektal on May 14, 2021, 04:19:34 pm »
Thank you. I understand.
I tried Xanmod kernel 5.12.3-xanmod2 and 5.11.12-rt11-xanmod1 but with no luck. Suspend is not working and I hear my fans is still running.

Only 5.11.16-sparky-amd64 works for me. Is it safe to stay on this kernel and not update to newer one?
Maybe further 5.12 kernels will work for me.
6
Sparky Linux kernel / Re: <Solved>Download older kernel
« Last post by pavroo on May 14, 2021, 12:02:44 pm »
No, I only build one, the latest kernel only.
Try Xanmod kernel instead or keep Debian's one as default.
7
Sparky Linux kernel / Re: <Solved>Download older kernel
« Last post by rektal on May 13, 2021, 05:03:06 pm »
The kernel 5.12.3 do not work with suspend mode either. I have checked the same kernel on Tumbleweed Live usb and there is the same problem.
I use kernel  5.11.16-sparky-amd64 now. Is this the last update for 5.11. kernel? There wili be no further updates for it?
8
Installation / Re: Installation Error Calamares on uefi32/64bit laptop
« Last post by Raikenzom on May 11, 2021, 05:17:15 am »
I solved this by disabling the Secure Boot.
9
Newbie questions / Re: Can't install Protonvpn
« Last post by lonegunmen on May 10, 2021, 01:08:40 am »
probably you can try to add
Code: [Select]
deb https://repo.protonvpn.com/debian unstable maininto /etc/apt/sources.list or a list file in /etc/apt/sources.list.d/

I actually tried this method a short while after making my post above. It will technically work and will allow you to install the protonvpn app, but unfortunately it still didn't work. Everytime I tried to connect with the protonvpn command line app, it would connect and then immediately disconnect. This was on a fresh install, so instead of trying to unscrew this mess, I ended up just reinstalling again and decided to do something better to use protonvpn.

With a new install of SparkyLinux 5.15 64bit LXQt version, I couldn't find any Network Manager GUI interface. Just that useless nm-tray icon near the clock. The "Edit connections" option doesn't even work with that pre-installed network icon, so if you mis-typed your password or need to change it, you're out of luck.  Why was this set-up this way? Anyway, I decided to do a little homework and install an actual functioning Network Manager GUI interface that also replaces that useless pre-installed nm-tray icon with networkmanager-applet icon. This way you could change wifi passwords, or even use protonvpn ovpn configuration file or some other vpn ovpn configuration file easily. So here is a quick rundown of what I did.

Open terminal and install these packages one at a time:

Code: [Select]
sudo apt-get install network-manager-gnome
sudo apt-get install network-manager-openvpn
sudo apt-get install network-manager-openvpn-gnome

After installing these packages, I logged out and then logged back in, and that should make the new networkmanager-applet icon appear on the panel bar near the clock. It will appear as if you have two network connection icons. Now we need to turn off the old nm-tray icon, since we don't need it anymore.

Go to Menu-->Preferences-->LXQt Settings-->Sessions Setting-->Autostart
uncheck nm-tray and close out, and then logged out and logged back in and now only the new networkmanager-applet icon should be the only network connection icon showing.

You will now have Advanced Network Configuration option in the menu now too.
Go to Menu-->Preferences-->Advanced Network Configuration

This is where you can make wifi password changes, import your vpn ovpn (such as protonvpn) configuration file, etc. Be sure to use your Openvpn username and password when you are filling in the username and password settings after importing your vpn ovpn file. Also, it may ask you to type a password in order to protect the keyring for the vpn, I just used my Openvpn password since it was easy to remember. Basically, you just import the ovpn file, type in your Openvpn username & password, a window opens asking for a keyring password (just use your openvpn password) and that should be it, I think. Save and close out of Advanced Network Configuration window. Now click on that new network connection icon near the clock, lower right hand side and a little menu should pop up, choose "VPN Connections" and your newly created vpn entry should be there. Just click the square box next to it, and it should connect to your vpn and show a little lock added to the connection icon in the tray. I tested for DNS leaks and didn't find any, so it worked great. To disconnect from vpn, just uncheck that same box next to your vpn entry and it should disconnect.

Hopefully this will help someone out there, I tried to remember each step.
10
Suggestions / Screencopy: a GUI app brings Android screen on your desktop
« Last post by jidan on May 08, 2021, 03:19:43 pm »
I wrote before about scrcpy here: https://forum.sparkylinux.org/index.php/topic,5089.0.html

As scrcpy binaries are included in bullseye repos, there's no need to build them locally, so i packed a simple yad script to simplify the procedure.
Find instructions here: https://github.com/maurosh/screencopy
and a deb file to install here: https://github.com/maurosh/screencopy/blob/main/screencopy_1.0_all.deb

The script is published under GPLv3.
Pages: [1] 2 3 ... 10