Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Recent posts

Sparky applications / Re: 'APTus AppCenter' not usea...
Last post by rektal - June 17, 2024, 08:00:13 PM
Thanks for your post Linuxuser.

I usually use terminal and
sudo spu to up-to-date my system.

Thanks for:
sudo apt autoremove to remove old kernels. It was very useful for me.
Sparky applications / Re: 'APTus AppCenter' not usea...
Last post by duststuff - June 17, 2024, 10:10:52 AM
Thanks for your latest post, Patrick. There are at least some apps that can be installed via the APTus AppCenter that can't be installed via 'apt', 'apt-get', and probably not Synaptic either. You could still find other ways to install these, but I find that the AppCenter makes the process easier. When possible, I do usually use the command-line utilities to install things since it's easier. But for updates I find it easier to use the Sparky upgrade app that automatically checks for updates, alerts you, and then runs through the process if you give it the 'OK'. If, for some reason, that runs into trouble, then I hit the command-line again to sort it out.

Interesting that you also have Nvidia graphics -- the issue might be that combined with a recent update. It would be interesting to know whether @AxL's system uses non-Nvidia graphics. Here I've got Intel and am not seeing the problem.

(This is off-topic, but I notice from your system info that you have a 'Logitech Webcam C270'. I have that web-cam and it seemed to work fine for awhile but then I started having issues with it disconnecting randomly. Have you ever experienced that?)

Newbie questions / Re: virtualbox not work
Last post by duststuff - June 17, 2024, 04:56:26 AM
I haven't done this before, but what you want to do is run virtualbox itself from the terminal; once you've done that it should start virtualbox as you are used to and then you can try to do the actions that are not working. After doing those, then you can go back to the terminal to see if there is any related output.

The first thing you need to figure out is what the command is to run virtualbox from the terminal. It may be as simple as 'virtualbox', but sometimes there is some other variation. And sometimes a program is designed so that some operations can be done from the terminal (without a GUI), so you'll need to figure out the command that will start the GUI for you. A simple online search should provide this info, or if you have something like a 'Start' or 'Apps' menu where virtualbox is included, you may be able to right-click on the virtualbox item and choose something like 'Properties' or 'Edit' to see what command it uses to start the program.
Sparky applications / Re: 'APTus AppCenter' not usea...
Last post by Linuxuser - June 16, 2024, 11:10:58 PM
Hi guys,

want you to know that I'm still there on my research for the reason(s) why 'Sparky APTus AppCenter' is not working on system configurations like mine or rektal's ...

In the meantime and for the future, I would strictly recommend not to rely on GUI tools such as 'Sparky APTus AppCenter' to manage software packages. If you - 'rektal' - prefer to use a GUI for that, then better use the robust and well-tested allrounder 'synaptic' (that comes with Debian, also installed with Sparky 7 & 8), instead.

However, I prefer the command-line utility 'apt' or 'apt-get' for installing, updating, removing, and otherwise managing deb packages (for debian based distributions). To learn more about the 'apt' command open your terminal and type 'man apt'.

Because 'APTus AppCenter' is not applicable on my machine (since my first installation of Sparky7.3 in May), I would have no other choice anyway.

Instead, I regularly use the following 'apt-get' commands in the terminal, to keep my system clean and up-to-date:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get clean

.. and additionally, if necessary:

sudo apt autoremove
.. that removes any old packages (and older kernels) that are no longer needed.

Finally, as I promised, I post here some information about my system from the output of 'inxi -Frz':

  Kernel: 6.1.0-21-686 arch: i686 bits: 32 Desktop: Openbox v: 3.6.1
    Distro: SparkyLinux 7.4 (Orion-Belt)
  Type: Desktop Mobo: ASUSTeK model: P4P800-X v: Rev 1.xx
    serial: <superuser required> BIOS: American Megatrends v: 080009
    date: 06/23/2005
  Info: single core model: Intel Pentium 4 bits: 32 type: MT cache:
    L2: 1024 KiB
  Speed (MHz): avg: 2999 min/max: N/A cores: 1: 2999 2: 2999
  Device-1: NVIDIA NV44A [GeForce 6200] driver: nouveau v: kernel
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.Org v: driver: X: loaded: nouveau
    unloaded: fbdev,modesetting,vesa dri: nouveau gpu: nouveau
    resolution: 1680x1050~60Hz
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Active apt repos in: /etc/apt/sources.list
    1: deb bookworm main contrib non-free non-free-firmware
    2: deb-src bookworm main contrib non-free non-free-firmware
    3: deb bookworm-security/updates main contrib non-free non-free-firmware
    4: deb-src bookworm-security/updates main contrib non-free non-free-firmware
    5: deb bookworm-updates main contrib non-free non-free-firmware
    6: deb-src bookworm-updates main contrib non-free non-free-firmware
    7: deb bookworm main non-free
  Active apt repos in: /etc/apt/sources.list.d/sparky.list
    1: deb [signed-by=/usr/share/keyrings/sparky.gpg.key] core main
    2: deb-src [signed-by=/usr/share/keyrings/sparky.gpg.key] core main
    3: deb [signed-by=/usr/share/keyrings/sparky.gpg.key] orion main
    4: deb-src [signed-by=/usr/share/keyrings/sparky.gpg.key] orion main
  Processes: 165 Uptime: 2h 1m Memory: 2.95 GiB used: 1.3 GiB (44.1%)
  Shell: Bash inxi: 3.3.26

Until then,

Good luck!


Newbie questions / Re: virtualbox not work
Last post by bertgio - June 16, 2024, 08:17:48 PM
Thanks for the suggestion, in the meantime I tried on another PC with SparkyLinux KDE first installation kernel and the result remained the same. The only ISO that can show me the VM desktop is pmagic_2013_02_28_i586.iso. I tried the ISO Parted_Magic_2021.09.15_x64.iso but the result is the same as described in posts n.1. I will try to follow your advice even if I don't know how but I'm sure I can launch a VM from the terminal. Thanks again.
System upgrading / Re: [RESOLU] System update req...
Last post by piotrfr - June 15, 2024, 11:04:10 PM
Bonjour Paul74, et toutes et tous les autres, et toutes mes excuses sur le fait de ne pas avoir remercier ta réponse sympa et explicative... Oups...

Par contre, tu parles d'avoir effectué les mises à jour de 7.1 etc..., mais tu as fait comment ces màj ?

Avec tous mes tests, mon systeme est un petit peu chamboulé, j'aurai aimé savoir si je pouvais installer directement la dernière version et si cela est possible, est-ce que cela "nettoie" l'ancien systeme ? Pour ma part, la version 6.7, Po-Tolo ?
Et y a-t-il une solution pour mettre à jour le systeme sans supprimer les diverses applications installées ?

Merci pour l'aide à venir et bonne fin de journée à toutes et tous


Hello Paul74, and all the others, and my apologies for not having thanked your nice and explanatory response... Oops...

On the other hand, you talk about having carried out the updates to 7.1 etc..., but how did you do these updates?

With all my tests, my system is a little messed up, I would have liked to know if I could directly install the latest version and if this is possible, does it "clean" the old system?  For my part, version 6.7, Po-Tolo?
And is there a solution to update the system without deleting the various installed applications?

Thank you for the help and have a good rest of the day everyone.
Newbie questions / Re: virtualbox not work
Last post by duststuff - June 15, 2024, 10:46:10 AM
You could try running it in the terminal to see if it gives any output that would help you understand why it's not working.
Sparky applications / Re: 'APTus AppCenter' not usea...
Last post by rektal - June 14, 2024, 08:16:46 PM
I couldn't find which packages are missing. APTus is broken for me now. I couldn't fix it.
I hope that developer will fix it somehow in the future.
I can only rely on him.
Sparky applications / Re: access to smarttphone memo...
Last post by duststuff - June 14, 2024, 06:11:01 PM
Besides what I've already mentioned, here's a couple other things that might help:

1. Have you checked the support and forum pages of the Fairphone website? It looks like there might be some ideas there.

2. To see if your system is recognizing the phone, you can try listing the USB devices on your system with the following command:
lsusbIf you're not sure how it will be listed, run the command with the phone unconnected and note the output; then connect the device and run it again and compare the output to see what is new. If nothing is new, then your system is not recognizing it for some reason.

3. If you have more than one USB port, you could try others to see if they work.

4. You could also look at the last part of the output of the following command immediately after connecting the phone to see if there are any warnings or errors that might be related:
5. Also, when you're looking for help on this or other similar forums, it would be good for you to include as much relevant information as possible. You can use the command-line tool 'inxi' and its various options to generate general / specific / relevant information about your system that you can then copy from the terminal (Shift + Ctrl + C) and paste into your post here using the code markers for easier readability. (Hover over the icons above where you're writing till you see the one marked 'Code', click on that and it should give you code markers like this: "code""/code" except with bracket markers in place of the quote markers. Then just paste the inxi output from the terminal between the code markers so it will show up correctly [you can use the preview option to check it's working as expected].) The 'inxi' tool has lots of different options -- here is just one example:
inxi -Frz(The '-F' option includes basic information for quite a few parts of your system, the '-r' option provides details on your repos, and the '-z' option filters out some things for privacy / security, which is probably a good idea when posting in public spaces like this forum.)
Sparky applications / Re: access to smarttphone memo...
Last post by lukand - June 14, 2024, 03:35:42 PM
I tried to copy some files from PC to the memory card via USB. Unfortunately, unlike in the past, there is no way to see the icons which provide the possibility to access the memory card and internal smartphone memory as well. Despite restart, the situation is the same. There is much free space on the 512 GB Samsung memory card. The only mode I applied whilst connecting Fairphone 4 was to transfer files via USB

View the most recent posts on the forum