Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Recent posts

#1
Newbie questions / Re: virtualbox not work
Last post by duststuff - Today at 10:46:10 AM
You could try running it in the terminal to see if it gives any output that would help you understand why it's not working.
#2
Sparky applications / Re: 'APTus AppCenter' not usea...
Last post by rektal - June 14, 2024, 08:16:46 PM
I couldn't find which packages are missing. APTus is broken for me now. I couldn't fix it.
I hope that developer will fix it somehow in the future.
I can only rely on him.
#3
Sparky applications / Re: access to smarttphone memo...
Last post by duststuff - June 14, 2024, 06:11:01 PM
Besides what I've already mentioned, here's a couple other things that might help:

1. Have you checked the support and forum pages of the Fairphone website? It looks like there might be some ideas there.

2. To see if your system is recognizing the phone, you can try listing the USB devices on your system with the following command:
lsusbIf you're not sure how it will be listed, run the command with the phone unconnected and note the output; then connect the device and run it again and compare the output to see what is new. If nothing is new, then your system is not recognizing it for some reason.

3. If you have more than one USB port, you could try others to see if they work.

4. You could also look at the last part of the output of the following command immediately after connecting the phone to see if there are any warnings or errors that might be related:
dmesg
5. Also, when you're looking for help on this or other similar forums, it would be good for you to include as much relevant information as possible. You can use the command-line tool 'inxi' and its various options to generate general / specific / relevant information about your system that you can then copy from the terminal (Shift + Ctrl + C) and paste into your post here using the code markers for easier readability. (Hover over the icons above where you're writing till you see the one marked 'Code', click on that and it should give you code markers like this: "code""/code" except with bracket markers in place of the quote markers. Then just paste the inxi output from the terminal between the code markers so it will show up correctly [you can use the preview option to check it's working as expected].) The 'inxi' tool has lots of different options -- here is just one example:
inxi -Frz(The '-F' option includes basic information for quite a few parts of your system, the '-r' option provides details on your repos, and the '-z' option filters out some things for privacy / security, which is probably a good idea when posting in public spaces like this forum.)
#4
Sparky applications / Re: access to smarttphone memo...
Last post by lukand - June 14, 2024, 03:35:42 PM
I tried to copy some files from PC to the memory card via USB. Unfortunately, unlike in the past, there is no way to see the icons which provide the possibility to access the memory card and internal smartphone memory as well. Despite restart, the situation is the same. There is much free space on the 512 GB Samsung memory card. The only mode I applied whilst connecting Fairphone 4 was to transfer files via USB

#5
Sparky applications / Re: 'APTus AppCenter' not usea...
Last post by duststuff - June 14, 2024, 03:11:16 PM
Thanks, @rektal. I notice that you have Nvidia for graphics -- that could be causing the issue as well. It might be helpful for you to compare your system's info with that of @AxL -- perhaps they would be willing to post that here for your reference. Meanwhile, I'd definitely recommend looking at the recent history of your system's updates, since that might give you a clue of one or more packages / updates that might have caused the issue.
#6
System upgrading / Re: Skype Install / Upgrade 'B...
Last post by Henry1 - June 14, 2024, 02:35:24 PM
Thank you Pavroo and Dustin,

I will use Skype via browser.

Thank you in advance for your help.

Henry
#7
Sparky applications / Re: 'APTus AppCenter' not usea...
Last post by rektal - June 14, 2024, 02:34:20 PM
I have noticed that sparky-welcome is not working too. There is a blank page too.

Output of inxi -Frz is:
System:
  Kernel: 6.9.4-x64v3-xanmod1 arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 5.27.11 Distro: SparkyLinux 8 (Seven-Sisters)
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: PRIME Z590-P v: Rev 1.xx serial: <superuser required>
    UEFI: American Megatrends v: 1801 date: 12/26/2022
CPU:
  Info: 6-core model: Intel Core i5-10400F bits: 64 type: MT MCP cache:
    L2: 1.5 MiB
  Speed (MHz): avg: 2216 min/max: 800/4300 cores: 1: 4188 2: 4111 3: 800
    4: 800 5: 800 6: 4293 7: 800 8: 800 9: 800 10: 800 11: 4099 12: 4305
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1650] driver: nouveau v: kernel
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 24.1.0 driver: X:
    loaded: modesetting unloaded: fbdev,vesa dri: nouveau gpu: nouveau
    resolution: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: nouveau,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.5 compat-v: 4.3 vendor: mesa v: 24.0.8-1 renderer: NV168
  API: Vulkan Message: No Vulkan data available.
Audio:
  Device-1: Intel driver: snd_hda_intel
  Device-2: NVIDIA TU116 High Definition Audio driver: snd_hda_intel
  API: ALSA v: k6.9.4-x64v3-xanmod1 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active
Network:
  Device-1: Realtek RTL8125 2.5GbE driver: r8169
  IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter
    driver: rtl8xxxu type: USB
  IF: wlan0 state: up mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    type: USB
  Report: hciconfig ID: hci0 state: up address: <filter> bt-v: 4.0
Drives:
  Local Storage: total: 3.66 TiB used: 2.4 TiB (65.5%)
  ID-1: /dev/nvme0n1 vendor: GOODRAM model: SSDPR-PX500-512-80
    size: 476.94 GiB
  ID-2: /dev/nvme1n1 vendor: GOODRAM model: SSDPR-PX500-512-80
    size: 476.94 GiB
  ID-3: /dev/sda vendor: Toshiba model: HDWD110 size: 931.51 GiB
  ID-4: /dev/sdb vendor: Toshiba model: MQ04UBD200 size: 1.82 TiB type: USB
Partition:
  ID-1: / size: 468.09 GiB used: 408.35 GiB (87.2%) fs: ext4
    dev: /dev/nvme1n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 10.9 MiB (3.6%) fs: vfat
    dev: /dev/nvme1n1p1
Swap:
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) file: /swapfile
Sensors:
  System Temperatures: cpu: 34.0 C mobo: 32.0 C gpu: nouveau temp: 31.0 C
  Fan Speeds (rpm): fan-1: 0 fan-2: 1070 fan-4: 0 fan-5: 0 fan-6: 0 fan-7: 0
    gpu: nouveau fan: 1736
Repos:
  Active apt repos in: /etc/apt/sources.list
    1: deb http://deb.debian.org/debian trixie main contrib non-free non-free-firmware
    2: deb-src http://deb.debian.org/debian trixie main contrib non-free non-free-firmware
    3: deb http://security.debian.org/debian-security/ trixie-security/updates main contrib non-free non-free-firmware
    4: deb-src http://security.debian.org/debian-security/ trixie-security/updates main contrib non-free non-free-firmware
    5: deb http://deb.debian.org/debian trixie-updates main contrib non-free non-free-firmware
    6: deb-src http://deb.debian.org/debian trixie-updates main contrib non-free non-free-firmware
    7: deb http://deb-multimedia.org/ trixie main non-free
  No active apt repos in: /etc/apt/sources.list.d/dropbox.list
  Active apt repos in: /etc/apt/sources.list.d/google-chrome.list
    1: deb [arch=amd64] https://dl.google.com/linux/chrome/deb/ stable main
  No active apt repos in: /etc/apt/sources.list.d/google.list
  Active apt repos in: /etc/apt/sources.list.d/megasync.list
    1: deb [signed-by=/usr/share/keyrings/meganz-archive-keyring.gpg] https://mega.nz/linux/repo/Debian_12/ ./
  No active apt repos in: /etc/apt/sources.list.d/pipelight.list
  No active apt repos in: /etc/apt/sources.list.d/playonlinux.list
  No active apt repos in: /etc/apt/sources.list.d/plexmediaserver.list
  Active apt repos in: /etc/apt/sources.list.d/protonvpn-stable.list
    1: deb [arch="all", signed-by=/usr/share/keyrings/protonvpn-stable-archive-keyring.gpg] https://repo.protonvpn.com/debian stable main
  No active apt repos in: /etc/apt/sources.list.d/sid.list
  Active apt repos in: /etc/apt/sources.list.d/signal-xenial.list
    1: deb [arch=amd64 signed-by=/usr/share/keyrings/signal-desktop-keyring.gpg] https://updates.signal.org/desktop/apt xenial main
  Active apt repos in: /etc/apt/sources.list.d/sparky.list
    1: deb [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ core main
    2: deb-src [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ core main
    3: deb [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ sisters main
    4: deb-src [signed-by=/usr/share/keyrings/sparky.gpg.key] https://repo.sparkylinux.org/ sisters main
  No active apt repos in: /etc/apt/sources.list.d/virtualbox.list
  No active apt repos in: /etc/apt/sources.list.d/wine-staging.list
  Active apt repos in: /etc/apt/sources.list.d/xanmod-kernel.list
    1: deb [signed-by=/usr/share/keyrings/xanmod-archive-keyring.gpg] http://deb.xanmod.org releases main
Info:
  Memory: total: 16 GiB available: 15.48 GiB used: 4.25 GiB (27.4%)
  Processes: 346 Uptime: 3h 11m Shell: Bash inxi: 3.3.34

First of all, I miss removing old kernels with APTus. Now I can't do it anymore.
#8
System upgrading / Re: Skype Install / Upgrade 'B...
Last post by duststuff - June 14, 2024, 02:24:07 PM
@Henry1, okay, I understand.

@pavroo, thanks for this information. Once it's removed from APTus, feel free to PM me or leave a note here, and I'll mark this as 'Solved'.
#9
Newbie questions / virtualbox not work
Last post by bertgio - June 14, 2024, 02:21:39 PM
I am newbbie.i have this problem. On sparkylinux 7.4 kde with kernel dowgrade to 5.15.160-sparky-lts-amd64 virtualbox-7.0_7.0.12-159484~Debian~bookworm_amd64.deb does not work as well as virtualbox 7.0.18-162988~Debian~bookworm. The installation ends without errors but when I go to create a virtual machine or add an existing one it starts but stops without giving any signals. Do others have the same problem?
#10
Sparky applications / Re: 'APTus AppCenter' not usea...
Last post by duststuff - June 14, 2024, 02:14:54 PM
Hi, rektal, thanks for the updates. When I run it from the terminal I also get the "Overriding existing handler for signal 10. Set JSC_SIGNAL_FOR_GC if you want WebKit to use a different signal" output, but the GUI still works as expected. One difference is that my system is Sparky 7.x (based on Debian 'stable') whereas yours is Sparky 8.x (based on Debian 'testing', I think). From what I've heard, it's more common for various types of problems to show up in Debian testing when they are updating / upgrading / changing packages, etc., and sometimes these get resolved 'automatically' in a number of days. However, 'AxL' is also on Sparky 8.x and the app is working fine for him, so there must be some difference between your systems.

I did a bit of a search online with the output "Overriding existing handler for signal 10. Set JSC_SIGNAL_FOR_GC if you want WebKit to use a different signal", and it seems to indicate that the problem could be caused by WebKit. So you could check out what webkit-related packages are on your system and if any of those were updated recently, since that might be the source of the problem. If so, you could see if anyone has reported it as a WebKit bug and/or you could look for a way to downgrade to an earlier version of WebKit to see if that works. If you have compositing enabled on your system, you could also try to disable that to see if it solves it (I saw this suggestion in relation to Nvidia graphics cards, along with another idea related to disabling hardware acceleration if that's an option anywhere).

So there's at least some chance that this is not a Sparky bug, although the Sparky developer(s) do control which packages are included in the repos, so if they can confirm there is a problem with one or more packages and downgrade them in the repos, then that would make things easier for you. But it's also possible for you to do a downgrade on your own if you already know how or are willing to learn, although my sense is it's not necessarily an easy process.

So I don't have any easy answers for you, but these ideas should help point you in the right direction.

Also, when you're looking for help on this or other similar forums, it would be good for you to provide as much relevant information as possible. You can use the command-line tool 'inxi' and its various options to generate general / specific / relevant information about your system that you can then copy from the terminal (Shift + Ctrl + C) and paste into your post here using the code markers for easier readability. (Hover over the icons above where you're writing till you see the one marked 'Code', click on that and it should give you code markers like this: "code""/code" except with bracket markers in place of the quote markers. Then just paste the inxi output from the terminal between the code markers so it will show up correctly [you can use the preview option to check it's working as expected].) The 'inxi' tool has lots of different options -- here is just one example:
inxi -Frz(The '-F' option includes basic information for quite a few parts of your system, the '-r' option provides details on your repos, and the '-z' option filters out some things for privacy / security, which is probably a good idea when posting in public spaces like this forum.)

View the most recent posts on the forum