SparkyLinux Forums

Software & hardware support => Hardware => Topic started by: carlossotelo on February 01, 2018, 02:43:39 AM

Title: How to disable OpenGL 2.
Post by: carlossotelo on February 01, 2018, 02:43:39 AM
Hi everybody, Im new in Sparky and Linux in general. I have an Intel atom n455 and the graphics have problems with Qupzilla and other apps (like black bars in upside) because is OpenGL 2 enabled by default, which is not fully supported on this micro. I can't disable it beacause the driconfig dont detect my integrated card.
Spoiler (click here to view)
$ xdriinfo
               Screen 0: not direct rendering capable.
The Drivers are updated, so i dont know why dont detect the card. But glxinfo Do. I only have problem with xdriinfo.

Well, thanks for your help and srry if my english is not good.
Title: Re: How to disable OpenGL 2.
Post by: Capitain_Jack on February 01, 2018, 01:50:28 PM
I found a post at manjaro linux about your hardware and changing the render mode, you must adapt the commands and package names to sparky type (where there is mhwd, it is apt-get, the best way to find should be search for each step he is taking to change the render mode, but on debian instead, as sparky is debian based).

https://forum.manjaro.org/t/problems-with-opengl-2-1-and-gma-3150/28273/2

Good luck! If anyone else know off a solution, please post a reply!
Title: Re: How to disable OpenGL 2.
Post by: carlossotelo on April 10, 2018, 06:03:42 PM
Just for saying, i tried lubuntu and xubuntu and xdriinfo detect the card. I tried Debian too but is the same like sparky. Maybe is a problem of config files. I dont know   :-\ Anyway, thanks for help.
Title: Re: How to disable OpenGL 2.
Post by: carlossotelo on April 10, 2018, 11:37:10 PM
Well, you can't believe me, but I install the new ISO of sparky 5.3 and update all, and now xdriinfo detect the board :o. Thanks for help and srry for everything xD.