Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Recent posts

Installation / Re: APTus AppCenter slow <SOLV...
Last post by Henry1 - June 03, 2024, 06:13:53 PM
Hi Dustin,

Done it!

Thank you for all your help.

Installation / Re: APTus AppCenter slow
Last post by duststuff - June 03, 2024, 03:16:09 PM
You're welcome, Henry.

Also, if/when you feel that the original topic you started has been resolved, it would be great if you could do one more thing and add '[Solved]' to the beginning or end of this thread's title. This would be helpful for anyone else searching these forums for a solution to the same problem. If you don't know how to do that, see this post (,4239.msg17825.html#new). Basically, you just edit the first post in the thread; to do that, go to the bottom right of the post and it looks like you can use either 'Quick Edit' or 'More...'-'Modify' to get to a page where you can make the change and save it, etc.
Installation / Re: APTus AppCenter slow
Last post by Henry1 - June 03, 2024, 12:30:22 PM
The changes you made has probably caused the error, we (as regular users) shouldn't be doing this, Microsoft is very sneaky keep changing the way signing keys are handled creating issues very often lately; I will keep this information in case of need while checking for further developments.

Thank you very much Dustin.

Installation / Re: APTus AppCenter slow
Last post by duststuff - June 03, 2024, 12:00:39 PM
You're welcome, Henry.

I understand; I'm not a snap fan either, and am glad I don't 'have' to use it for anything with my current setup here.

What I was referring to is the same as or similar to 'Method 1' on this page: . It looks like this article was updated recently, so the instructions might be fine, but I had some issues when following similar instructions from a different online source -- they basically hadn't updated them for changes in gnupg2 as far as how signing keys are handled. Then once I started looking into it I also decided I wanted to use different paths for storing keys, etc. So here's what I have in my notes about this in regards to some edits I made to the commands used and what worked for me:

Quote• Website 'easy download' link only offers a snap version. To install w/o using snap:
        ◦ Dependencies: software-properties-common apt-transport-https curl ca-certificates .
        ◦ Get key (DM edit): curl -fsSL | sudo gpg --dearmor | sudo tee /etc/apt/keyrings/skype.gpg > /dev/null
        ◦ Add Skype 'stable' repo (DM edit): echo deb [arch=amd64 signed-by=/etc/apt/keyrings/skype.gpg] stable main | sudo tee /etc/apt/sources.list.d/skype-stable.list
        ◦ [2023-Dec-16: One of the reasons I made edits to the above commands was to avoid having the key put in a legacy location, but now I'm wondering whether the changes I made will actually affect that, and how exactly the key got in that legacy location to cause the error. Maybe it was something that was done during the install process in the following step?]
        ◦ Update cache, then install 'skypeforlinux' pkg.
Since I started using Sparky I've just used the APTus AppCenter to install Skype, but I've kept these notes handy in case I ever need to do it manually.

Hope that helps,
Installation / Re: APTus AppCenter slow
Last post by Henry1 - June 03, 2024, 10:47:22 AM
Hi Dustin,

Looking at the Skype official page, I have seen that the download is for Linux Snap:; I personally avoid snap at all costs as nobody knows what is going on inside that package and only Canonical can run a snap store...After xz backdoor, there might be problems with the verification of the author's application/package...If you have a hotmail account, there is no need to install Skype but just open it in a browser (I use Firefox)...

Thank you Dustin for your update.

Newbie questions / Re: System freezes on reboot
Last post by duststuff - June 03, 2024, 04:20:34 AM
I don't have a lot of experience searching through logs, but if the problem involves anything in the part of the boot that systemd controls, then I think the command-line utility 'journalctl' could be useful for you. If you're not familiar with it, you can run
man journalctlto read the man pages and decide how to best use it for your issue. The command-line utility 'dmesg' may also have some helpful info. Some other questions / comments that might help you move forward on this:

1. When you say it freezes on reboot, does it freeze during the part when it is shutting the system down or when it is bringing it back up? If it is when it is bringing it back up, then you could check / adjust your BIOS settings and/or boot-loader (eg. grub) kernel parameters to have the system show as much data as possible when booting.

2. Have you tried rebooting it in other ways? If so, do you get the same result, or something different?

3. Do you have another (different make/model) PC on which you can replicate this same problem?

4. Does another Linux distro or different Sparky version on this PC show the same problem?

5. Are you connected to the internet when this happens? If so, what type of connection is it? Do you have more than one way to connect to the internet? If so, have you tried switching to that to see if the problem persists? Have you tried disconnecting from the internet to see if the problem persists?

6. When you're looking for help on this or other similar forums, it would be good for you to provide as much relevant information as possible. You can use the command-line tool 'inxi' and its various options to generate general / specific / relevant information about your system that you can then copy from the terminal (Shift + Ctrl + C) and paste into your post here using the code markers for easier readability. (Hover over the icons above where you're writing till you see the one marked 'Code', click on that and it should give you code markers like this: "code""/code" except with bracket markers in place of the quote markers. Then just paste the inxi output from the terminal between the code markers so it will show up correctly [you can use the preview option to check it's working as expected].) The 'inxi' tool has lots of different options -- here is just one example:
inxi -Frz(The '-F' option includes basic information for quite a few parts of your system, the '-r' option provides details on your repos, and the '-z' option filters out some things for privacy / security, which is probably a good idea when posting in public spaces like this forum.)
Installation / Re: APTus AppCenter slow
Last post by duststuff - June 03, 2024, 02:48:02 AM
You're welcome, Henry; glad to hear you were able to identify the repo causing the slow-down. I've also noticed lately that the upgrade tool seems to have trouble connecting with the Skype repo. I also have a Proton VPN repo that's been giving me an error / warning about authentication because it can't find the signing key -- I've noticed that this repo was 'updated' in more than one upgrade session, but the problem persists. So far I haven't taken the time to trouble-shoot either of these issues. I think sometimes what happens with these third-party repos is that something gets changed on their side that requires a change on a user's system. This might normally get fixed by the Sparky developers via an update/upgrade once they're aware of it and have the time to address it, but it may also be possible for a user to fix it themselves if they already have or are willing to search for the knowledge they need to do so. With Skype, if you want more control and awareness on how it gets installed and updated, you can also do the install yourself (instructions on Skype website in my post below, although you may want to make some adjustments to avoid errors or to suit your own tastes, as they may be a bit out-of-date) rather than doing it through the APTus AppCenter.
Newbie questions / [SOLVED] System freezes on reb...
Last post by one23 - June 02, 2024, 11:36:25 PM

I have freshly installed Sparky Linux MinimalCLI 7.3 with up to date system and running on 6.1.0-21-amd64 kernel.

The trouble is that for some reason every time I reboot system with sudo reboot it freezes on reboot. The last message I can see says something about ethernet link being down. I must power off machine twice as the first time I get only blinking cursor.

Which logs would show what is happening during reboot?

Thanks in advance.
Installation / Re: APTus AppCenter slow
Last post by Henry1 - June 02, 2024, 05:34:27 PM
Hi Dustin,

From your suggestion I checked the repositories and I think the problem is stable main enabled as disabling it, APTus and System Upgrade tool are very fast now...The warning says: Impossible to recover  504  Gateway Time-out [IP: 443]

I'll keep you updated...

Thank you for your help, Dustin.

Installation / Re: APTus AppCenter slow
Last post by duststuff - June 02, 2024, 03:56:02 PM
Hi Henry, :-)

I'm not Pavroo, but a few days ago or so I had a 200+ MB update take about 1.5 - 2 hours instead of the usual 1-3 minutes or so, but since then things have been back to normal. Not sure what the cause was, but I think it was mainly two packages that made up most/all of the download, each one around 100+ MB. One was from a third-party repo and the other was most likely from the Sparky repo. My guess is that there was something wrong on a server hosting a repo or somewhere on the route in-between that was slowing things down.

If this persists for you, I would look into seeing if it's possible to switch one or more of your repos over to a mirror that's more local for you to see if that helps. I 'think' this is possible to do with Sparky, but haven't looked into it yet myself. If it is possible, I'm also not sure if it can be done through a more user-friendly GUI, or whether it would take some terminal commands, etc. You may also find it helpful to figure out if the slow-down is the result of only one/some repos on your system (you can search online for how to view the history of your package manager if you don't know how to do that). Also, for Pavroo or others to give more specific help, it would be helpful if you post your repo information within code markers copy/pasted from the output of
inxi -r as well as mentioning what package(s) you were downloading from what repo(s) during the time that it was relatively slow for you (if you're able to figure that out). It could be just a temporary glitch, but I'm guessing it's some sort of internet-related problem rather than a Sparky problem.

Hope that helps,

View the most recent posts on the forum