Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Recent posts

#61
Newbie questions / Re: How do you cnfigure Konsol...
Last post by nucman - January 25, 2024, 12:59:03 AM
My suggestions...

https://github.com/ohmybash/oh-my-bash  (theme of choice, I like "90210", and the sudo plugin)

https://www.nerdfonts.com/font-downloads (your Mono font of choice, I like Caskaydia)

https://draculatheme.com/konsole
#62
Newbie questions / deb files are opening not inst...
Last post by nucman - January 25, 2024, 12:54:23 AM
Hi all, I'm on about day 5 of using Sparky. When I first installed I am quite sure when I opened a .deb file in the GUI it prompted to install. Now when I open a .deb file it opens the file in ark and just shows the contents. I looked at file associations and I don't see any other apps that should be opening .deb.

I did some searching and found gdebi in the terminal and looked in the App repo and saw numerous gdebi tools, but if my original belief above is correct what I need is already installed. What is the correct app to be opening .deb files in the GUI to prompt to install?

edit: Using Sparky 8 with KDE.

Thanks
#63
Newbie questions / PlayOnLinux/CapTvTy issues whe...
Last post by Changala - January 24, 2024, 05:12:07 PM
I don't think this is the right category to load this post, but let's start here.

I am used to download my favorite TV shows to enjoy them better at a quieter moment than live, so I run CapTvTy in PlayOnLinux.
So far to PoTolo, so good.
A full system-upgrade from PoTolo to OrionBelt worked fine, but left a major problem, I can no longer download from some of the TV channels, only a few of them, unfortunately my favourites.

What I did before calling for help:

1) wiped a spare partition and made a clean new installation of Sparky7.2, PlayOnLinux and Captvty.
Same issue, can't download from some TV channels.

2) wiped again this partition and made a clean new installation of Sparky6.7, PlayOnLinux and Captvty.
Great, all TV channels download normally.
- I notice in the task-manager, that the channels that fail to download in OrionBelt, transfer mp4 files with curl, all other channels that still work under Sparky7.2, transfer ts files without the help of curl.
Then I made a full system-upgrade from PoTolo to OrionBelt, successfully, all TV channels download.
- unfortunately, insanely, after the recommended "sudo apt-get autoremove", all the mp4 TV channels hang again.

There has been 127 system components removed by the clean-up, probably only a few of them still needed, but I have no clue which ones and how to. Log here below.

Thank you

Lecture des listes de paquets...
Construction de l'arbre des dépendances...
Lecture des informations d'état...
Les paquets suivants seront ENLEVÉS :
  crda ftp g++-10 gir1.2-ayatanaappindicator3-0.1 gir1.2-gtksource-3.0 libaom0
  libatk1.0-data libavcodec58:i386 libavdevice58 libavfilter7 libavformat58
  libavresample4 libavutil56:i386 libbasicusageenvironment1 libbpf0 libcbor0
  libcmis-0.5-5v5 libcodec2-0.9 libcodec2-0.9:i386 libcurl3-gnutls:i386
  libdav1d4 libdav1d5 libdav1d5:i386 libdns-export1110 libfaudio0:i386 libffi7
  libffi7:i386 libffms2-4 libfl2 libflac8 libflac8:i386 libfluidsynth2
  libgdbm-compat4:i386 libgdbm6:i386 libglew2.1 libglu1-mesa:i386
  libgs9-common libgssdp-1.2-0 libgtksourceview-3.0-1
  libgtksourceview-3.0-common libgupnp-1.2-0 libicu67 libicu67:i386
  libieee1284-3:i386 libigdgmm11 libigdgmm11:i386 libilmbase25
  libisc-export1105 libjim0.79 libkvazaar6 libkvazaar6:i386 libldap-2.4-2
  libldap-2.4-2:i386 liblivemedia94 libllvm11 libllvm11:i386 liblrdf0
  liblsmash2 libmbedcrypto3 libmjpegutils-2.2-0 libmms0 libmpdec3
  libmpeg2encpp-2.2-0 libmplex2-2.2-0 libnetpbm10 libnspr4:i386 libntfs-3g883
  libodbc1:i386 libodbccr2:i386 libofa0 libopenal1:i386 libopenexr25
  libopengl0:i386 libopenh264-6 libopenh264-6:i386 liborcus-0.16-0
  liborcus-parser-0.16-0 libpci3:i386 libpcre3 libpcre3:i386 libperl5.32
  libperl5.32:i386 libperl5.36:i386 libplacebo120 libpoppler102 libpostproc55
  libprocps8 libprotobuf-lite23 libpython3.9 libpython3.9-minimal
  libpython3.9-stdlib libqpdf28 libqrcodegencpp1 librest-0.7-0 libsidplay1v5
  libsndio7.0:i386 libsnmp40:i386 libsrt1.4-gnutls libssl1.1 libstb0:i386
  libstdc++-10-dev libswresample3:i386 libswscale5 libtesseract4 libtiff5:i386
  libuuid1:i386 libvidstab1.1 libvkd3d-shader1:i386 libvkd3d1:i386 libvpx6
  libwebp6:i386 libwmf-0.2-7 libwmf0.2-7 libwrap0:i386 libwxbase3.0-0v5
  libwxgtk3.0-gtk3-0v5 libx265-192 libxslt1.1:i386 linux-image-5.10.0-22-amd64
  perl-modules-5.32 python3-certifi python3-charset-normalizer
  python3-requests python3.9 python3.9-minimal telnet vkd3d-compiler:i386
0 mis à jour, 0 nouvellement installés, 127 à enlever et 0 non mis à jour.
Après cette opération, 882 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] (Lecture de la base de données...
#64
Sparky applications / Re: sparky-backup-core
Last post by dennie75 - January 22, 2024, 11:19:13 PM
Thank you for a solution. Still have some problems after the upgrade from version 6 to 7. A lot has changed in bookworm. Sparkybackup and Sparky-installer work differently than in version 6 and still have problems with them. I like to build linux distro's and love the sparky applications. For developers and hobby people, it's a world that opens up to you. Thank you for this beautiful Sparky
#65
Installation / Re: Sparky rolling installatio...
Last post by pavroo - January 21, 2024, 07:38:52 PM
Pics can be uploaded to any online service, and then past a link to the screenshot via image icon called 'Insert an image'
#66
Sparky applications / Re: sparky-backup-core
Last post by pavroo - January 21, 2024, 07:36:40 PM
you can replace 'remsu' to 'spsu' or 'spsudo'
#67
Newbie questions / Re: name resolution inconsiste...
Last post by nucman - January 21, 2024, 04:43:46 AM
annnd... of course I find the answer immediately after posting 😑

https://www.lowlevelmanager.com/2011/09/fix-linux-dns-issues-with-local.html

I guess I'll make this response instead of deleting in case anyone else deals with this.
#68
Newbie questions / name resolution inconsistencie...
Last post by nucman - January 21, 2024, 04:35:52 AM
Hi all, new to Sparky but somewhat know what I'm doing with linux. I installed the latest Sparky with KDE yesterday.

I run a local pi-hole with some custom *.local DNS entries. These work on every other device I have. But in the Konsole terminal both ping and ssh do not resolve. Nslookup and host do resolve. My DNS servers are properly populated in /etc/resolv.conf. I am using DHCP. I've exhausted what I know to troubleshoot, this is odd to me. What is going on??  Thanks

$ ping ntp.local
ping: ntp.local: Name or service not known

[07:27 PM]-[user@nuc11]-[~]-
$ nslookup ntp.local
Server:         192.168.40.5
Address:        192.168.40.5#53

Name:   ntp.local
Address: 192.168.40.190


[07:27 PM]-[user@nuc11]-[~]-
$ host ntp.local
ntp.local has address 192.168.40.190

[07:27 PM]-[user@nuc11]-[~]-
$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 192.168.40.5
nameserver 192.168.40.3


#69
Applications / Re: How make my Distro Sparky ...
Last post by penguin - January 20, 2024, 08:56:37 PM
Quote from: ConanSP on January 18, 2024, 07:48:23 PMGood Afternoon,
Exist a program?a Sparky program maybe?
For i make my Sparky with my shape

kkk if don´t understand-me,
Thank you


https://wiki.sparkylinux.org/doku.php/sparky_backup_system
#70
Installation / Re: Sparky rolling installatio...
Last post by sdibaja - January 20, 2024, 08:29:06 PM
good morning.
what is the status of Sparky 2024.01
nothing here seems to apply, all rather old.
---
Having problem installing:
sparkylinux-2024.01-x86_64-mate.iso

where can I send screenshots?
thanks, Peter

View the most recent posts on the forum