Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Recent posts

#81
Newbie questions / Re: WINE install on SparkyLinu...
Last post by sparkfan - April 04, 2024, 03:24:19 PM
hello drewdavis  I installed wine several times on bookworm without any problems!
You find it on my special LPD Homepage, WINE 8
http://www.abwahl-schwentinental.de/nov2020,html
dont hesitate to ask more from one of my emails if still problems ;-)
sparkfan
#82
Hardware / Re: [KDE Version] How to Insta...
Last post by duststuff - April 04, 2024, 03:21:37 PM
I just noticed on my Sparky 7.3 system that the 'APTus AppCenter' (accessible through the apps / 'start' menu) has a package called 'Nvidia Settings' (under 'System'-'Others'). If that's also available on your system, it might be worth checking out, if you haven't already. There's a chance that it's only useful if you already have the correct driver(s) installed, but I thought I'd mention it anyway in case it's helpful. I think there are also one or more general Linux packages 'out there' that were developed to identify the hardware of a system and then search online for a matching driver. I haven't ever used one of these, but I've heard others reference them who were facing situations roughly similar to yours.
#83
Newbie questions / WINE install on SparkyLinux fa...
Last post by drewdavis - April 04, 2024, 04:36:32 AM
Hi,

I just installed SparkyLinux overnight but having issues trying to install WINE. Below are my terminal entries and responses (from info I found on another topic here that is closed). What can I do to resolve this? Thanks!

$ sudo apt install --install-recommends winehq-stable
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
winehq-stable : Depends: wine-stable (= 8.0.0.0~kinetic-1)
E: Unable to correct problems, you have held broken packages.

$ apt policy libnss3 libnss3:i386
libnss3:
Installed: 2:3.61-1+deb11u2
Candidate: 2:3.61-1+deb11u3
Version table:
2:3.61-1+deb11u3 500
500 http://deb.debian.org/debian-security bullseye-security/updates/main amd64 Packages
*** 2:3.61-1+deb11u2 500
500 http://deb.debian.org/debian bullseye/main amd64 Packages
100 /var/lib/dpkg/status
libnss3:i386:
Installed: 2:3.61-1+deb11u2
Candidate: 2:3.61-1+deb11u3
Version table:
2:3.61-1+deb11u3 500
500 http://deb.debian.org/debian-security bullseye-security/updates/main i386 Packages
*** 2:3.61-1+deb11u2 500
500 http://deb.debian.org/debian bullseye/main i386 Packages
100 /var/lib/dpkg/status

$ sudo apt install libnss3=2:3.61-1+deb11u2 libnss3:i386=2:3.61-1+deb11u2
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
libnss3 is already the newest version (2:3.61-1+deb11u2).
libnss3:i386 is already the newest version (2:3.61-1+deb11u2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

who can help me!
#84
Suggestions / Re: Text Installer with Consol...
Last post by djringjr - April 03, 2024, 08:11:57 PM
Sparky unfortunately doesn't have the GUI screen reader installed, but it can be installed.

Debian already has both console speech and GUI speech (orca) installed out of the box if you press "s" at the start of the installer.

DR
#85
Applications / Re: k3b not installable
Last post by AxL - April 03, 2024, 06:52:51 PM
Quote from: Splinx64 on April 03, 2024, 06:13:33 PMYeah, I solved my problem.

I removed the option to use unstable packages in my Sparky testing system.
And, I found another sid source, removed it too.

After them I did

$ sudo apt update && sudo apt full-upgrade
Now I could install all missing packeges.

Voilà, that was it.
  [....]

Well, I'm glad you were able to solve your problems.

Quote from: Splinx64 on April 03, 2024, 06:13:33 PM[....]  Thank you for your help.




#86
Applications / Re: k3b not installable
Last post by Splinx64 - April 03, 2024, 06:13:33 PM
Yeah, I solved my problem.

I removed the option to use unstable packages in my Sparky testing system.
And, I found another sid source, removed it too.

After them I did

$ sudo apt update && sudo apt full-upgrade
Now I could install all missing packeges.

Voilà, that was it.

Thank you for your help.
#87
Suggestions / Re: Text Installer with Consol...
Last post by djringjr - April 03, 2024, 05:26:01 PM
I can make a list of installed packages in the full MATE GUI of SparkyLinux with this command:

sudo dpkg-query -f '${binary:Package}\n' -W > packages_list.txt


After I install Debian Minimum and change the /etc/apt/sources.list file to the SparkyLinux /etc/apt/sources.list file showing the added repositories for Sparky Linux, I can then add all the installed packages that I need to have a full Sparky MATE GUI with this command:

sudo xargs -a packages_list.txt apt install
#88
Suggestions / Re: Text Installer with Consol...
Last post by djringjr - April 03, 2024, 04:53:45 PM
So far, no success.

My next plan is to get the installed packages list, and a copy of the /etc/apt/sources.list file which gives the Sparky Linux repositories.

Then using a minimal Debian iso, install using console speech. The Debian iso asks you if you want speech during instalation, and if so to press "s".

With that I can make myself a talking Sparky Linux, but it still doesn't solve the problem of having Sparky instalation being accessible for blind users.

One step at a time.

Regards,

David
#89
Suggestions / Re: Text Installer with Consol...
Last post by djringjr - April 02, 2024, 10:21:35 PM
I have done some work on achieving this.

First. I installed speech-dispatcher, espeak and espeakup as what's said to be an install with screen reader didn't install them.

Also brltty the braille device driver wasn't installed. I installed that also.

But still no console speech.

Also now I cannot log in with my laptop that has Sparkylinux on it. Log in says "error", so I am sending this from my phone.

Best regards,

David
#90
Applications / Re: k3b not installable
Last post by Splinx64 - April 02, 2024, 07:17:49 PM
Thank you for these links.

Of course, please excuse, that I havn't answered ealier. But, on Eastern there wasn't enough time for this.

Unfortunately, none of the methods helped.

But, I remembered, that, maybe, some unstable packages  were installed before changing to trixie. I found here a workaround to get one step further.
With this method I could install k3b again.

But this didn't solve my problem to install vlc.

I have also seen, that some installed packages have been kept back.

OK, I know, that isn't an elegant method to run unstable packages in my testing environment. Therefore, I will remove this option again soon  and go back to a clean testing. I think, than I can also find a solution to install vlc.

View the most recent posts on the forum