Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Recent posts

Sparky applications / Re: Problem with Distribution ...
Last post by penguin - January 17, 2024, 11:51:15 AM
Quote from: seadevil on December 07, 2023, 05:12:35 PMI cannot install Fsearch.  I keep getting error message:  aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Sparky/orion-belt
one person said to:     apt remove software-properties-gtk    but that did absolutely   nothing !

so how can i fix this ?   

i ran :     sudo add-apt-repository ppa:christian-boxdoerfer/fsearch-stable
            sudo apt update
              sudo apt install fsearch

nothing works

I am not in front of my Sparky Machine . Have you checked on Aptus or Synaptic for fsearch?

When I need something that is not in the Aptus or Synaptic , i check fsearch case, you have
For example, you can grab MX Linux MX-23 Testing   fsearch
If installation fails, try another version (Mx 21 or Mx 19)

Keep one eyes on what you are doing during install.
Hope it helps.

Artwork & screenshots / Re: Show Us Your Desktop
Last post by AxL - January 17, 2024, 01:46:10 AM
The oldest SparkyLinux installation I have. No less, than since May 06, 2016' (almost 8 years old).

And there it is, working great, without any problem ... And of course using my favorite WM Fluxbox.

full screen

full screen

Cheers !! 

Newbie questions / Sparky self shut down after 24...
Last post by DukeLander - January 14, 2024, 08:29:37 PM
Hi folks,

I have Sparky installed on my older laptop, which has Klipper nad Samba installed, worked fine on older 6.x editions.
On 7.x although every power option is turned off, laptop simply shut down itself after 24h.
First I thought I have some hw problem, tried Ubuntu server, no shut down.
Went back to Sparky, same problem again.
Am I missing something, some option or....?

Hardware / usb printer installation
Last post by jnwright - January 12, 2024, 02:37:35 AM
I have a Brother usb printer, model HL-L2320D.
I have used many linux distros and until now,
the only one that installed the printer automatically using linux
drivers without me having to download and install Brother drivers
is Spiral linux.

I decided to try Sparky linux, ver. 7.2 and to my surprise,
it also automatically installed the printer without me having
to do any thing.

Spiral and Sparky are based on Debian stable.
Sparky uses the 6.1.0-17 kernel; Spiral uses the kernel.

A lot of other distros are also based on Debian stable,
so the question I have is how are Spiral and Sparky able to
automatically install this printer and the other distros are not ?
System upgrading / Re: Upgrade from 5
Last post by webxtor - January 09, 2024, 05:56:20 PM
After upgrading from 5 to 6 and from 6 to 7 known openbox issues:

  • Broken menu as described here


    sudo apt-get install jgmenuEdit in ~/.config/openbox/rc.xml this part
            <action name="ShowMenu">
            <action name="Execute">
    openbox --reconfigure
    Then fine tuning jgmenu:

    • Init to create config file ~/.config/jgmenu/jgmenurc
      jgmenu_run init
    • Append (Exit) and prepend (Favorties)
      jgmenu_run init -i
      What now>append
      What now>prepend
      This will create ~/.config/jgmenu/append.csv and ~/.config/jgmenu/prepend.csv which you can edit to also add/remove entries.
      I have added Chrome to prepend.csv next to Firefox by guessing how it should be and it worked including the icon:
      File manager,thunar,system-file-manager
    • Adjust settings for: positioning, tint2 integration and filtering unwanted apps in ~/.config/jgmenu/jgmenurc
      # csv_cmd = apps
      csv_cmd = jgmenu_run apps | grep -v "libexec/xscreensaver"
      # tint2_look = 0
      tint2_look = 1
      # position_mode = fixed
      position_mode = pointer
      Here I have changed the default positioning from fixed to pointer so it follows the mouse pointer.
      Also I have filtered out all of the xscreensaver screensavers which spammed Settings section.
      Changes reflect immediatelly.

  • gscreenshot no longer included


    sudo apt-get install flameshotEdit in ~/.config/openbox/rc.xml this part (2 times)
    <command>flameshot gui</command>openbox --reconfigure
  • No more volume (pavucontrol) system tray (volume meters?) icon. Similar Debian 11 Bullseye thread


    apt-get install pasystrayFor autostart add into ~/.config/openbox/
    pasystray &
  • WiFi disabled and system time shifted to several days ahead after waking up from suspend


    sudo nano /lib/systemd/system-sleep/wifi-time-fix#!/bin/sh
    set -e
    if [ "$2" = "suspend" ] || [ "$2" = "hybrid-sleep" ]; then
        case "$1" in
                pre) true ;;
                post) sleep 1 && 
                  rfkill unblock wlan && # wifi unblock
                  service ntp restart ;; # fix time with ntp online servers
    sudo chmod +x /lib/systemd/system-sleep/wifi-time-fixCredits:

  • On pasystray volume indicator no more percentage display on mouseover/change, just the progress bar on change. Also muting no longer works.

    Solution: ???

Newbie questions / Re: Double Commander installat...
Last post by TRon - January 01, 2024, 08:20:10 AM
Quote from: lukand on December 07, 2023, 02:03:30 PMCan it be related with the fact that the installed system is MATE of 7.1 level?
Running MATE on SparkyLinux 7.2 (it will automatically update to it) with DC without any issues. Installed DC when Sparky was still at 7.0 using apt.

DC can be located with Menu/Accessories or quick-search

My usr/share/applications/doublecmd.desktop file contents is:
[Desktop Entry]
Name=Double Commander
GenericName=File Manager
Comment=Double Commander is a cross platform open source file manager with two panels side by side.
Exec=doublecmd %F
Comment[ru]=Double Commander — это кроссплатформенный двухпанельный файловый менеджер с открытым кодом.

How did you install DC and in case you did not use the default available DC from sparky then which DC version and from which source did you obtain DC ?
Installation / Re: woeusb not working
Last post by pavroo - December 31, 2023, 09:29:20 PM
sudo apt install woeusb-ng
Installation / Re: woeusb not working
Last post by nandi - December 31, 2023, 08:24:40 PM
thank you installed with the
sudo pip3 install WoeUSB-ng --break -system-packages

It works maybe not ellegant way
i dont know the proper way to do it
Installation / Re: woeusb not working
Last post by pavroo - December 31, 2023, 04:38:45 PM
Install 'woeusb-ng' instead.
Installation / woeusb not working
Last post by nandi - December 31, 2023, 03:58:04 PM
i tried to install woeusb with
aptus its missing alot of stuff
anyone knows what extra steps i
need to do? Do i need pip and python installed?

View the most recent posts on the forum