Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Recent Posts

Pages: [1] 2 3 ... 10
1
Installation / Re: Installation Error Calamares on uefi32/64bit laptop
« Last post by Raikenzom on May 11, 2021, 05:17:15 am »
I solved this by disabling the Secure Boot.
2
Newbie questions / Re: Can't install Protonvpn
« Last post by lonegunmen on May 10, 2021, 01:08:40 am »
probably you can try to add
Code: [Select]
deb https://repo.protonvpn.com/debian unstable maininto /etc/apt/sources.list or a list file in /etc/apt/sources.list.d/

I actually tried this method a short while after making my post above. It will technically work and will allow you to install the protonvpn app, but unfortunately it still didn't work. Everytime I tried to connect with the protonvpn command line app, it would connect and then immediately disconnect. This was on a fresh install, so instead of trying to unscrew this mess, I ended up just reinstalling again and decided to do something better to use protonvpn.

With a new install of SparkyLinux 5.15 64bit LXQt version, I couldn't find any Network Manager GUI interface. Just that useless nm-tray icon near the clock. The "Edit connections" option doesn't even work with that pre-installed network icon, so if you mis-typed your password or need to change it, you're out of luck.  Why was this set-up this way? Anyway, I decided to do a little homework and install an actual functioning Network Manager GUI interface that also replaces that useless pre-installed nm-tray icon with networkmanager-applet icon. This way you could change wifi passwords, or even use protonvpn ovpn configuration file or some other vpn ovpn configuration file easily. So here is a quick rundown of what I did.

Open terminal and install these packages one at a time:

Code: [Select]
sudo apt-get install network-manager-gnome
sudo apt-get install network-manager-openvpn
sudo apt-get install network-manager-openvpn-gnome

After installing these packages, I logged out and then logged back in, and that should make the new networkmanager-applet icon appear on the panel bar near the clock. It will appear as if you have two network connection icons. Now we need to turn off the old nm-tray icon, since we don't need it anymore.

Go to Menu-->Preferences-->LXQt Settings-->Sessions Setting-->Autostart
uncheck nm-tray and close out, and then logged out and logged back in and now only the new networkmanager-applet icon should be the only network connection icon showing.

You will now have Advanced Network Configuration option in the menu now too.
Go to Menu-->Preferences-->Advanced Network Configuration

This is where you can make wifi password changes, import your vpn ovpn (such as protonvpn) configuration file, etc. Be sure to use your Openvpn username and password when you are filling in the username and password settings after importing your vpn ovpn file. Also, it may ask you to type a password in order to protect the keyring for the vpn, I just used my Openvpn password since it was easy to remember. Basically, you just import the ovpn file, type in your Openvpn username & password, a window opens asking for a keyring password (just use your openvpn password) and that should be it, I think. Save and close out of Advanced Network Configuration window. Now click on that new network connection icon near the clock, lower right hand side and a little menu should pop up, choose "VPN Connections" and your newly created vpn entry should be there. Just click the square box next to it, and it should connect to your vpn and show a little lock added to the connection icon in the tray. I tested for DNS leaks and didn't find any, so it worked great. To disconnect from vpn, just uncheck that same box next to your vpn entry and it should disconnect.

Hopefully this will help someone out there, I tried to remember each step.
3
Suggestions / Screencopy: a GUI app brings Android screen on your desktop
« Last post by jidan on May 08, 2021, 03:19:43 pm »
I wrote before about scrcpy here: https://forum.sparkylinux.org/index.php/topic,5089.0.html

As scrcpy binaries are included in bullseye repos, there's no need to build them locally, so i packed a simple yad script to simplify the procedure.
Find instructions here: https://github.com/maurosh/screencopy
and a deb file to install here: https://github.com/maurosh/screencopy/blob/main/screencopy_1.0_all.deb

The script is published under GPLv3.
4
Hardware / Re: Acer one 10 s1002 (very simmilar to s1003) 2 in one
« Last post by rpisp on May 08, 2021, 05:47:18 am »
Yes tried pavucontrol first but no luck.

I will post output of those commands when I am at home with the tablet

Thanks
5
Installation / Re: Trying KDE rolling
« Last post by BaukeP on May 07, 2021, 10:48:51 pm »
Sorry for this late reaction.
Thanks a lot. Running perfectly now!

Bauke
6
Newbie questions / Re: Can't install Protonvpn
« Last post by xingjiapeng on May 07, 2021, 03:19:44 pm »
probably you can try to add
Code: [Select]
deb https://repo.protonvpn.com/debian unstable maininto /etc/apt/sources.list or a list file in /etc/apt/sources.list.d/
7
Newbie questions / [Solved] Can't install Protonvpn
« Last post by lonegunmen on May 07, 2021, 01:03:27 am »
I'm using SparkyLinux 5.15 LXQt 64bit version. I went to the Protonvpn website and was using the installation directions here: https://protonvpn.com/support/official-linux-client/

When I went to do step #1
Code: [Select]
wget -q -O - https://repo.protonvpn.com/debian/public_key.asc | sudo apt-key add - it completed correctly.

Then I tried to do step #2
Code: [Select]
sudo add-apt-repository 'deb https://repo.protonvpn.com/debian unstable main' and it gave an error "sudo: add-apt-repository: command not found".

So I installed the package "software-properties-common" via Synaptic and ran the step #2 command again except it ended with this error message:

Code: [Select]
$ sudo add-apt-repository 'deb https://repo.protonvpn.com/debian unstable main'
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 95, in <module>
    sp = SoftwareProperties(options=options)
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 109, in __init__
    self.reload_sourceslist()
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 599, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)   
  File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in get_sources
    (self.id, self.codename))
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Sparky/sid

This is where I'm stuck. It won't add the new repository so I can install protonvpn. I could have sworn I saw the protonvpn-cli app in the APTus program, but I guess I was mistaken because it's not there. Is there anyway to fix this issue, so I can install protonvpn?
8
General discussion / Re: sharing musescore over zoom
« Last post by paxmark1 on May 06, 2021, 02:56:21 pm »
I am just a hobbyist and since you are running the 3.6 version of musescore (which I have never used) I am all out of ideas.  Hopefully others might have some.  peace out 
9
General discussion / Re: sharing musescore over zoom
« Last post by AsusIce on May 06, 2021, 11:47:30 am »
you are correct, that i have changed 2x variables.
The laptop is definitely a lesser version and i was on Win10.
Musescore version is the same on both 3.6.2.548021370.
Musescore plays fine when i run it as the program, it's only when i share over Zoom that it's very distorted.

Code: [Select]
Host: pete-pc Kernel: 4.19.0-16-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.4
  Distro: SparkyLinux 5.14 (Nibiru)
Machine:
  Type: Laptop System: ASUSTeK product: E402NA v: 1.0
  serial: <root required>
  Mobo: ASUSTeK model: E402NA v: 1.0 serial: <root required>
  UEFI: American Megatrends v: E402NA.302 date: 10/07/2016
Battery:
  ID-1: BAT0 charge: 26.6 Wh condition: 27.1/32.2 Wh (84%)
CPU:
  Dual Core: Intel Celeron N3350 type: MCP speed: 2373 MHz
  min/max: 800/2400 MHz
Graphics:
  Device-1: Intel driver: i915 v: kernel
  Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
  resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6)
  v: 4.5 Mesa 18.3.6
Audio:
  Device-1: Intel Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series
  Audio Cluster
  driver: snd_hda_intel
  Sound Server: ALSA v: k4.19.0-16-amd64
Network:
  Device-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet
  driver: r8169
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
  driver: ath9k
Drives:
  Local Storage: total: 29.12 GiB used: 5.03 GiB (17.3%)
Info:
  Processes: 178 Uptime: 7d 19h 44m Memory: 3.72 GiB used: 1.82 GiB (48.8%)
  Shell: bash inxi: 3.0.32
10
Newbie questions / Re: Spectre-Meltdown vulnerabilities.
« Last post by nemomen on May 06, 2021, 11:21:30 am »
Hello paxmark1, hello Sparkers!
thanks for your respond. You are right, I always use stable releases.
Detailed:
On the website for the first code all items are in green, and I have regularly update grub/grub2, so I think, they are correct.
On the website for the second code, I could not find any similar items, like mine.
And I do repeat my statement: only when I run the command as normal user led to the CVE-2018-3640 and CVE-2018-3615 affected results, which are not stated on the websites. Running the command as root, and I always run it as root, never led the other, than clean result.
I do not understand, what would be the reason of the difference of normal user and root in this case.
Care safe!
nemomen

Pages: [1] 2 3 ... 10