SparkyLinux Forums

Software & hardware support => Hardware => Topic started by: nemomen on September 03, 2020, 01:08:40 PM

Title: <SOLVED> Canon Laser Printer i-Sensys LBP7010C does not print.
Post by: nemomen on September 03, 2020, 01:08:40 PM
Hello everybody over there!
I feel so Hannibal ante portas, but nevertheless Rome wins anyway. The question is why?
SW:. SparkyLinux Xfce 5.12 Nibiru Sid.
HW: inxi:
CPU: Dual Core Intel Core i3-3220 (-MT MCP-)
speed/min/max: 1595/1600/3300 MHz Kernel: 4.19.0-10-amd64 x86_64 Up: 2m
Mem: 708.5/7668.1 MiB (9.2%) Procs: 182 Shell: bash 5.0.3 inxi: 3.0.32

Subject: Canon Laser Printer i-Sensys LBP7010C does not print.

The printer works properly under all kind of Windows, but does not print under all kind of Linux distros I had ever tried. The best solution is the solution of SparkyLinux, but the printer does not print. See details.

I do remember to opened a topic on the same subject previously and closed, when I had found on the website of Apple localhost:631 no driver for this printer. In the meantime they had uploaded this driver, but it does not work (at last at me).

Some details and steps have been taken yet.
Any source of the steps are the followings:
▪ Canon LBP 2020/imprimante_canon_capt2 [Wiki ubuntu-fr].html and so on.

▶ Download the driver. Available:
Check thoroughly the Readme file and recommends of Canon. Take your steps if necessary.
The cable is connected, the printer is turned off. Generally be root.
▶ Install the driver.
It is necessary to use the 32-bit driver on 64-bit PC, too. (The 64-bit driver has not been installed by lack of dependencies).
First: install the cndrvcups-common_3.21-1_i386.deb package.
While install by Gdebi the package requires about 75 dependencies to download and install.
Second: install the cndrvcups-capt_2.71-1_i386.deb package.
While install by Gdebi the package requires about 2 dependencies to download and install.
Any of the steps I had taken yet:
▶ Then use the command in terminal ls -l /dev/usb/lp* /dev/bus/usb/*/* to define the output possible: /dev/usb/lp0 and/or /dev/usb/lp1.
▶ Then check data by command sudo usb_printerid /dev/usb/lp0 or /lp1 in terminal.
It would be a similar one: GET_DEVICE_ID string: MFG:Canon;MDL:LBP7010C/7018C;CMD:CAPT;VER:3.0;CLS:PRINTER;DES:Canon LBP7010C/7018C
▶ Then run the command of: sudo /etc/init.d/cups restart
The result would be like that:
[ ok ] Restarting cups (via systemctl): cups.service.
▶ To start CUPS immediately, issue the following command: root (sudo) #systemctl start cups
▶ Then root (sudo) #systemctl enable cups for automatically booting.
▶ Then check the cups by ls /usr/share/cups/model/ | grep CNCUPS
▶ Then register the printer: sudo /usr/sbin/lpadmin -p Canon-LBP7010C-7018C -m CNCUPSLBP7018CCAPTK.ppd -v ccp://localhost:59687
[Some source tells localhost:59787; 59787 -; 59687 -E; 59787 -E and others. None of them works].
▶ Then run sudo /usr/sbin/ccpdadmin -p Canon-LBP7010C-7018C -o /dev/usb/lp1 and/or /lp0
It would be similar like the follows:
CUPS_ConfigPath = /etc/cups/
LOG Path        = None
UI Port         = 59787
Entry Num  : Spooler   : Backend   : FIFO path      : Device Path    : Status