Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Recent posts

#41
Desktops / Re: Plasma Discover issue
Last post by rektal - April 28, 2024, 11:19:15 AM
I am using Muon as an alternative package manager.
The problem is that I use Sparky 8 KDE and I have to use Discover to update flatpak and snap apps.
#42
Desktops / Re: Plasma Discover issue
Last post by Filemon7 - April 28, 2024, 09:57:32 AM
There is alternative of plasma discover its called gnome-software.

Or synaptic manager sudo apt install synaptic-manger or synaptic.

If cannot be fixed use that for flatpak install gnome-software-flatpak for snap gnome-software-snap.

You need to wait for fixed that behavior of sparky.

Try also in synaptic manager force version.

Synaptic->settings->settings->distribution-> force distribution version something like that.

Then apply ok and update.

#43
Desktops / Re: Plasma Discover issue
Last post by rektal - April 28, 2024, 09:09:23 AM
During update via Discover there is an info alert:
System package cannot be removed.
Nie można usunąć pakietu systemowego:

WARNING: You are trying to remove the following essential packages: libapt-pkg6.0 (due to apt) libext2fs2 (due to e2fsprogs)
#44
Desktops / Re: Plasma Discover issue
Last post by rektal - April 28, 2024, 08:40:49 AM
I can confirm that the latest update removed plasma-discover.
Update removes:  plasma-discover plasma-discover-backend-flatpak plasma-discover-backend-fwupd plasma-discover-backend-snap packages. What for?
Następujące pakiety zostaną USUNIĘTE:
  libapt-pkg6.0 libatk-bridge2.0-dev libatk1.0-dev libatspi2.0-dev libcairo2-dev libcdio19 libchafa0
  libcloudproviders-dev libcurl3-gnutls libcurl4 libdb5.3 libdvdread8 libext2fs2 libflac12
  libgdk-pixbuf-2.0-dev libgee-0.8-dev libgeos-c1v5 libgeos3.12.1 libglib2.0-0 libglib2.0-bin libglib2.0-dev
  libglibmm-2.4-1v5 libgtk-3-dev libharfbuzz-dev libhwy1 libiso9660-11 libjson-glib-dev libminizip1
  libpango1.0-dev libpsl5 libreiserfscore0 libtirpc3 libvte-2.91-dev libxt6 packagekit packagekit-tools
  plasma-discover plasma-discover-backend-flatpak plasma-discover-backend-fwupd plasma-discover-backend-snap
  valac
Zostaną zainstalowane następujące NOWE pakiety:
  libabsl20230802 libapt-pkg6.0t64 libcdio19t64 libchafa0t64 libcurl3t64-gnutls libcurl4t64 libdb5.3t64
  libdvdread8t64 libext2fs2t64 libflac12t64 libgeos-c1t64 libgeos3.12.1t64 libglib2.0-0t64
  libglibmm-2.4-1t64 libhwy1t64 libiso9660-11t64 libminizip1t64 libpsl5t64 libreiserfscore0t64 libtirpc3t64
  libxt6t64
Następujące pakiety zostały zatrzymane:
  dwz libbpf1 libelf-dev libzvbi-common master-pdf-editor
Następujące pakiety zostaną zaktualizowane:
  apt apt-utils aptitude aptitude-common bluez-tools btrfs-progs chafa colord curl dconf-cli
  dconf-gsettings-backend dconf-service dvdauthor e2fsprogs flac fuse2fs geoclue-2.0 gir1.2-gdkpixbuf-2.0
  gir1.2-gee-0.8 gir1.2-harfbuzz-0.0 gir1.2-json-1.0 gir1.2-pango-1.0 gir1.2-soup-3.0 git gnome-keyring
  gnome-user-share gstreamer1.0-nice iio-sensor-proxy imv isight-firmware-tools jp2a jwm libaccounts-glib0
  libadwaita-1-0 libaudiofile1 libcolord2 libcolorhug2 libdbus-glib-1-2 libdconf1 libdvdnav4 libenchant-2-2
  libflac++10 libfreexl1 libgav1-1 libgdk-pixbuf-2.0-0 libgdk-pixbuf-xlib-2.0-0 libgdk-pixbuf2.0-0
  libgdk-pixbuf2.0-bin libgee-0.8-2 libgeoclue-2-0 libgeocode-glib-2-0 libgfapi0 libgfrpc0 libgfxdr0
  libglib2.0-dev-bin libgraphene-1.0-0 libgssdp-1.6-0 libgtop-2.0-11 libgupnp-1.6-0 libgupnp-av-1.0-3
  libgupnp-dlna-2.0-4 libgupnp-igd-1.6-0 libgusb2 libharfbuzz-cairo0 libharfbuzz-gobject0 libharfbuzz-icu0
  libharfbuzz-subset0 libharfbuzz0b libinstpatch-1.0-2 libjson-glib-1.0-0 libjxl0.7 liblensfun1 liblqr-1-0
  libmanette-0.2-0 libmbim-glib4 libmbim-proxy libmediaart-2.0-0 libmm-glib0 libnice10 libnotify-bin
  libnotify4 libnsl2 libnss-nisplus liboauth0 libogdi4.1 libpackagekit-glib2-18 libpango-1.0-0
  libpangocairo-1.0-0 libpangoft2-1.0-0 libpangomm-1.4-1v5 libpangoxft-1.0-0 libqmi-glib5 libqmi-proxy
  libqrtr-glib0 libraptor2-0 librest-1.0-0 librsvg2-2 librsvg2-common librttopo1 libsecret-1-0 libsoup-3.0-0
  libvala-0.56-0 libvalacodegen-0.56-0 libvcdinfo0 libwpebackend-fdo-1.0-1 libxaw7 libxfce4util7
  libxfconf-0-3 libxklavier16 libxml++2.6-2v5 libxmu6 mako-notifier modemmanager opensc opensc-pkcs11
  pango1.0-tools python3-apt realmd sshfs tecla valac-bin vcdimager webp-pixbuf-loader x11-apps x11-utils
  x11-xkb-utils x11-xserver-utils xdg-dbus-proxy xfconf xss-lock xterm zenity
132 aktualizowanych, 21 nowo instalowanych, 41 usuwanych i 5 nieaktualizowanych.
Why? Should I stop using spu Sparky upgrade?
#45
Desktops / Re: Plasma Discover issue
Last post by rektal - April 28, 2024, 08:29:50 AM
It didn't help.
I used Timeshift to restore my system but after update Discover fails again.

This happened when I used APTus full update.
When I used APTus safe update system works fine.
#46
Desktops / Re: Plasma Discover issue
Last post by Filemon7 - April 28, 2024, 06:46:35 AM
Simply you need change apt mirror to local one.

You can also write apt --fix-broken install.

Here more info: https://superuser.com/questions/1386209/how-to-solve-this-dependencies-apt-fix-broken-install
#47
Desktops / Re: Plasma Discover issue
Last post by rektal - April 28, 2024, 06:32:26 AM
My system info.
rektal@Sparky:~$ neofetch
                                              rektal@Sparky
          .            `-:-`                  -------------
          .o`      .-///-`                    OS: SparkyLinux 8 (Seven-Sisters) x86_64
        `oo`    .:/++:.                      Kernel: 6.8.7-x64v3-xanmod2
        os+`  -/+++:` ``.........```          Uptime: 28 secs
        /ys+`./+++/-.-::::::----......``      Packages: 3210 (dpkg), 15 (flatpak), 9 (snap)
      `syyo`++o+--::::-::/+++/-``            Shell: bash 5.2.21
      -yyy+.+o+`:/:-:sdmmmmmmmmdy+-`          Resolution: 1920x1080
::-`  :yyy/-oo.-+/`ymho++++++oyhdmdy/`        DE: Plasma 5.27.10
`/yy+-`.syyo`+o..o--h..osyhhddhs+//osyy/`      WM: KWin
  -ydhs+-oyy/.+o.-: ` `  :/::+ydhy+```-os-    Theme: Sparky [Plasma], Fluent-round-dark [GTK2/3]
  .sdddy::syo--/:.    `.:dy+-ohhho    ./:    Icons: [Plasma], breeze-dark [GTK2/3]
    :yddds/:+oo+//:-`- /+ +hy+.shhy:    ``  Terminal: konsole
      `:ydmmdysooooooo-.ss`/yss--oyyo          CPU: Intel i5-10400F (12) @ 4.300GHz
        `./ossyyyyo+:-/oo:.osso- .oys          GPU: NVIDIA GeForce GTX 1650
      ``..-------::////.-oooo/  :so          Memory: 2392MiB / 15850MiB
    `...----::::::::--.`/oooo:    .o:
          ```````    ++o+:`    `:`                                 
                    ./+/-`        `                                 
                  `-:-.
                  ``
#48
Desktops / Re: Plasma Discover issue
Last post by rektal - April 28, 2024, 06:14:49 AM
I tried to install Plasma Discover using APTus but it failed.
Plasma Discover is not installed. This info shows APTus AppCenter.

I think that this issue is related to the latest updates.

Terminal info:
rektal@Sparky:~$ su
Hasło:
root@Sparky:/home/rektal# apt install plasma-discover
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Unsatisfied dependencies:
 plasma-discover : Wymaga: packagekit (>= 1.0)
                  Poleca: software-properties-qt ale nie zostanie zainstalowany
Error: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
root@Sparky:/home/rektal#
#49
Desktops / Plasma Discover issue <Solved>
Last post by rektal - April 28, 2024, 06:04:30 AM
Plasma Discover is not working anymore.
Muon shows that it is virtual package.
It has happened after last updates.

How to fix it?
#50
Sparky applications / Installing GSCAN2PDF
Last post by djringjr - April 15, 2024, 02:40:45 AM
I tried to install gscan2pdf and it will not run and it gives these errors.

INFO - Starting gscan2pdf 2.13.2
INFO - Called with /usr/bin/gscan2pdf --log=/home/djringjr/log-file
INFO - Log level DEBUG
INFO - Using en_US.UTF-8 locale
INFO - Startup LC_NUMERIC C
INFO - Reading config from /home/djringjr/.config/gscan2pdfrc
INFO - Config file version 2
DEBUG - $VAR1 = {};

INFO - Operating system: linux
INFO - DISTRIB_ID=Sparky
DISTRIB_RELEASE=7.3
DISTRIB_CODENAME=Orion-Belt
DISTRIB_DESCRIPTION="SparkyLinux"
INFO - PRETTY_NAME="SparkyLinux 7.3 (Orion-Belt)"
NAME="SparkyLinux"
VERSION_ID="7.3"
VERSION="7.3 (Orion-Belt)"
ID=sparky
ID_LIKE=debian
HOME_URL="https://sparkylinux.org/"
SUPPORT_URL="https://sparkylinux.org/forum/"
BUG_REPORT_URL="https://sourceforge.net/p/sparkylinux/tickets"
VERSION_CODENAME=orion-belt
DEBIAN_CODENAME=bookworm

I tried to report a bug at the given address, even when I'm logged in, I cannot post a bug report.

Regards,

View the most recent posts on the forum