Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Recent posts

#1
Desktops / need help to install wayland o...
Last post by yannig - Today at 06:39:56 PM
Hello,
I got an old 7" toughpad (fz-m1, an i5 rugged tablet), and aim to use it mostly, but not only as a gps. The Gps software (osmand, organic map) are android programs,so i need to install waydroid, so i need to have wayland running.
So could you tell me, the best way to have wayland running on sparky ?
I tried from kde, but gave up the fight. Is it possible from lxqt ?
on my desktop i run sparky with cinnamon and i'm happy with it, so i would be happy not to have to fight excessivelly with new de ...
 as i finally want to make something simple, with some satnav software, librewolf and tor browser, smplayer, and some basic document viewer. And to have it all working fine on a 7" screen (no tiny little boxes to tick or tiny text to read), mostly without a kb.
thanks already
#2
System upgrading / When Upgrading
Last post by Ze_Mind - June 22, 2024, 03:42:26 AM
I ran a update and upgrade, and I get this nasty fellow. And I try to fix it, but, umm..

mind@mind-system:~$ sudo apt upgrade
You might want to run 'apt --fix-broken install' to correct these.
Unsatisfied dependencies:
 libavif16 : Depends: libsvtav1enc1d1 (>= 1.7.0+dfsg) but it is not installed
Error: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
mind@mind-system:~$ sudo apt --fix-broken install
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libcbor0.8          libjavascriptcoregtk-4.1-0  libllvm15     libwebkit2gtk-4.1-0
  libgupnp-igd-1.0-4  libjim0.81                  libunibreak5
Use 'sudo apt autoremove' to remove them.

Installing dependencies:
  libsvtav1enc1d1

Summary:
  Upgrading: 0, Installing: 1, Removing: 0, Not Upgrading: 698
  2 not fully installed or removed.
  Download size: 2,169 kB
  Space needed: 6,918 kB / 849 GB available

Continue? [Y/n] y
Get:1 http://deb.debian.org/debian trixie/main amd64 libsvtav1enc1d1 amd64 1.7.0+dfsg-2+b1 [2,169 kB]
Fetched 2,169 kB in 0s (9,146 kB/s)       
(Reading database ... 203752 files and directories currently installed.)
Preparing to unpack .../libsvtav1enc1d1_1.7.0+dfsg-2+b1_amd64.deb ...
Unpacking libsvtav1enc1d1:amd64 (1.7.0+dfsg-2+b1) ...
dpkg: error processing archive /var/cache/apt/archives/libsvtav1enc1d1_1.7.0+dfsg-2+b1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libSvtAv1Enc.so.1', which is also in package libsvtav1enc1:amd64 2:1.6.0-dmo1
Errors were encountered while processing:
 /var/cache/apt/archives/libsvtav1enc1d1_1.7.0+dfsg-2+b1_amd64.deb
Error: Sub-process /usr/bin/dpkg returned an error code (1)
#3
Sparky applications / Installing Steam
Last post by Ze_Mind - June 22, 2024, 01:22:30 AM
When I go to install Steam, it wants to update, so I do so.

Then I get this error:

.........
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
libc6 is already the newest version (2.38-13).
libegl1 is already the newest version (1.7.0-1+b1).
libegl1 set to manually installed.
libgl1 is already the newest version (1.7.0-1+b1).
libgl1 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libreoffice-common : Breaks: libreoffice-core (< 4:24.2~) but 4:7.4.5-3 is to be installed
 xdg-desktop-portal-kde : Depends: kio but it is not going to be installed
                          Depends: libkf5iconthemes5 (>= 5.102.0~) but it is not going to be installed
                          Depends: libkf5kiocore5 (>= 5.102.0~) but it is not going to be installed
                          Depends: libkf5kiofilewidgets5 (>= 5.102.0~) but it is not going to be installed
                          Depends: libkf5kiogui5 (>= 5.102.0~) but it is not going to be installed
                          Depends: libkf5kiowidgets5 (>= 5.102.0~) but it is not going to be installed
                          Depends: libkf5service-bin but it is not going to be installed
                          Depends: libkf5service5 (>= 5.102.0) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I never had this before..
#4
System upgrading / update CUPS
Last post by spaccabbits - June 21, 2024, 12:41:58 PM
after updating CUPS (SparkyLinux 8) I find this
Stopped cups.service - CUPS Scheduler.
Dependency failed for cups.service - CUPS Scheduler.
cups.service: Job cups.service/start failed with result 'dependency'.
and I lost all the printers
#5
System upgrading / Re: Sparkyy7 Upgrad No login
Last post by Ze_Mind - June 21, 2024, 06:17:49 AM
BUMP.

I'm getting the same issue as him..
#6
Sparky applications / Re: 'APTus AppCenter' not usea...
Last post by pavroo - June 21, 2024, 01:04:28 AM
Looks like it is an issue on some machines, not all, with the latest version of yad 13.0 (or new yad config).
So if you have such issue, please manually download and install (downgrade) yad to 12.3 from sf, for your Sparky version :
https://sourceforge.net/projects/sparkylinux/files/files/yad123/
and let me know does it help, please.
#7
Sparky applications / Re: 'APTus AppCenter' not usea...
Last post by rektal - June 20, 2024, 08:57:27 PM
The issue is the same on default debian kernel and xanmod kernel.
But there is something new too.

There is an output of sparky-aptus-appcenter in terminal.
(zenity:3161): Gtk-WARNING **: 20:50:50.754: Theme parser error: gtk.css:1770:3-26: No property named "-GtkArrow-arrow-scaling"

(zenity:3161): Gtk-WARNING **: 20:50:50.756: Theme parser error: gtk.css:4511:31-35: Junk at end of value for -gtk-icon-shadow

(zenity:3161): Gtk-WARNING **: 20:50:50.756: Theme parser error: gtk.css:4515:31-35: Junk at end of value for -gtk-icon-shadow

(zenity:3161): Gtk-WARNING **: 20:50:50.797: Unable to acquire session bus: Połączenie jest zamknięte
Overriding existing handler for signal 10. Set JSC_SIGNAL_FOR_GC if you want WebKit to use a different signal
#8
Artwork & screenshots / again: i3wm on sparky
Last post by orfeu - June 20, 2024, 02:07:59 PM
Hello,
Like manyroads, I'm a fan of i3wm.  Here is shown a printscreen of my desktop. In XFCE desktop environment the window manager is replaced with i3. So there is still the panel of XFCE i.e. lxpanel. And there are Conkies (five of them). Tell me what you think of it.

link  https://ibb.co/WfRmwPN
   
#9
Artwork & screenshots / Re: i3wm on SparkyLinux
Last post by orfeu - June 20, 2024, 01:36:17 PM
Nice, I really like to use i3 wm
#10
Introduction / Re: Hello from Belgium
Last post by orfeu - June 20, 2024, 12:58:31 PM
Goedemiddag Dirk,
Ik heb dus ook een dual boot met Sparky. Sparky ken ik al langer en het werkt goed.
Wat de Belgische politiek betreft, daar moet een Nederlander beter over zwijgen. Maar we zijn toch lid van Europa? 
groeten,

View the most recent posts on the forum