Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Recent posts

#51
System upgrading / Re: Skype Install / Upgrade 'B...
Last post by duststuff - June 14, 2024, 02:24:07 PM
@Henry1, okay, I understand.

@pavroo, thanks for this information. Once it's removed from APTus, feel free to PM me or leave a note here, and I'll mark this as 'Solved'.
#52
Newbie questions / virtualbox not work
Last post by bertgio - June 14, 2024, 02:21:39 PM
I am newbbie.i have this problem. On sparkylinux 7.4 kde with kernel dowgrade to 5.15.160-sparky-lts-amd64 virtualbox-7.0_7.0.12-159484~Debian~bookworm_amd64.deb does not work as well as virtualbox 7.0.18-162988~Debian~bookworm. The installation ends without errors but when I go to create a virtual machine or add an existing one it starts but stops without giving any signals. Do others have the same problem?
#53
Sparky applications / Re: 'APTus AppCenter' not usea...
Last post by duststuff - June 14, 2024, 02:14:54 PM
Hi, rektal, thanks for the updates. When I run it from the terminal I also get the "Overriding existing handler for signal 10. Set JSC_SIGNAL_FOR_GC if you want WebKit to use a different signal" output, but the GUI still works as expected. One difference is that my system is Sparky 7.x (based on Debian 'stable') whereas yours is Sparky 8.x (based on Debian 'testing', I think). From what I've heard, it's more common for various types of problems to show up in Debian testing when they are updating / upgrading / changing packages, etc., and sometimes these get resolved 'automatically' in a number of days. However, 'AxL' is also on Sparky 8.x and the app is working fine for him, so there must be some difference between your systems.

I did a bit of a search online with the output "Overriding existing handler for signal 10. Set JSC_SIGNAL_FOR_GC if you want WebKit to use a different signal", and it seems to indicate that the problem could be caused by WebKit. So you could check out what webkit-related packages are on your system and if any of those were updated recently, since that might be the source of the problem. If so, you could see if anyone has reported it as a WebKit bug and/or you could look for a way to downgrade to an earlier version of WebKit to see if that works. If you have compositing enabled on your system, you could also try to disable that to see if it solves it (I saw this suggestion in relation to Nvidia graphics cards, along with another idea related to disabling hardware acceleration if that's an option anywhere).

So there's at least some chance that this is not a Sparky bug, although the Sparky developer(s) do control which packages are included in the repos, so if they can confirm there is a problem with one or more packages and downgrade them in the repos, then that would make things easier for you. But it's also possible for you to do a downgrade on your own if you already know how or are willing to learn, although my sense is it's not necessarily an easy process.

So I don't have any easy answers for you, but these ideas should help point you in the right direction.

Also, when you're looking for help on this or other similar forums, it would be good for you to provide as much relevant information as possible. You can use the command-line tool 'inxi' and its various options to generate general / specific / relevant information about your system that you can then copy from the terminal (Shift + Ctrl + C) and paste into your post here using the code markers for easier readability. (Hover over the icons above where you're writing till you see the one marked 'Code', click on that and it should give you code markers like this: "code""/code" except with bracket markers in place of the quote markers. Then just paste the inxi output from the terminal between the code markers so it will show up correctly [you can use the preview option to check it's working as expected].) The 'inxi' tool has lots of different options -- here is just one example:
inxi -Frz(The '-F' option includes basic information for quite a few parts of your system, the '-r' option provides details on your repos, and the '-z' option filters out some things for privacy / security, which is probably a good idea when posting in public spaces like this forum.)
#54
System upgrading / Re: Skype Install / Upgrade 'B...
Last post by pavroo - June 14, 2024, 01:49:16 PM
Due to removed the skype.deb (no updates so far) by MS, it will be removed from APTus soon.
#55
System upgrading / Re: Skype Install / Upgrade 'B...
Last post by Henry1 - June 14, 2024, 11:38:56 AM
Hi Dustin,

I understand the bug you reported in your topic but I was just explaining (personal opinion) why I won't use Snap or Flatpak to download Skype; while upgrading the system yesterday, I got an update for Skype (I opened another topic asking Pavroo) which I don't understand, maybe related to the bug of updating Skype without having its repo enabled (mine is disabled).

Best Regards,

Henry
#56
System upgrading / Re: Skype Install / Upgrade 'B...
Last post by duststuff - June 14, 2024, 10:53:36 AM
Yes, Henry, I understand that, but that is not the bug I'm reporting in this topic. And unless Microsoft changes their policy on this, you may be waiting a long time for a solution that involves a DEB install file for Skype. :-) Cheers, ---Dustin
#57
Sparky applications / Re: 'APTus AppCenter' not usea...
Last post by rektal - June 14, 2024, 05:23:55 AM
Even Timeshift didn't help. APTus is not useable anymore for me.
#58
Sparky applications / Re: 'APTus AppCenter' not usea...
Last post by rektal - June 14, 2024, 04:37:09 AM
Yes. I am sure Dustin.

There is an output of sparky-aptus-appcenter in terminal.

Gtk-Message: 04:34:00.985: Failed to load module "xapp-gtk3-module"
Overriding existing handler for signal 10. Set JSC_SIGNAL_FOR_GC if you want WebKit to use a different signal
Gtk-Message: 04:34:01.187: Failed to load module "xapp-gtk3-module"

I have installed this package but APTus is still a blank page.
Overriding existing handler for signal 10. Set JSC_SIGNAL_FOR_GC if you want WebKit to use a different signal
#59
Installation / /temp/sparky-appcenter/skypefo...
Last post by Henry1 - June 13, 2024, 07:44:40 PM
Hi Pavroo,

Upgrading the system I received an update for Skype but the release is always 8.109.0.209 (the latest stable version for Linux Snap is 8.19.0.201 while the latest might be ready soon 8.120.76.101) ; this is for future updates without Microsoft's deb.files or for not slowing down when looking for updates? Thank you in advance.

Best regards
Henry
#60
System upgrading / Re: Skype Install / Upgrade 'B...
Last post by Henry1 - June 13, 2024, 07:05:42 PM
Hi Dustin,

The problem is that Microsoft has suddenly stopped the deb.files for Skype forcing (typical from Microsoft) users to download via Snap (Linux Mint has blocked by default Snap for privacy and security reasons); I will unistall the old version of Skype's APTus App center and use it via browser waiting for a solution.

Regards
Henry

View the most recent posts on the forum