Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

virtualbox not work

Started by bertgio, June 14, 2024, 02:21:39 PM

Previous topic - Next topic


I am newbbie.i have this problem. On sparkylinux 7.4 kde with kernel dowgrade to 5.15.160-sparky-lts-amd64 virtualbox-7.0_7.0.12-159484~Debian~bookworm_amd64.deb does not work as well as virtualbox 7.0.18-162988~Debian~bookworm. The installation ends without errors but when I go to create a virtual machine or add an existing one it starts but stops without giving any signals. Do others have the same problem?


You could try running it in the terminal to see if it gives any output that would help you understand why it's not working.


Thanks for the suggestion, in the meantime I tried on another PC with SparkyLinux KDE first installation kernel and the result remained the same. The only ISO that can show me the VM desktop is pmagic_2013_02_28_i586.iso. I tried the ISO Parted_Magic_2021.09.15_x64.iso but the result is the same as described in posts n.1. I will try to follow your advice even if I don't know how but I'm sure I can launch a VM from the terminal. Thanks again.


I haven't done this before, but what you want to do is run virtualbox itself from the terminal; once you've done that it should start virtualbox as you are used to and then you can try to do the actions that are not working. After doing those, then you can go back to the terminal to see if there is any related output.

The first thing you need to figure out is what the command is to run virtualbox from the terminal. It may be as simple as 'virtualbox', but sometimes there is some other variation. And sometimes a program is designed so that some operations can be done from the terminal (without a GUI), so you'll need to figure out the command that will start the GUI for you. A simple online search should provide this info, or if you have something like a 'Start' or 'Apps' menu where virtualbox is included, you may be able to right-click on the virtualbox item and choose something like 'Properties' or 'Edit' to see what command it uses to start the program.

View the most recent posts on the forum