Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

'APTus AppCenter' not useable

Started by Linuxuser, June 12, 2024, 10:49:39 PM

Previous topic - Next topic

Linuxuser

You are welcome, rektal! I am pleased to hear that I could help.

Thank you, Dustin, for your reply as well!

QuoteThere are at least some apps that can be installed via the APTus AppCenter that can't be installed via 'apt', 'apt-get', and probably not Synaptic either. You could still find other ways to install these, but I find that the AppCenter makes the process easier.

Well, this would be one point to send a proposal to Pawel & Co.:

Would you like to provide all Sparky users with a robust and simple command-line version of your 'APTus AppCenter', that works for all users who cannot apply your GUI version for any reason; i.e. without necessarily graphical front-end, i.e. not Yad based without "new HTML technology", but even more "lightweight"? This would be great and very helpful.

QuoteInteresting that you also have Nvidia graphics -- the issue might be that combined with a recent update.

If this is the case, then the opensource 'nouveau' driver for Nvidia graphics cards would be to blame for this issue and not Nvidia graphics itself. What I want to say is, even if AxL's system uses Nvidia graphics, but the proprietary driver from Nvidia instead, he might have not encountered this problem. 

I am not yet sure if the nouveau driver is to blame, but one evidence for that would be that, in this context, I have to report another severe bug which I encountered as I first installed Sparky (from Sparky ISO live image 7.3, MinimalGUI i686) last May from an usb stick by means of the "Calamares" Sparky Installer (see icon on live desktop):

As I reached the final step "Install", after I agreed with the point "Summary", to start finally the installation process, the installer's window display suddenly disappeared that I was forced to install the distro on a blind flight! Nothing for the faint-hearted or beginners, I thought! I had to wait about 25 minutes until the installation process finished, in front of a blank window without a progress bar nor any other more information what is going on. This was then my first experience with Sparky. Whew!

Quote(This is off-topic, but I notice from your system info that you have a 'Logitech Webcam C270'. I have that web-cam and it seemed to work fine for awhile but then I started having issues with it disconnecting randomly. Have you ever experienced that?)

Unfortunately, I have not yet tested my webcam with Sparky at my PC since I installed Sparky in May, because I use currently the integrated webcam of my much faster laptop (with i5 64bit CPU and Opensuse Leap 15.5) for all necessary apps which require a webcam.

However, I still will check out the 'Logitech Webcam C270' at my Sparky PC and will let you know if I will have any issues with it. But please be patient, because I do not sit every day at my old PC to check out things with Sparky. I do not know yet which programs I could use for that, perhaps vlc or cheese, because apps like Skype are not worth to be used on a slow old 32bit 'i386' architecture. 


Till soon,

Cheers

Patrick

AxL

Quote from: rektal on June 14, 2024, 02:34:20 PM[....]  I miss removing old kernels with APTus. Now I can't do it anymore.



sudo /usr/lib/sparky-aptus-appcenter/bin/old-kernel-remover


Quote from: rektal on June 14, 2024, 08:16:46 PMI couldn't find which packages are missing. APTus is broken for me now.





Have you tried reinstalling both sparky-aptus-appcenter & sparky-welcome packages yet?

sudo apt --reinstall install sparky-aptus-appcenter sparky-welcome



Quote from: duststuff on June 17, 2024, 10:10:52 AM[....]   It would be interesting to know whether @AxL's system uses non-Nvidia graphics.

Of course, NO Nvidia crapola or Intel:









PS.- I suspect, that both your problem and that of the OP, is due to the graphics card that you use.







Cheers !! 



➤ Want to know how you can use a program you have never used before? "man" will be your best new friend! Type "man <pkg-name>" in a shell.
➤ Or, point your browser to "manpages.debian.org/<pkg-name>" .... RTFM !!!

duststuff

QuoteThank you, Dustin, for your reply as well!
You're welcome, Patrick. :-)

QuoteUnfortunately, I have not yet tested my webcam with Sparky at my PC since I installed Sparky in May, because I use currently the integrated webcam of my much faster laptop (with i5 64bit CPU and Opensuse Leap 15.5) for all necessary apps which require a webcam.

However, I still will check out the 'Logitech Webcam C270' at my Sparky PC and will let you know if I will have any issues with it. But please be patient, because I do not sit every day at my old PC to check out things with Sparky. I do not know yet which programs I could use for that, perhaps vlc or cheese, because apps like Skype are not worth to be used on a slow old 32bit 'i386' architecture.

Understood. Not a problem. In my research thus far, it seems that it could be a kernel-related problem, or it could be because the device isn't getting enough power. I have found that the issue happens less or not at all when I have the device plugged into the back of a desktop PC (i.e. greater power source, I've heard) than when it is plugged into a laptop's USB port. The next thing I'm going to try when I get a chance is to use a powered USB hub -- hopefully that will solve it.

AxL, I appreciate you sharing the extra information on the thread -- perhaps the OP and others will be able to use it to resolve the issue.

AxL

#18
Quote from: duststuff on June 19, 2024, 06:04:05 AM[....]  AxL, I appreciate you sharing the extra information on the thread ...

You're welcome !!


And to be a little more specific:

AMD Ryzen 5 5500U - AMD Radeon RX Vega 7



By the way, I forgot to ask in my previous message to the two users with problems.

 If you use a different theme, than the one you are using (preferably a dark one)
e.g.- Breeze Dark or similar in KDE and Dusk or something equivalent in XFCE

 Does the same thing still happen to you ... ??? 





Cheers !!





➤ Want to know how you can use a program you have never used before? "man" will be your best new friend! Type "man <pkg-name>" in a shell.
➤ Or, point your browser to "manpages.debian.org/<pkg-name>" .... RTFM !!!

Linuxuser

Hi guys,

many thanks to you, AxL, for your additional information about your system and your valuable tips (in your last two posts) to approach this problem, which I will give a trial soon, however presumably not before this weekend.

Quote from: AxL on June 18, 2024, 11:32:30 PMOf course, NO Nvidia crapola or Intel:

BTW, "to be a little more specific": I do NOT use Nvidia "crapola", but Nvidia "GeForce 6200", haha ... little joker!

That you use a 'AMD Ryzen 5 5500U - AMD Radeon RX Vega 7', one can see from your posted system info by 'conky'.

Moreover, I really enjoy your funny animated Emojies in your posts, I sometimes got a real laughing fit, ...
if you would not sometimes insult forum users by them, who don't deserve it.


Until then,

Cheers, Patrick


AxL

Quote from: Linuxuser on June 19, 2024, 11:02:23 PM[....]  one can see from your posted system info by 'conky'.

  Let's see lad.  Because, it seems that you have some visual or reading problem.

The image attached to my previous message clearly shows a ST terminal (aka: Suckless Terminal). Showing the Neofetch output.
So no, it's NOT a Conky

Quote from: Linuxuser on June 19, 2024, 11:02:23 PM[....] if you would not sometimes insult forum users by them, who don't deserve it.

Seriously, are you in good condition, or do you have any kind of problem .... ???   

Because, seeing a few simple .gif smileys as an insult, is the stupidest and most ridiculous thing I've ever heard in my entire life.







 


➤ Want to know how you can use a program you have never used before? "man" will be your best new friend! Type "man <pkg-name>" in a shell.
➤ Or, point your browser to "manpages.debian.org/<pkg-name>" .... RTFM !!!

rektal

Thank you AxL.
sudo apt --reinstall install sparky-aptus-appcenter sparky-welcomeThis is very useful for me.

Sparky-aptus-appcenter have all dependencies. I have got all these files installed.

I have reinstalled  sparky-aptus-appcenter sparky-welcome but with no luck.

pavroo

the image says it is xanmod kernel.
Is the same issue on Debian default kernel?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at [url="//irc.libera.chat"]irc.libera.chat[/url]

AxL

Quote from: rektal on June 20, 2024, 07:45:38 AMThank you AxL.

You're welcome !!

Quote from: rektal on June 20, 2024, 07:45:38 AMsudo apt --reinstall install sparky-aptus-appcenter sparky-welcomeThis is very useful for me.

Glad to help !!

Have you already tried this other option ... ?? that I mentioned in my previous message:

Quote from: AxL on June 19, 2024, 08:05:21 PMIf you use a different theme, than the one you are using (preferably a dark one)
e.g.- Breeze Dark or similar in KDE and Dusk or something equivalent in XFCE

 Does the same thing still happen to you ... ??? 







Cheers !!



➤ Want to know how you can use a program you have never used before? "man" will be your best new friend! Type "man <pkg-name>" in a shell.
➤ Or, point your browser to "manpages.debian.org/<pkg-name>" .... RTFM !!!

rektal

The issue is the same on default debian kernel and xanmod kernel.
But there is something new too.

There is an output of sparky-aptus-appcenter in terminal.
(zenity:3161): Gtk-WARNING **: 20:50:50.754: Theme parser error: gtk.css:1770:3-26: No property named "-GtkArrow-arrow-scaling"

(zenity:3161): Gtk-WARNING **: 20:50:50.756: Theme parser error: gtk.css:4511:31-35: Junk at end of value for -gtk-icon-shadow

(zenity:3161): Gtk-WARNING **: 20:50:50.756: Theme parser error: gtk.css:4515:31-35: Junk at end of value for -gtk-icon-shadow

(zenity:3161): Gtk-WARNING **: 20:50:50.797: Unable to acquire session bus: Połączenie jest zamknięte
Overriding existing handler for signal 10. Set JSC_SIGNAL_FOR_GC if you want WebKit to use a different signal

pavroo

Looks like it is an issue on some machines, not all, with the latest version of yad 13.0 (or new yad config).
So if you have such issue, please manually download and install (downgrade) yad to 12.3 from sf, for your Sparky version :
https://sourceforge.net/projects/sparkylinux/files/files/yad123/
and let me know does it help, please.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at [url="//irc.libera.chat"]irc.libera.chat[/url]

Linuxuser

Quote from: pavroo on June 21, 2024, 01:04:28 AMLooks like it is an issue on some machines, not all, with the latest version of yad 13.0 (or new yad config).
So if you have such issue, please manually download and install (downgrade) yad to 12.3 from sf, for your Sparky version :
https://sourceforge.net/projects/sparkylinux/files/files/yad123/
and let me know does it help, please.

Downgrading Yad does not help, because your software bug was already there with Yad version 12.3!

But I won't bother with it anymore, in any case.


rektal

APTus App Center still doesn't work for me, even after recent updates. All I see is a blank page. But I won't worry about it anymore and I have to get used to it.

View the most recent posts on the forum